Fairphone Open 17.02.0 is now available

My fault. I deleted all data in “Fairphone Updater” now it works. I should have done this before asking you ;-]. Anyway question solved.


Yaaay it worked within the first trial! :slight_smile: :slight_smile:
However, some personal settings were lost, like the Apps that have been idle for some time and the favourites panel (the apps you get when sliding from the right). Where is this info stored?

I had no problem to upgrade via TWRP. No Xposed or GSuite installed.

I’m a bit afraid of updating to a new version.
I installed 17.01.0 (from 16.12.0) and this was already a bit strange.

at first some facts:

  • FP2 - Fairphone Open
  • Xposed installed (Xprivacy, AFWall+, FakeGapps)
  • phone was encrypted before 17.01.0

Strange things happend while installing 17.01.0:

  • Updater was able to download the new build but it showed “Failed to copy file to /cache” after download
  • I downloaded the build manually via code page (https://code.fairphone.com/) and opened/installed it via updater
  • it showed some errors while TWRP performed the update
  • I was happy/surprised that the phone was able to start again

Now the correct/new build number of the installed version is shown (17.01.) under “About phone” menu.
The phone encryption is somehow gone. I absolutly have no idea how this works but currently I will not be aked to type in the encrytion code after turning my phone on and off.

How can I ensure that everything is fine now? I read some threads about that TWRP port for the FP2 is not working with encrypted phone but what would be the best way to proceed and go on installing 17.02.0 now?

Thanks for any advise.

If your device is modified (you flashed anything e.g. Xposed and/or encrypted) the updater usually doesn’t work. Instead you have to download the .zip and install it via TWRP (not via the updater) and re-flash all modifications in TWRP in one go before rebooting.

A more detailed description can be found in the #updateguide for modified Open OS.

1 Like

Thanks. This seems to be the way I have to go ✏ Update Guide for a modified FP Open OS (with Gapps, Xposed and more)
(including installing TWRP Community Port in advance because of the encryption)

I will let you know if everything went fine.

Currently my phone is hanging when I try to boot into TWRP (but I’m still able to boot into the OS). I hope I will be able to somehow start or install the community port of a newer TWRP release using adb/fastboot.

Installed the update via the updater, during following reboot rebooted into TWRP and installed GApps and XPosed. Worked fine with unencrypted FP2.

Perfectly up and running, 17.02 with Xposed, I flashed the zip and in the same session within TWRP also xposed v87, rebooted and it works seamlessly :slight_smile:

OTA update from 17.01 to 17.02 with OpenGApps re-install.
Seems to work fine.

Update went smooth - thanks a lot!

I updated from 16.12 with encrypted data and XPosed, but only flashed XPosed after the update (i.e. within an extra TWRP session). However, I haven’t experienced any bootloop (as I expected from other’s reports with similar setups concerning 17.01)!

I updated to 17.0.2 and the phone starts without issues although I did not flash Xposed and OpenGAPPS again…

This is strange enough… but now I want to have Xposed and OpenGAPPS back, and I can’t seem to flash them.

My Fairphone is encrypted and I see TWRP not being able to mount /data.
So I moved the zips to my external storage and try to flash them from there.

But when I flash OpenGapps: TWRP reboots. And when I flash Xposed, the screen goes black, and I have to force a reboot.

I’d love to disable encryption, but that doesn’t seem to be an option; the settings app doesn’t give such an option.

Did anyone else ever experience this and what do you think is a good path to follow here?

Have a look at https://forum.fairphone.com/t/pencil2-update-guide-for-a-modified-fp-open-os-with-gapps-xposed-and-more/21117.

1 Like

Hey @Lidwien, thanks for the link. I followed those steps. But it doesn’t work…

Following the step in the link you provided:
1) I have the latest zips and (1.7), since my phone is encrypted, I saved them on an external SD
2) I did the update (updater says I am on 17.0.2)
3) Flashing goes wrong (see my first post)

Did you flash Xposed and OpenGAPPS at the same time? (As described in step (3).)

1 Like

I tried both flashing them at the same time and flashing them separately.

Check out this topic:

For the future - especially with encryption - flash all your modifications before rebooting after an update.

Thanks for the Update. I loste the hope that Use of Proximity Sensor Drains the battery will be fixed one day.
Calibrated the sensor with new modem and flashed the old modem afterwards.

I installed FPOSOS [FPOOS : don’t use censorship on my posts @paulakreuzer. I already don’t like it on wikified pages, but on my posts, it’s unacceptable] 17.02, with GravityBox on top, started my script to get external storage writable, rebooted twice in the process, installed back WaveUp, and nope… I lost 50% of the batterie in 5h.

So I uninstalled WaveUp and lost 25% in 10minutes, rebooted and everything want well back.

So it’s not yet fixed.

1 Like

+1 Today I flashed the old (FP2-gms59-1.5.1) modem files on three FP2’s. Is there any statement about Use of Proximity Sensor Drains the battery issue?

1 Like

I succeeded in installing 17.02 but not seamlessly.
I downloaded fp2-sibon-17.02.0-manual-userdebug.zip & open-gapps-arm5.1-pico-20170302.zip on my SD card.
(I did not unzipped any of these files)
Entered TWRP mode
and tried to install both files, but I get unable to mount errors

Then I tried the updater and installed 17.02
and installed openGAPPS in TWRP

it seems to work now