Fairphone Open 16.12.0 is now available

Try to dalete chache - if it not help, try to wipe your Phone and reinstall Fairphone Open.

Well, i don’t want to be the Fairphone Advocat - many bugs are not solved till today, like the nasty
But in you case, i think, the same problem can aslo happen on another Android Smartphone.
If you decide to drive Open Source without Google Service - be ready to bring some patience and knowledge to fix some bugs.

The fastest and simplest would be a full wipe. And fresh Fairphone Open OS Installation afterwards.

Did you remember to change the platform. Xml to make the SD-Card readable?

I already did a wipe cache and dalvik. No change.

I’m living without Google for some years now. Never had such anormal issues even with custom ROMs. Never had any issue in fact. FP2 software is just awful and my patience has a limit. I was the guy saying “give them time to fix things, is fair from us” but look at those unsolved, critical bugs ten months later.

I’ll need to do a clean reinstall if logcat doesn’t show anything clear. Great.

@Friek No microSD here. Thank you @explit and @Friek, this community is the most awesome asset Fairphone has, :slight_smile:


Yes, Roboe, i must agree with you. Smartphone business is not for pussies :slight_smile:
If Fairphone want change the world - they need to hear and work together with the community.
But nothing. I see only - the community is only used for: Tell the world, how good we are!

Fairphone has a good Product, yes. But the Software is a mess smoetimes. Yes, limited resources, limited finances - anything is understable. But what the Fairphone Devs are doing? They make the camera better and change the look of icons?

If you tell how good Fairphone are - you will get warm words.
If you tell critics (and this critics really has a base, i tell nothing, what is not true) - they tell nothing. They simply ignore you.

Come on guys!
Lets solve the most critical bugs, and after that you can make the camera and the icons better.

I really hope, Fairphone Devs will read this conversation

Back to your problem, Roboe: I use SailfishOS as my daily Driver OS, but i also have an installed Fairphone Open as Backup and have a possibility to switch to that if i need.

Tell me, did you tried a full reflash with fastboot?
I mean reflash all the parts of the OS: Modem, Software, kernel, recovery etc.?

This one is the right one:


Much appreciated, @explit. I’ll have some time this night to investigate and solve this mishap. I’ll contact you if needed, :blush:

1 Like

You are absolutely right. That is what I said. The software at its current state is a mess. And doing cosmetics only is the wrong way. Lets see, what the next update brings to us…


Remember that Fairphone promised Android 6 and I can understand when they spend more time on the Marshmallow port and only fix security bugs in Lollipop.


3 posts were split to a new topic: Fairphone and Communication

A post was split to a new topic: Should Fairphone prioritize on fixing Lollipop Bugs or upgrading to Marshmallow?

A post was merged into an existing topic: Fairphone and Communication

Well, I just also stumbled over a similar problem.

Already when downloading files from F-Droid it gives me an error that files can’t be downloaded.
So I downloaded the apk manually and tried to install them. When then attempting to press “install” in the installer, nothing happens, I can only abort the process.

Eventually I was able to install the app via adb, from my computer. Not really an option I was looking for, but at least for now it worked.

That’s another issue. I can install them, but not run them. Actually, I think the package manager doesn’t create properly the Unix user or do not register properly the app’s manifest in the system.

Your F-Droid issue remembers me an issue it suffered on some beta version. Are you on the latest F-Droid?

On the other side, the unresponsiveness of the Install button is probably caused by an screen overlay app. Android has a security “feature” that disables that button to avoid you get tricked by malware. Maybe you have a blue filter or night filter app enabled?


some other apps do use overlays were named is this thread:

1 Like

Good hint. I have been testing such an app in the past days, so that may have triggered the install issue.
Downloading apps from fdroid worked again after some reboots, so maybe nothing wrong actually on my side.

Thanks for the hint!


Hey, I didn’t update you. Reflashing fixed nothing. Thank you for your help, though, :slight_smile:

I’m taking a break of my troublesome FP2 until Marshmallow arrives (and a new workflow of the FP Team, hopefully). I refurbished a Moto G and I’m happily running OmniROM 6.0 + microG on it. In the meantime, the screen module of my FP2 is being used by a familiar of mine, which suddenly saw the left side of their screen not working and it’s waiting for a repair.

1 Like

Hmm, will there be a 17.01, or will it be skipped, as February security fixes is only three days away (probably)

1 Like

Maybe it’ll be skipped in favour of some sweet Marshmallows! :yum:


Coming back to my post. Looks like the reboots were caused by something different:

$ uptime
21:19:34 up 15 days, 12:32, load average: 12.84, 16.38, 28.27
Only quirks with this uptime: it looks like mobile data is more fragile. I have extended times with no signal, where i used to have signal earlier. But this might be something else. Did not want to check as i wanted to work on my uptime. Reboot only with 17.01, or will this be 17.02?