Fairphone Open 16.11.0 release

Fairphone Open 16.11.0 has been released. You can get it through the
updater or by downloading from the website.


Fairphone Open 16.11.0 includes all the security fixes found in Fairphone OS 1.9.3.


  • Security fixes (*) (Android public security bulletin for November)
  • “Checkup”, a hardware diagnostic tool (available under Settings →


(*) Security fixes:

CVE-2012-6702, CVE-2014-9908, CVE-2015-1283, CVE-2015-8963,
CVE-2015-8964, CVE-2016-0718, CVE-2016-2184, CVE-2016-3754,
CVE-2016-3862, CVE-2016-3911, CVE-2016-3912, CVE-2016-5195,
CVE-2016-6136, CVE-2016-6700, CVE-2016-6702, CVE-2016-6703,
CVE-2016-6704, CVE-2016-6705, CVE-2016-6711, CVE-2016-6712,
CVE-2016-6715, CVE-2016-6717, CVE-2016-6719, CVE-2016-6719,
CVE-2016-6720, CVE-2016-6720, CVE-2016-6722, CVE-2016-6723,
CVE-2016-6724, CVE-2016-6725, CVE-2016-6737, CVE-2016-6738,
CVE-2016-6740, CVE-2016-6741, CVE-2016-6742, CVE-2016-6743,
CVE-2016-6745, CVE-2016-6748, CVE-2016-6752, CVE-2016-6828,
CVE-2016-7910, CVE-2016-7911, CVE-2016-7915, CVE-2016-7916


Sadly my update gets in a loop.
I start my phone, then I see the blue Fairphone screen, the white word loading, then optimising Android apps, which is followed by the blue Fairphone screen, the white word loading, then optimising Android apps, which is followed by …

I can stop this behaviour by taking out my battery, but the loop starts again.
The previous update gave me the same loop.
Then I could resolve it by installing Gapps.
Only with this update I want to try to go without Gapps.

I copied the update file on my sd-card
Install update file through TWRP, no success, the loop again
Install update file through TWRP, clear the cache, no success, the loop again
Install update file through TWRP, clear the cache, clear dalvik cache, no success, the loop again

Does anybody know what to do now?

Updated. As expected Battery-drain-bug is still not solved with Fairphone OS 1.9.3 / Fairphone Open 16.11

I need to use the old Modem Files from Fairphone OS 1.5.1 (gms59) or my battery would drain twice as fast.

Maybe some of the Fairphone Devs could tell us, when this problem will be solved?

This Problem exist since Fairphone Open 16.08 / 16.09 / 16.10 and 16.11
Please Devs! Fix this damn bug, that the CPU can go to deep-sleep and not always listening for the proximity sensor.

4 Updates and still no fix! Please, this is very important!


Flash with fastboot. There is a script inside flash.bat/flash.sh which will flash all necessary files.

Take this file:

I would like to do a complete new setup of my phone, as my Win-Computer cannot access the phone anymore. Is it enough to flash the manual-userdebug from TWRP? Then xposed (as with the updates before)?

Update went smoothly, thanks! No problem so far.

Well, doesn’t seem to be my day.
My FP2 power and volume down gets me only to a Fairphone screen nothing else. Even holding down the buttons for seconds makes no difference. So I can’t get to recovery mode.
The separate sd-reader is not found on my Linux computer.
But I am at my friends and he has my old FP1.
I put my sd-card in his Fairphone and connect the FP1 to the computer.
Yes, it is recognised.
I load the manual ota and gapps pico on the sd-card. (if I can’t get it working without gapps, at least gapps is already on the sd-card).
As my sd-card is 32 g, I can unzip the file on the sd-card.
And just as my phone is ready to try to flashboot my FP2 with TWRP, I see the battery is very low.
Thus I have no other option then wait till my battery is full again.

Does anyone self-compile the image and get the same error as me?

frameworks/av/media/libeffects/visualizer/EffectVisualizer.cpp: In function 'int Visualizer_command(effect_handle_t, uint32_t, uint32_t, void*, uint32_t*, void*)':
frameworks/av/media/libeffects/visualizer/EffectVisualizer.cpp:604:49: error: 'MEASUREMENT_COUNT' was not declared in this scope
             *replySize < (sizeof(int32_t) * MEASUREMENT_COUNT)) {
make: *** [out/target/product/FP2/obj/SHARED_LIBRARIES/libvisualizer_intermediates/EffectVisualizer.o] Fehler 1
1 Like

Hello! Same problem… New release enters in a loop “optimising apps”… Just 1h like this… optimising, then restarting, optimising, restarting…

1 Like

Same here…
Tried fairphone updater, flash.sh, wipe dalvik and cache (not possible… unable to mount encrypted partition)

Update went smoothly, thanks!
First I flashed the XPosed framework version 87-sdk22-arm, than I updated to 16.11.0.
No new problem so far. Thanks for providing this update and power to the devs to solve the pending software issues!

That’s how it should be - this is how fastboot mode looks like, which can be entered by pressing Volume down + power buttons. If you want to go to recovery, you need to press Volume up + power button. :wink:

If I in fastboot, then I connect the phone to the computer. And there is goes wrong. The FP 2 isn’t found. But a test with a FP 1 shows me I can connect to the computer. That should mean that the cable I use is oke. So fastboot gets me nowhere on my FP2

By recovery mode you mean TWRP?

Or the stock recovery. Your description just sounded like you were surprised that nothing happens when pressing Volume down + power buttons and like you actually wanted to go to recovery mode. So I just wanted to point out that recovery mode is entered by Volume up + power rather than Volume down + power.

However, now it sounds like you tried to connect to the computer while in fastboot mode. I’m sorry, that this doesn’t work. :worried:

Update smoothly installed with updater.

Carry on and keep up the good work ! :sunny:

With volume down + power button I tried to go in fastboot like is explained fairphone open os install instructions by method 2, but I seem to wrong somewhere.

With volume up + power button I only can go to TWRP.

If your installed recovery is TWRP, then this is of course where you get, when you enter recovery mode, so that’s fine.

As for fastboot, your description sounds like the phone is not recognized by the PC. I’m sorry, I can’t help with that. Has fastboot ever worked before for you?

I never tried fastboot, so I can’t tell if it worked before.

This is a good point (so it’s worth repeating). For Xposed users: you will need to update to framework version 87 (either before the 16.11.0 update, or immediately afterwards). Versions 86 and lower are NOT compatible with the Android November security patches included in this update and will cause a boot loop.

(maybe this is what @Sac and @oviked ran into? Also, if you’re running openGapps, you will also need re-flash those to avoid a boot loop. Note that @Lidwien wants to get rid of Gapps, which is why she’s taking a different route).


I will have to end my effort to go without gapps, because I need my phone working.
Perhaps with the next update I will try another attemp to go without gapps.