Fairphone Open 16.10.0 is now available

I’m also currently using Apkpure and, even though I’m quite happy with it, it would appreciate if someone could confirm it’s safety.

Since the update, I can’t connect my phone to my PC anymore. It only works, if I choose the “Mount SD Card” option, but then I can’t get to the internal storage anymore. Does anybody know what to do?

This usually happens to me when my OpenGApps version doesn’t match. Flashing the latest available version helped every time.

1 Like

Thank you very much, verasiegrid!!! What you recommended, I am shure, I did before, but without success. Today however it worked!:relaxed:

Again, it is better now, but not o.k… F-Droid works, but Google Play Store doesn’t: I can see and choose any of all the apps, but I can’t download or update any of it. The download process starts, runs and runs and runs and ends with an error message: “Download not possible” or something like that. Deleting the cache didn’t help.
On the other side: APKPure works.
Any other suggestions what I could try to get the Play Store running?

I have a cool side effect with the clock problem :grinning:

When I put the phone on flight mode and turn it off when I turn it on again, it can’t connect so can’t get the date right.

Result: I have unlimited lifes on Frozen game :wink: as the game seems to think it’s actually 1970!!!

So some good comes out of this very very annoying bug!


Sadly I have to say that I have frequent reboots since update 16.10

Try to follow this workaround guide: FP2 random reboots - see #rebootsguide for help

You can update the platform.xml in a save way manually from TWRP like described in 4b) of this guide: ✏ Update Guide for a modified FP Open OS (with Gapps, Xposed and more)

Have tested everything listed in that post at least twice without luck. I have now been asked to send back my phone to get it replaced so I guess my phone is a lost cause. Support have really been fast this time so guess they really have worked their way through the backlog which is nice to see :slight_smile:

1 Like

I am back again here without a solution. I tried a lot of things, but nothing successful. Than I asked Fairphone Support and after some vain hints I have got the answer to ask here at the forum:

“For the rest I have to direct you to our forum, see below, as we don’t
officially support open source!
Unless its a problem with the hardware!”

It is obviously difficult to find out the reason for my problem, but therefore I asked the Support for help. The response, quite disappointing!
As I have read here, I am not the only one with this issue, some others are also left on its own with it.

Two ideas strike me:

My experience with this release: I have no problems updating from 16.07.1 to 16.10.0

Hi Antimailer,
thanks for your hints, but unfortunately it didn’t help. At the XPrivacy logs I have found a lot of remarks with the Play Store icon, but not the one you mentioned. Some others possibly suspicious (?):

  • accounts/blockingGetAuthToken
  • android.intend.actionPACKAGE_REMOVED

But I don’t know the meaning of these remarks, unfortunately.

Ok, but I think we move in the right direction:
I recommend that you either temporarily disable XPrivacy for all applications where you can see remarks in the XPrivacy activity log (beside Play Store this could be Google Play Services, Google Services Framework, etc. - I can’t tell you exactly because I haven’t installed Play Store) or maybe better completely disable the XPrivacy module in XPosedInstaller/Module (reboot required).
If Play Store is working then you now that XPrivacy settings are the reason for your problems.

Some more details to the still unsolved issue of downloading apps with Google Play Store:

It also happens with some (but not all) apps at the APKPure store, which are shown as to be updated. Downloads also don’t work with the XPosed Installer, same behavior as with the Play Store. At the F-Droid store I experienced no such problems.

It looks as if the issue has to do with the download process from the Play Store server. The Play Store app is telling, that it does download (an app) and shows a green line, running from left to right, but there is no download icon at the status bar. After some time this process stops an I get an error message , “errorcode 495”. At the Google Help Desk they specify six steps to eliminate the error, I tried it all without success.

Does anybody know a tool, which analyses the download process and does it show at a log file?

I disabled XPrivacy, without success.

I think you have also rebooted afterwards. Unfortunately I have no further ideas.

Yes, I did reboot. Never the less thank you for your backing!

Meanwhile I have updated to version 16.11.0, which went smooth! But the issue is still there, obviously doesn’t depend on the 16.10.0 version. So I like to ask one of the moderators to move the descriptions and contribution of to this issue to a new topic, e.g. ‘Unable to update apps by means of the Google Play Store’. It is unsolved still.

Thank you!

I am still looking for a solutions for the not updating Google Play Store apps at my FP2. A cause for this issue could be, that there is something wrong with my Google account. At this account e.g. there is besides my FP2 another smartphone I never have had or registered anywhere, and I can’t delete this phone. Very strange!
So I intend to delete this account and to open a new one. May be, the Play Store does work with the new one? But because of the new account I would lose some apps I have payed for :frowning:! Does anybody know, whether there is a possibility to transfer payed apps from one account to another and how to do that? Would be very helpful!!!

Fairphone 16.11 is out now: