Fairphone Open 16.10.0 is now available

Yeah I have read the article. Didn’t solve anything for me.

I have sent them a support request but got the answer (after approx. 1 month) to have patience as they are working on a solution.

I don’t know if I want a replacement device. My phone works flawless except the reboots and I am not up for having any other problems that I may get if I get a new one.

I have to admit, this is not the kind of response I would have expected, but at least it seems they are confident in finding a solution. So good luck that this will be fixed soon! :slight_smile:

Me neither but as you say, hopefully the confidence originate from some major advancement on this issue and the random reboots will soon be a memory to all of us having them.

They also ended the email with a promise to get back to me as soon as its solved so I guess waiting is the only thing to do. At least I can use the phone to make calls which is the most important feature of a cellphone :stuck_out_tongue:

last week I called the support in the Netherlands and didn’t have to
wait for half a minute to get a support-member and a solution for a serious problem. So I can recommend calling them instead of mailing. Good luck!

Thank you, freibadschwimmer! I didn’t know, that I don’t need superuser with open OS. Now I have uninstalled it and the binary error message is gone.
But clearing the cache didn’t change anything for play store and F-Droid, unfortunately. And off course the strange version messages at the update screens are still there.

I did my update and followed the update guide (as I did with the lase 2 updates). After restarting, 2-3 apps were GONE. I especially miss my VVS (S-/U-Bahn tickets Stuttgart). I still had the APK on my storage card - but I can’t install ist anymore! Does anybody have a similar expierience?

Thank you for the advice. Will try that next time. Hopefully there won’t be a next time though :stuck_out_tongue:

I did the update and so far it works without problems. The Fairphone Setup Wizard bug (multi-user problem) doesn’t occur any more - thanks for fixing this :slight_smile:

As always, I updated with the manual zip file. No problem so far, it feels stable (ignoring the fatal clock bug…).
Also, it fixed the light sensor lag when turning on the screen, so I’m happy for now. It seems it was just a placebo effect, unfortunately

Hey @Roboe, last time I also installed with the manual zip file, as it wouldn’t work over the air (download okay, restart to install and then booted w/o installing as if nothing happened). However, why do you always do it, what’s the advantage to an OTA update?

I don’t like the Updater app, because it creates a confusing userdata folder on the storage (which in fact is a mistake), and I had bad experiences in the past with my former Nexus 4 storage being wiped out accidentaly via MTP for that reason.

But anyway, I need to have a computer near when I update, because I patch the system with Needle/Tingle for faking signatures, which is needed by microG to impersonate Google Mobile Services.
Besides, I change emojis to the EmojiOne set, increment DPI settings (add ro.sf.lcd_density=430 to build.prop, instead of 480) and apply AdAway adblocker, and I like to make a backup of system and store it on my computer in case anything crash and I need a quick restore.

Yes, I have a complex update procedure, I have to automate this process sometime.

1 Like

Thanks for the insight. It’s a bit similar for me regarding the laptop close during an update, as I’m also always flashing the latest OpenGAPPS and xposed on it. I haven’t really figured out a good backup routine, but your way does make a lot of sense, I guess. And I love the idea regarding the smileys - I’ll certainly have to look into that soon!

1 Like

Thanks for the Update, worked like a charm using the update guide.

Just wanted to let you know that I really appreciate you providing security updates so quickly… Great job, keep up the good work!

With your setup, it seems easy enough. I’d do the following when an update pops out from the Updater:

  1. Download latest Xposed Installer
  2. Download latest OpenGApps package
  3. Download the FP Open update from the Updater (if it’s not possible just to do this, then download the OTA package from the web)
  4. Reboot to recovery (Reboot from the power menu and keep Vol + pressed)
  5. Flash the three zips in a row, first the OTA and then the rest
  6. Reboot and enjoy

You can take a look at this great @freibadschwimmer for further options:

1 Like

It seems this all connects to the SD-card not being writeable. I thought I updated the platform.xml properly, but I had two “” instead of one ". I corrected that, now the app can be reinstalled.
Can the platform.xml be updated from TWRP before the reboot?

1 Like

Glad this worked for you ! You could build a custom .zip to flash from TWRP but the most simple would probably be to backup your platform.xml on your computer as platform.xml and write a small script that does the following :

adb shell cp /system/etc/permissions/platform.xml /storage/sdcard0/permissions.xml
adb remount
adb push platform.xml /system/etc/permissions/platform.xml

And run it from your computer each time you upgrade. Another way would be to use a shell script on the phone (that could actually be fun oneliner using sed).

The first line allows for backup of your platform.xml at the root of your internal storage, thus it’s not exactly mandatory

1 Like

Beware of file permissions. You may need to run adb shell chmod 644 /system/etc/permissions/platform.xml

That’s pretty easy, in fact. More docs here.

1 Like

The update to FP Open 16.10.0 went smoothly for me (my phone is encrypted, does not have the Google apps, or the Xposed framework).

1 Like

plain build in updater user - no real trouble during the update - just no real “visible results” - I do get the reported “clock time error” and I still have trouble with the calendar. It would help me a lot to know at least where to pose that kind of question - as apparently that place is not here on the forum.
[no random reboots so far, so the wrong time setting isn’t causing trouble - yet]

This two strange screens at the update module are gone and it looks o. k. now. But I didn’t change anything to get it right. Quite mysterious, this change!