Fairphone Open 16.10.0 is now available

On my Fairphone I see Your current operating system version Fairphone Open 16.10.0

Have experienced more reboots since the update. Now its so often that the phone is almost unusable… :frowning:

Findings after a few of days:

  • Proximity sensor: OK

  • GPS location: Icon is after enable and disable still there.

  • Display auto backlight: changes slow

  • Screen flickering after boot up: from time to time still there

  • FP Open OS: Clock resets after reboot: still there

  • Random reboots: seems to be gone

  • Battery only charging mode: does no longer work on a notebook usb port with max 0.5A.

Summary: Feels more stable - thanks a lot!

I also have constant reboots at least 3 or 4 times a day, but strangely already for one week or so, meaning: I don’t have 16.10 installed yet but it appeared with 16.09, and not from the beginning. If it’s the same root cause for you and me, maybe it’s not 16.10?
I thought, maybe it has something to do with xposed modules? At least my reboots more or less appeared after trying out gravity box, youtube adaway and nify. I don’t remember any other major changes. Do you use any of those?
My device is encrypted, with openGAPPS
I’m thinking about a factory reset, because as you write: the device is almost unusable when it reboots randomly, no matter if it’s in usage or not. Any ideas and help is welcome.

I am observing this since 16.09. Not dramatic, but annoying when you have to wait until you can actually read the screen outside.


The Problem with no deep sleep and battery drain after updating to Fairphone Open 16.08/16.09/16.10 is finaly solved.
Well its not bugfixed but i found an workaround:

You need old Modem Firmware Images, which was unfortunately not included in Fairpohone Open 16.07 but i found them in the package:

You need to flash all Modem Files from this Firmware Package.
Your Android System and Recovery will remain the installed one.
That means, you can use the latest Fairphone Open or GMS.
Only the Modem Files will remain the old, which don’t have this bug.

For all people, who is not so familiar with fastboot - they can contact me and i will give them my special update package which include all the necessary files which will be flashed with the script from
Windows / Linux.

In the end you will have Fairphone Open 16.07 with the modem Images from 16.07 and earlier. My standby time is 24h instead of 12h.


While i think that’s a great investigation and might help fp engineers alot, i wouldn’t downgrade my phone to that state of the software because of all those security fixes… There have been a lot of them since 16.07, and substantial ones


The system.img can remain the actual (Latest Fairphone Open or GMS)
Only the Firmware files need to be flashed from the old Version.

Update went smooth as always.

But despite it shouldn’t, TWRP still showed the message, that /misc and /bootselect were not found… strange.

Some more strange behaviour, which started with installing a second SIM (?) at the open version 16.09.0:
I can’t install any Play Store apps. I can see it all, but it’s not possible to download. It starts the download process, but never finishes it.
On the other side when I try to download an app from F-Droid I always get an error “F-Droid ist abgestürzt” at the first run. When I try it a second time, it works.
And just after starting the phone I always get a message “Die Su-Binärdatei ist veraltet”. I have installed the F-Droid superuser, version Because of this message I flashed the 'Update-SuperSU-V2.46.zip via TWRP. But it didn’t change anything.

Helpful (?) information via the app ‘root verifier’:
BUSYBOX INSTALLED: BusyBox v1.24.2-meefik (2016-04-18 08:44:40 BST) multi-call binary.
DEVICE: Fairphone FP2

It would be great, if anybody could give me a hint to find out what is wrong with my phone!

Did you upgrade from 16.09, or from an earlier version?

The fix for this is in the recovery system, and the previous version of recovery is running when installing the update. The messages will not appear when booting into recovery after installing this version.

1 Like

Not sure what you were trying to achieve, but you neither need to install any su binaries nor a su manager, since open os is rooted by default (can be activated in the developer settings).
As for the installation problems, you could try to clear the cache of the play store and of fdroid.


I don’t think we have the same problem. I have it no matter what OS and version I use. I have tested all the latest FP OS- and FP open OS-versions aswell as Sailfish OS and have frequent random reboots when screen is on using all of them. I don’t use xposed or openGAPPS and my phone is not encrypted.

For me no factory reset or clean installs have removed the problem… :confused:

I have had this problem since day 1…

Doesn’t sound good. Did you have a look at this article?

Personally I would contact support and ask for a replacement, if all possible workarounds didn’t help.


I edited my Post a bit. Old System.img from 16.07 is not necessary anymore to fix the battery drain bug

Yeah I have read the article. Didn’t solve anything for me.

I have sent them a support request but got the answer (after approx. 1 month) to have patience as they are working on a solution.

I don’t know if I want a replacement device. My phone works flawless except the reboots and I am not up for having any other problems that I may get if I get a new one.

I have to admit, this is not the kind of response I would have expected, but at least it seems they are confident in finding a solution. So good luck that this will be fixed soon! :slight_smile:

Me neither but as you say, hopefully the confidence originate from some major advancement on this issue and the random reboots will soon be a memory to all of us having them.

They also ended the email with a promise to get back to me as soon as its solved so I guess waiting is the only thing to do. At least I can use the phone to make calls which is the most important feature of a cellphone :stuck_out_tongue:

last week I called the support in the Netherlands and didn’t have to
wait for half a minute to get a support-member and a solution for a serious problem. So I can recommend calling them instead of mailing. Good luck!