Fairphone Open 16.09.0 is now available

Updated without problem.
Did see a glitch in the lockscreen when drawing my pattern: the screen was split in multiple squares that were all flickering randomly as I was moving my finger. Did it twice and then went back to normal :slight_smile:

1 Like

After a very quick scan of the updater source code, I didn’t find any reference to that path… But I can see the same behavior on my device…
So now I have tried deleting the folder and as soon as I have opened the Updater app, the folder was recreated.
Also a funny thing is, that the are creating storage/emulated/0/updater/ AND updater/ in the internal storage :wink:
Debugging the updater is hard because it’s install as a system app that not even TitaniumBackup can uninstall apparently :rolling_eyes:
Okay, I finally uninstalled the updater with (in the phone shell): mv /system/priv-app/FairphoneUpdater/FairphoneUpdater.apk /system/priv-app/FairphoneUpdater/FairphoneUpdater.apk.bak; sync; reboot
I think I found something… The line final File externalStoragePublicDirectory = Environment.getExternalStoragePublicDirectory(Environment.getExternalStorageDirectory() + resources.getString(R.string.updaterFolder)); gets the path /storage/emulated/0/storage/emulated/0/updater
I think the programmer didn’t quite understand the method getExternalStoragePublicDirectory (see here for documentation about that method), basically you give it a constant pre-defined like Environment.DIRECTORY_PICTURES and not your own string…
So apparently I fixed it (at least that folder doesn’t get created but I am not 100% the OTA is still working…^^) (btw why am I fixing bugs for Fairphone in my freetime? :nerd:)


Worked smoothly, thanks!

Because you are a good guy, :wink:

I thought the problem would be something similar, but didn’t have the spare time (nor I was in the mood, honestly) to dive into the Java (ugh) code myself. Thank you so much!

Hope they fix it in the next release, now that they have your contribution, :slight_smile:

PD: you could had change the package signature in build.gradle to avoid the need of uninstalling the original one, :wink:


Just make sure the devs learn about this fix :wink:

1 Like

Today I actually tried for the first time to follow and thus test the FPOOS update guide.

Basically it worked fine, except for that I didn’t manage to use ADB in TWRP:

At some point during the EFCT16 I also ran into this. I wrote a post on authorising from within TWRP - though this will likely only work if the phone isn’t encrypted. It could be that if your device is encrypted that the file with the authorisation signatures isn’t readable when in TWRP, causing no authorisations to be available. Sorry if seems a stupid explanation - I’m not that aware of how this whole Android thing is designed to work.


Possible. My phone is encrypted and TWRP (in the version/modification FP uses) indeed cannot handle encrypted /data partitions.

Just changing the package id didn’t work, the app just crashed on startup… And my custom built Updater (also without changes) also doesn’t work because it fails with some error message, that /cache/fp_update_.zip is not found. Maybe that happens because the app is installed as a normal user app instead of a system-privileged app (dunno how to actually properly develop system-privileged apps on Android…)

Probably. A normal app cannot access /cache like that, AFAIK

Well they have implemented a check if they are a priviliged app and otherwise use a superuser library for doing things.

1 Like

Hi there everybody,
maybe I found a bug today concerning Truephone.
Since 3 days I am running FOS 16.09.0 installed by the Fairphone updater without any special configuration, rooted. But I got Truephone installed since months. With previous FOS-versions I used truephone and the build-in phone app simultaneously as I still did until today. Today I reused the “left desktop” with “letzter Kontakt” and “am häufigsten kontaktiert” since a long time. I can’t call any of the contacts there with both sim. When trying to call after choosing one of my two sim it says “Anruf nicht verbunden”. Same result when using “Kontakte”.

Anybody else with the same problem?
Do I have to uninstall truephone?

Have a blessed sunday

If you are interested, I have uploaded the patch to my personal GitHub: https://github.com/z3ntu/FairphoneUpdater/commit/01cb543cc212d7c0c8a8a761ef226583edc298af . I’ll try to submit the patch to the Gerrit instance for Fairphone (but the Google login is currently broken so I can’t log in)

1 Like

When the choose SIM dialogue comes up, try waiting a little longer before choosing a SIM card. Five seconds should do it, though I recall someone mentioning they had to wait a little longer. See also the topic over here or Fairphone support’s software issue report.

1 Like

Yeah, I agree, hence: @anon12454812 Have you recognized @z3ntu’s post? :wink:

@moderators: It might make sense to split @Roboe’s and @z3ntu’s bugfix discussion to a new thread?!

1 Like

Thanks, Johannes for answering.
Since I know the Two-SIM-Bug I always wait for the return of the dialogue after it disappeared.This is not my problem.

The build-in phone app doesn’t work any more for phone calls. This is the point.

Did you try to deactivate or temporarily uninstall your third party phone app?
This way you could check if your problem is caused by a conflict of the two apps.

For me also the update worked flawlessly. Encrypted, opengapps and exposed module. This time i even remembered in time to get the up-to-date version of opengapps beforehand :slight_smile:
Unfortunately, the issue with the proximity sensor (no deep sleep if used) isn’t fixed. But one probably couldn’t expect it this fast :wink:

Did you reset the proximity sensor?
Go to 'Settings’
scroll down to 'Maintenance’
and tab on “Proximity sensor”

Update seems fine.
But again something happened while updating which I already had several times: Automated updates pop up, I say install, it dls the files and then is stuck in a waiting loop. Killing the updater works sometimes, this time I had to restart the phone because it was completely stuck. Restarting the whole process once or twices does the trick.

If this issue is already known and mentioned somewhere just ignore this. Otherwise I just wanted to mention it, doesn’t seem to to a lot of harm, though.