Fairphone forum doesnt work in Opera Mini, Lightning AND FP standard browser

It works for me on all browsers I tried lately (standard Lineage OS browser, standard /e/ browser, Lightning and many FF variants). Though I do remember some issue with Lightning and the login page not loading (until the nth try) a while ago.

First thing that comes to my mind: What’s that do-not-enter-symbol notification in your status bar? Do you have some firewall or similar running?

Hi Paula

Thank you for your swift reply. Thought as much. It did work before my phone decided to reset on its own as described in my Thailand-Post update.

That symbol is the “Do not disturb” as seen in the bottom left of the screenshot below. Standard feature to make the phone not vibrate for every message you get.

1 Like

The forum also doesn’t work in Habit Browser for Android.

Curiously, it does work in links and lynx. However, in Firefox, it outright refuses to load unless JavaScript is enabled; very bad practice, in my opinion.

Forum in Lightning browser is always working for me. Did you try to clear all available caches (browser caches, app caches…), even though they should be clear after what has happened to your phone :hushed:?

I tried loading the forum in Lightning with Java Script disabled. Doesn’t work.
With JS enabled - no problem.

1 Like

You haven’t told us a crucial detail: Your Fairphone OS version / Android version. The standard browser, Lightning and probably Opera Mini depend on Android’s built in browser engine.

When the browser (engine) gets outdated websites refuse to connect. Recently TLS 1.1 and below were deprecated and that’s why users must upgrade for secure connections.

If you are on an older version of Fairphone OS, this might apply for you too: ✏ Constructive tips for improved security for the FP1(U) Anyway, FP2 users are lucky because their phone’s software is still well-supported (yeah, I know, Android 7 is overdue) and can upgrade. You should always use the latest software version.

You can upgrade using the Fairphone Updater app.


In the mentioned Thailand SIM Card for Data post you’ll find at least some details:
It’s a FP2 with new camera model (and it had worked before the uninteded “factory reset”)… :sunglasses:

I updated my post to include more background information.

I followed your hint and had Lightning delete all caches.

Also, as suggested by s99h, I checked if javascript is enabled. It is.

Still, I only get the burger menu as seen inn the screenshot…

I will use Opera for writing on the forum for now. Still I am a bit sad because before the big rebootening it just worked, just like any other website…

1 Like

I am having the same issue since some weeks. There was no apparent update, nor crash. It just did not work suddenly with Lightning
The forum web site cannot be loaded with Lightning (which I like because of its speed and usability) nor DuckDuckGo (which I like because of its hints to privacy issues such as guhgel analytics).
It only works with IceCatMobile (a Firefox fork) where I had to deactivate under “Extras > Add-ons” GNU LibreJS, which prevents the execution of non-free, non-trivial javascript.

I have never encountered any Forum issues with Android Firefox, but only as a reader not being logged in.
The lack of not being logged in is not related to troubles, but to my principle of not sharing more personal data on my phone as needed. (Therefore I still prefer to use a conventional computer.)

I assume JS is active, but even ublock does not cause troubles with the Forum.

Same issue on my FP2 with Lightning (FPOOS 18.04.1). I remember it used to work some time ago, but cannot say when. Let’s hope Android 7 solves the issue (and comes soon).

Are you also using FPOOS 18.04.1 (as @Freiton and @technorati)?

The forum software makes heavy use of JavaScript and might require a modern browser. Lightning uses the browser integrated into the system, that is not updated and quite old if you do not use Google Play. Do you have Google Play installed? If so, check the version of Android System WebView.
Opera Mini on the other hand does not have support for many recent web technologies.

I would recommend Firefox. Works well for me.


Since I am an Opera user since the early nineties, I’ll keep using Opera Browser (not mini) for now. I wish they’d bring the presto engine back, though, but thats a completely different Topic :slight_smile:

Yes, I am using Fairphone Open 18.04.1.
I realized that also the built-in Browser does not work, so it might be an issue of the Android integrated web engine (I forgot the name).
Mmmh, actually I just tried Firefox Klar, it does not work either, even by de-activating the privacy protections.
Next trial: FFUpdater (from F-Droid) to install Firefox (63). That works.
IceCatMobile is a fork of Firefox and does not work (in version 52,6).

So maybe it is a combined issue of features not being supported by the old Android rendering engine and new features of the forum which violate privacy settings of very secure browsers (like Duckduckgo, Firefox Klar and IceCatMobile).

I will use Firefox for now and investigate further in the direction of tracking by the fairphone forum.

1 Like

Privacy and security are two completely different things. A privacy-aware browser can be completely outdated and thus insecure.

Wikipedia says:

On Android, it has been using the Blink engine in version 6.x or earlier, and GeckoView since version 7.0.

F-Droid says the current version is 6.1.1 so the F-Droid version still uses Blink, which is also used by Google Chrome and is the default in Android:

In currently supported versions of the Android operating system (since version 4.4) the WebView component is based on Blink instead of WebKit.


PS.: Android 7 will of course also update the WebView component on your FP2. The browsers that rely on it should then work again.


I know. I just prefer to keep things simple for those who are not sufficiently deep into all the issues one is running into when using the internet, phone or just walking the streets (especially in China and the UK - never saw that many observation cameras elsewhere). Anyway, you got my message apparently.

2nd anyway, Lightning is working again with Android 7.

1 Like

Do you have the latest version of Klar installed? It should use the same rendering engine as Firefox. It tested it and it works well for me with Firefox Klar/Focus.

1 Like

After the Android 7 update the Forum works again using Lightning. These lines are typed on my FP2 :grinning: