Fairphone does not charge

Hi, I am having some trouble with my F3, as it won’t charge anymore. The light would not switch on which I connect the cable. When I connect it to my laptop I would get the overvoltage message. I tried different things, I read all the posts in this forum regarding similar issues and tried different workarounds, I cleaned the USB port with a small needle and a toothpick, tried different chargers (by the way the official F3 charger never worked), restarted the phone, did a complete reset of the internal memory, I even bought a new battery, but all no to avail. My guess really is that the bottom module is damaged, but what can I possbly do to verify that and is there a way to replace it? The F3 is 3 years old.
Any help is greatly appreciated,
Best
Jan

Hi and welcome to the forum.

You may find a fairphoneangels near you that has a spare bottom module you can try.

2 Likes

Welcome to the Fairphone community.

Because of the modular design of the FP3, the port can be exchanged. But unfortunately, it is not in stock right now:

Mid August, the augurs say, it might be back on shelf.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.