Fairphone 4 wifi connection

The wifi keeps disconnecting on my home wifi network. It drops off and doesn’t reconnect until I go into the wifi settings/selection, when the connection refreshes. Can anyone offer suggestions on this please? To ensure I have connection I’ve left data on and have ended up using up my 12GB data allowance the past 2 months, so it’s not a long term solution.

I’ve seen for older FP topics that suggest rebooting in safe mode and manually changing from 5GHz to 2.4GHz frequency, but that option doesn’t seem available in FP4 safe mode, and again wouldn’t expect this to be a problem on a new phone

2 Likes

If you have select automatic then it can switch between 2.4 and 5

You may also have auto on Wi&Fi or network.

Ensure either 2.4 or 5 is not on automatic

As you are home disable data on your sim too.

Maybe let’s rule out the WiFi network first. Could you download this app? There you can see how busy your networks are. This is mostly an issue with 2.4GHz because it has only a few channels, which also overlap. So interference is usually high. 5GHz has way more channels, but the higher frequency is easier blocked by walls.

Which phone did you have previously? That device really had no issues? Did anything change in your network or house? More devices or maybe new obstacles which could reflect radio signals? For the time I did have a FP4, I didn’t experience issues with WiFi.

Off topic, but worth mentioning. The best solution to this would be WiFi-6, which has overcome many of these instabilities. FP4 doesn’t have WiFi-6 :frowning:

Thanks both for the replies.

@amoun unclear on your suggestions, but I’m set to auto connect to this network. I’ve only seen it on 2.4 a small number of times, it’s mostly on 5. Even if I boot up in safe mode it doesn’t seem I can set this to one or the other.

@UPPERCASE I have a network monitor and there are some lower demand devices, but it hasn’t been a problem on Sony ZX1 Compact, Samsung S10, then Samsung S8, plus iPhone 6S work phone. No change in network or living space: same rooms and layouts, 3 wifi extenders in a single-story flat, never more than 3-4 metres from one.

2 Likes

I had the same problem. Weird thing was, the guest network (Fritz-Box) worked fine. Only differences I could make out were the IP-address and the Pi-hole/DNS.
For testing I just set back the router as DNS and it works. Doing without Ph-hole can only be a temporary option though.

1 Like

The 2.4 has to not be on auto.

Maybe you should check in the Pi-hole logs what’s denied for the FP4 device. One of these deny events should make the difference…

1 Like

Thanks for the screengrab - much clearer. Tried this and thought it was working, but didn’t take long for same issue to arise.

1 Like

Having the same issue on my fp4. My old Samsung Galaxy Note 10 had no issues at all with the WiFi Connection and when I switched to the FP it always loses Connection and reconnect sometimes takes 3 minutes. I didnt change any setting on my Fritzbox 7490.

1 Like

Similar experience - FP4 loses Wifi connection often, even though all other devices have no issue. It’s quite quick to reconnect, but of course it’s quite annoying.

I think the router supports both 5GHZ and 2.4GHZ on the same SSID - might have to turn off 2.4 to see. But it’s annoying that a new device would have such issues :pensive:

1 Like

Just give each a dif SSID

Mine are Fritz2_4 and Fritz5

You can give each a dif password too maybe.

When I’m home I only use 5G and sometimes, when I’m out I have to select 2.4 to use third party Wi-Fi :blush:

I guess I will have to split my Wifi indeed, but I don’t understand why the FP4 specifically has this issue (and none of the other devices at home). Seems to me like a software bug - is there is a channel to raise issues and tickets?

It’s an A11 design, not really a bug, though it does bug some people.
There is already a feature request via the FP3 beta world to bring back a simple ‘switch’ select 2.4 or 5

However I suppose that given I can select which I want at home by using dif SSIDs maybe it’s not going to present a problem when I am out as by design A11 should pick up the best signal. I.e it will select 5Ghz if available 2.4Ghz if not.

And presumably if the 5GHz signal is weak it will switch to 2.4Ghz

However having the option to decide would be more comforting to me.

As the FP3 has just been updated to Android 11 the same issue has now arrived there, as mentioned.

2 Likes

@amoun : I experience this problem on a daily basis (both at home and when I am on my way). I believe you when you say it is A11 design but, given android’s dominance in the smart phone market, I expected to find a lot about this on the internet. However, I seem to fail finding much information about it. Can you share pointers to sources about this A11 design decision?

I know multiple people running Android 11 on a non-FP device, but they do not seem to be affected by this. Do manufacturers like Samsung perhaps patch Android or something?

Additionally (and probably related to my earlier search failure), I fail to find whether A12 follows the same ‘design principle’. Do you happen to know that?

Are you referring to the above?

My wifi router uses the same SSID for 2.4 a 5 GHz and I’ve never observed this connection problem on FP4. Whether the phone connects to 2.4 or 5 seems a bit random, I even see it switching between them when having the phone on a table in the same room where the AP is. But I never observe any downtime when using the phone.

My router is Turris Omnia running OpenWRT 19.07.

1 Like

Yes that is the ideal setup and outcome, sadly, for some it is not optimum.

Thanks for your input :slight_smile:

Yes I am.

I experience this with an Ubiquiti Unifi Dream Machine. I know I can simply divide the networks with it (or add an additional network), but I do not control all routers I encounter when away from home.

2 Likes