Fairphone 4 camera not working

Hello everyone,
Camera shows black screen then exits by itself! It did work last week
I’ve tried safe mode, 3rd party camera app, I uninstalled the latest apps, turn off then on again: nothing works.
I contacted support today, but in the meantime, maybe someone here can provide suggestion? Apart from resetting everything, which I would NOT want to do. I spent so much time to set up all parameters and apps.
Thank you for your advice.

Have you tried entering the internal Test menu and performing the camera tests? What do you see if you do that? Are all 3 cameras affected?

To open the menu enter *#*#2886#*#* in your dialer app, click on the MANU button, and select the camera test.

In case one of the cameras doesn’t work via this test either, you could try removing the corresponding module, cleaning the contacts, and reinserting it into the phone to see if that makes a difference.

1 Like

Thanks for your suggestion. Unfortunately, test fail, front, main and superwide cameras, all failed!! Camera Led ok. I don’t know what camera OTP is, checked, it says: ok.
I don’t understand, I bought it new, from September!
Any other suggestion?
Thank you!

That’s curious. It’s likely not an issue with the connection then, as the front and back cameras are located in separate modules (which of course doesn’t mean you can’t still try to troubleshoot by removing and reinserting both.)

Which OS version are you currently running? Did anything specific happen shortly before the issue appeared (e.g. system update, dropped phone, etc.)?

Thank you for your answer. I’m not a photo addict, but it does help me sometimes for work, and I’m quite frustrated. I just don’t get it, is it possible that some security parameters did block my camera? I did not authorize position for camera, that’s the only unauthorized parameter.
I forgot to say that I have a new simcard, Faiphoen tutorials did suggest that maybe simcard issue. Well, it’s not.

Sorry I missed the rest of your questions.
Android 12. No phone dropping, I had the last update when I bought it in September 2023.

I’m pretty sure its not a permission issue. The internal test I had you perform earlier shouldn’t be affected by that.

Do you have an external SD-Card inserted into your phone? And if so how is it formatted?

Well, sometimes something can go wrong in production. Better that than having it fail a year in I guess. At least you won’t have any issues getting free replacements if necessary.
If its not an issue with the camera modules but some other hardware thats causing the issue you might have to bite the sour apple and perform a factory reset though. Fairphone support can usually only work on phones that have been reset for privacy reasons, if you don’t perform the repair yourself.

I do not believe your issue is caused by stock software or settings. I’m also running the latest FPOS on my FP4 and do not experience any camera issues at the moment, and since you’ve already tried alternate camera apps that one’s not the cause either. If you don’t want to perform a factory reset you can still try iteratively uninstalling apps, but I honestly find it hard to believe the issue as you describe it is rooted in software (- although it is of course hard for me to tell without knowing your setup).

I’d suggest you perform a full backup first (just in case) and then try removing/reinserting both cameras. If that doesn’t help you could see if there’s a Fairphone Angel with a FP4 in your area, that’s willing to meet up and swap cameras with you for testing purposes. That way you can tell if its the camera modules or something else (e.g. the core module) thats causing the issue. In case their camera modules work on your device - great, get some new camera modules. In case their camera modules do not work on your device, but yours work on the other one, I’m afraid the next step would be a factory reset to exclude software issues caused by your setup, before getting a core module replacement from Fairphone Support.

WOW, THANK YOU @AndreasChris for your answer!
1- I don’t have an inserted sd card.
2- I’ll try your suggestions, maybe you’re right, maybe I’ll have to reset it. I’m not sure I’ll find a French FP Angel around me!
Can you tell me how to perform a factory reset? If I have to, then I can only do this mid October,
What I really don’t understand is: how come it worked last week? Front and back when I tried them, and now, it’s “Back to Black”!
Thank you

I forgot to mention something, don’t know its relevance. I did put a small dark tape on front camera (just being careful). I took it off when back cameras didn’t work.
I wonder now if that may have played a part in the issue?

There’s a Fairphone support article on how to perfrom a factory reset:

You can lookup the rough locations of Fairphone Angels here:
https://angels.fairphone.community/

There’s always the possibility of some loose soldering joint that finally broke due to some vibration. These things can sometimes happen - and that’s what warranty is for.

Happy to help. Good Luck. :slight_smile:

As long as you put it on the outside of the display and didn’t perform the test while it was still on, I don’t think that caused the issue. :smiley:

Thank you for everything @AndreasChris

1 Like

Hi @AndreasChris , just to let you know, I’ve solved my issue. By being too careful I just blocked all access to my camera!!
I apologize to all who have followed this topic, it’s really all my fault!
That said, maybe it’s better to be careful than sorry, to be protected than naked.
Have a wonderful day

2 Likes

If you don’t mind me asking: How exactly did you manage to do that in a way that prevented the internal diagnostics tool from working?

Edit:
Just figured it out myself. Turns out disabling the camera access toggle under privacy settings also affects this app (note that the screenshots are from an FP4):


I was operating under the assumption, that permissions of the diagnostics tool cannot be taken away, which is actually true if you check its app settings:

I wonder wether that’s considered a bug or a feature. :smiley:

1 Like

Confidentiality > Access to camera: I turned it off. I didn’t even know the existence of “internal diagnostic tools”, Thanks to you now I know

1 Like

I got tired of “ask everytime” for my apps, so allowed when in use. But I’ve read from some geeks that maybe it’s better to ask everytime!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.