English

Fairphone 3 wifi calling

Just to avoid any confusion for others reading this thread: You’re describing the situation in the USA. It’s very different in Europe. Locked phones are not very common. But a few operators still maintain whitelists of phones for services like VoLTE / VoWiFi. And not being able to use these services with certain plans (like prepaid) is quite common.

3 Likes

I just saw a notice in Settings asking me to activate WiFi calling.

I activated it, but I’m pretty sure my mobile network plan doesn’t support it yet. I can’t test it right now.

And I can’t find the setting in the Settings tree. The settings search knows the term, but tapping it lands me somewhere where the setting is not to be seen.

I suppose the setting should not be visible to me and the notice in the settings somehow didn’t care about that.

Will have a look via ADB later …
Edit: seems to have no effect, even after rebooting, at least not visibly.

3 Likes

I clicked on the same notice. And I was able to enable it, but now the menu item in settings is nowhere to be found. Did you manage to find where it is hiding in debug / developer mode?

1 Like

No. I tried the ADB thing, but it

I didn’t dig much deeper, as

Hi all,
I have the same issue: Clicked on the message that suggests using Wifi calls, and then the option is nowhere to be seen later. I first supected that my carrier does not support WiFi calls after all, but when I do a call, it even tells me that it is a Wifi call, so thats not the issue. Also, I inserted the SIM card of my company phone, which 100% is Wifi call enabled, and the effect is the same. I have been browsing the internet for it quite a bit and found a) that Fairphone is not the only device suffering from this problem, and b) that there are several solutions, of which none worked for me. Here those that I tried:

  • Shut down phone, remove SIM, restart phone, power it off again, re-insert SIM, power on -> Option should be there, but is not.
  • Dial *#*#4636#*#*, select SIM card and toggle VoLTE and WiFi options -> Toggle is reset by the phone, cannot change this persistently

This one sounded reasonable, but I cannot find the appropriate App/Service on Fairphone:

  • Go to apps, list all apps, list system services and then locate “Wifi Calling” app and reset Cache. I do not have this App.

Anyone found a solution yet?

OK, tried more things, and finally “solved” it: I just received an update for the native phone app, and in there now the option appears under

  • Three dots
  • Settings
  • Calling Accounts (guessed - German: Anrufkonten)
  • Tap on the SIM-card
  • WiFi calling (guessed - German: WLAN telefonie)

Finally… However, in the normal settings app the setting is still missing…

7 Likes

You can set your phone to English temporarily and back to German again :wink: .

You’re right of course - was just too lazy :slight_smile: Did now - translations were guessed correctly :slight_smile:

1 Like

Thank you for finding the option! I found it too and was able to select “preferred wifi calling”.

I’m using WiFi calling successfully in The Netherlands (hollandsnieuwe carrier).

Dialer code *#*#4636#*#* -> Phone1 information shows “WiFi Calling Provisioned”, which is my carrier’s blessing :wink:

It was working “out of the box”. Can only search in Settings for “Wi-Fi calling”, tapping on the search result opens Network Settings but not the entry itself (probably hidden).

(Android Build 8901.2.A.0110.20200109)

Not necessarily.
It shows for me it’s enabled, too … but the mobile plan I have with my provider doesn’t support it, and so I can’t use it.

I take it this setting displays that the technical possibility would be there, but the real indication that you could use this would come from the availability of the respective setting in Settings.

Did you confirm it really works?

I have some indications:

  1. During calls, there’s a WiFi symbol to the left of the dialed number.
  2. Call setup is very quick in comparison to non-WiFi calls.
1 Like

I am also using hollandsnieuwe but with a HTC U11 Life. I know that the phone is able to use WiFi calling but “Wifi gesprekken geregistreerd” is selected off. I hope that if I buy a FP3 with /e/OS, WiFi calling is working.

Maybe someone over at [/e/ for FP3 (Google free OS)] knows this?

You should be able to confirm that wifi-calling works, if you put your phone into airplaine mode and activate wifi.

1 Like

Thank you! You saved my live :wink:

The June 5th, 2020 Android9 update at least has new wifi calling icon :wink:

FP3 A.0134, Android9 OS update, security patch level June 5, 2020

maybe it has better wifi calling capabilities as well. check for yourself and report back.

This one helped me out on my FP3 in Sweden (operator Halebop). Now sending SMS instantly

2 Likes

Slightly different issue here.

It took a while to get wifi-calling up and running but the continuing issue is that if I turn wifi off, to save battery life, I have to restart the phone to re-enable wifi, so I wonder if this is common.

I don’t think it should need a restart?

Since a couple of days I have a new update on my FP3 and since the update I get the complaint that people can’t hear me properly when talking to them on a phone call. The phone says I’m wifi-calling, and when I turn off wifi during the conversation the sound quality improves, and goes back to the quality I had before the update.

I’m not sure how wifi calling is configured and if I can improve it. The simplest solution for now seems to just turn off wifi-calling and go back to my old (fine) sound quality. But I can’t find how to do that. Does anyone know? Thanks in advance!