English

🇩🇪 Fairphone 3 und Blauzahn

Hallo Zusammen,

seit neuestem habe ich das Problem, das sich Bluetooth nicht mehr richtig? verbindet. Bei meinem Auto kann ich zwar noch Telefonanrufe über Bluetooth führen, es wird aber keine Musik von den verschiedenen Apps übertragen. Bei meinem Earpods dasselbe Problem, es wird zwar im FP3 angezeigt das eine Kopplung stattgefunden hat, aber ich hör nichts. Außerdem werden Richtungsanweisungen von G Maps, wie eingestellt, zwar über das Telefon ausgegeben aber sehr sehr leise. Ich habe die aktualisierten Apps Android System Web View, Carrier Services und Android Auto deinstalliert, so das die vorherigen Versionen installiert sind, da ich den Verdacht habe, hatte das da was nicht stimmt. So langsam komme ich zu der Überzeugung das der Kauf eine Riesendummheit war.

servus Jürgen

Welche Software hast Du auf dem FP3?
Es gibt hier einen Nutzer, der seit dem letzten Update ähnliches berichtet: 🇩🇪 Bluetooth Wiedergabe Bug? das kann aber nicht von allen bestätigt werden.

2 Likes

Android 10
Build 8901.3.A.0084.20210204

2 Likes

Ein anderer Nutzer hat gemeldet, dass er das Problem lösen konnte, indem er den Standortzugriff erlaubt hat. Irgendwas mit “low energy feature”. Das ist wohl im Zusammenhang mit der Corona WarnApp bekannt geworden.

Falls Du das noch nicht getan haben solltest, wäre es einen Versuch wert.

Hast Du parallel auch noch das WLAN aktiviert?
Ein anderer Ansatz ist wohl, dass Du einmal versuchen kannst, das Telefon im Flugzeug-Modus zu betreiben und dann nur Bluetooth zu aktivieren. Es soll wohl zu Kollisionen mit bspw. WLAN auf 2,4 GHz kommen.
Das hilft jedenfalls zumindest mal bei der Eingrenzung; ist aber natürlich für das Telefonieren keine Lösung.

1 Like

Das wäre so, wie wenn ich sagen würde “fahr mit Deinem Auto besser nicht über Eisenbahnkreuzungen, es könnte zu einer Kollision mit einem Zug kommen!” Dass beide Funkstandards im 2,4-GHz-Band funken, ist zwar bekannt, aber die Hardware - hier das FP3 - hat, ähnlich wie bei einem geregelten Eisenbahnübergang, dafür zu sorgen, dass beide Techniken reibungslos arbeiten, indem zu Beginn unterschiedliche Kanäle ausverhandelt werden. So fair muss auch ein Fairphone sein…

2 Likes

Schadet trotzdem nicht, diese Ursache auszuschließen.
Um bei dem - echt schrägen - Vergleich zu bleiben:
Es kommt auch auf Bahnübergängen immer wieder zu Kollisionen.

Und die Ursachen können in beiden Fällen (Bahn und Fairphone) mannigfaltig sein.
Das ist nicht notwendig ein Fehler von Fairphone. Ich könnte mir beispielsweiseauch vorstellen, dass irgendeine App o.ä. die Kommunikation stört.


Nur weil ein Problem nicht auftreten dürfte, kann es trotzdem bestehen.; )

2 Likes

So gern ich mich selbst zitiert sehe, ich befürchte das BLE zeugs trifft hier nicht zu:
Corona Warn App hat mich da nur drauf gestoßen, denn wer geht davon aus, dass du für die Bluetoothfunktionalität Standortzugriff benötigst…
Je nach BLE Device erfolgt die Kupplung teils sehr lose via dazugehöriger App und wird gar nicht richtig im System verankert. Das ist aber nichts, was sich über Android Updates ändern sollte.
Und insbesondere Geräte wie Android Autoradios oder Lautsprecher sollten mMn ausschließlich ohne BLE funktionieren, denn sie haben ja auch eine zuverlässige Stromversorgung.
Hier ist übrigens der technische Hintergrund. Also die Waage von dem anderen Thread halte ich tatsächlich für einen heißen Kandidaten :wink: Bei Smartwatches KA

2 Likes

Mal als bildliche Zusammenfassung:


In den Entwickleroptionen gibt es auch allerhand Bluetooth Optionen zum manuellen Einstellen. Sollte zwar eigentlich nicht notwendig sein, aber vielleicht hilft es ja dort Apt-X zu aktivieren, falls bekannt ist, dass das Gerät das kann.
Hier auf 3.A.0101 gibt es bei Medienaudiowiedergabe keinerlei Probleme. Also wenn ich gleichzeitig über 2,4Ghz ein FullHD Video mit 40MB/s Demux Rate streame, funktioniert das so lange reibungslos wie ich es nicht über Bluetooth Audio anhören möchte. Neben Interferenzproblemen geht es über die gleiche Antenne+Chips. Iwann ist einfach Schluss und um Probleme auszuschließen ist es eine legitime Standardidee auf 5Ghz zu wechseln.

2 Likes

Ja?

Wenn Du geregelte Bahnübergänge meinst, ist das meistens “human error”…

Dann aber bitte die technischen Fakten berücksichtigen, die schließen bereits einige Probleme im Vorfeld aus.

Back to topic…

1 Like

Das ist vollkommen korrekt, hier kommt es allerdings nicht einmal zum Beginn einer Wiedergabe über Bluetooth-Audio. So sehr kann das WLAN nicht ausgelastet sein, dass es zu keiner Audiowiedergabe kommt…

Ich bin mir nicht sicher, ob es sich hier um ein Fairphone-spezifisches Problem handelt: Ich habe noch ein Samsung Tablet (Galaxy Tab S2), auf dem LineageOS 17.1 läuft. Damit habe ich das gleiche Problem:
Während ich früher (mit LOS 16) vom Tablet aus die Musikausgabe via Bluetooth an meinen Raspberry Pi 3 mit OSMC schicken konnte, geht das jetzt nicht mehr. Die einzige Bluetooth-Option, die mir für den Pi angezeigt wird, ist “Kontaktfreigabe” - was natürlich überhaupt keinen Sinn macht. Das ist bei meinem Tablet und beim FP3 identisch.
Im Gegensatz dazu werden bei der Bluetooth-Kopplung mit meinem Ford-Audio-System die Optionen

  • Telefonanrufe
  • Medien-Audio
  • Kontaktfreigabe und
  • SMS

angezeigt.

Das spricht in meinen (technisch laienhaften) Augen dafür, dass es sich um einen Bug in Android 10 handelt.

1 Like

Solange das Fairphone mit dem Ford-Audio-System ebenfalls

  • Telefonanrufe
  • Medien-Audio
  • Kontaktfreigabe und
  • SMS

als Freigaben anzeigt und diese auch entsprechend funktionieren, unterschreibe ich fast, dass sich der Fehler eher in der Konfiguration / Software von OSMC finden lassen wird. Also im Zusammenspiel von bluez, pulseaudio, dbus, …

z.B. dbus bewirbt bei mir

unter OpenSuse /etc/dbus-1/system.d/bluetooth.conf:

<policy user="root">
<allow own="org.bluez"/>
<allow send_destination="org.bluez"/>
<allow send_interface="org.bluez.AdvertisementMonitor1"/>
<allow send_interface="org.bluez.Agent1"/>
<allow send_interface="org.bluez.MediaEndpoint1"/>
<allow send_interface="org.bluez.MediaPlayer1"/>
<allow send_interface="org.bluez.Profile1"/>
<allow send_interface="org.bluez.GattCharacteristic1"/>
<allow send_interface="org.bluez.GattDescriptor1"/>
<allow send_interface="org.bluez.LEAdvertisement1"/>
<allow send_interface="org.freedesktop.DBus.ObjectManager"/>
<allow send_interface="org.freedesktop.DBus.Properties"/>
<allow send_interface="org.mpris.MediaPlayer2.Player"/>
</policy>

unter /etc/pulse/default.pa

.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

Die Arch-Leute haben meistens gute Wikis.

Also ich habe es gerade mit ner Verbindung zu OpenSuse Tumbleweed erfolgreich getestet. Relevante Softwareversionen:

bluez-5.58-1.2.x86_64, pulseaudio-14.2-6.1.x86_64, systemd-246.13-1.2.x86_64, dbus-1-1.12.20-5.2.x86_64, alsa-plugins-pulse-1.2.2-3.4.x86_64, gstreamer-1.18.4-1.2.x86_64

Solange die übrigen Betroffenen nicht so wie du ein Gerät melden, mit dem es funktioniert, ist dein Fairphone anscheinend nicht betroffen :+1:

2 Likes

Hallo Waldie,

es hat tatsächlich geklappt. Bluetooth aus, Flugzeug-Modus an, Bluetooth an,
läuft. Flugzeug-Modus aus, mobile Daten an, läuft immer noch.
Besten Dank für Eure Hilfe.
:heart_eyes_cat:
Ich war schon am verzweifen.

Servus Jürgen

3 Likes

Musstest Du auch die Bluetooth-Geräte neu koppeln?

@Jarl , dass Thema bitte als “gelöst” markieren. :slight_smile:

Hallo Deepsea

Nein habe ich nicht gemacht.

3 Likes

Sorry, war BertG nicht Waldie.

2 Likes