Fairphone 3 File Transfer Can't Open File

Hello :slightly_smiling_face: I have Android 10 on my Fairphone 3 and I’ve connected it via USB to my laptop with Debian KDE on it. I’ve enabled MTP on my Fairphone. I can see on the laptop the Fairphone files but when I try to open them I get, ‘Can’t open file [filename]’. I’ve tried clearing the storage caches on my Fairphone but to no avail. Could anyone please help me fix this so I can send files over USB to my laptop?

Welcome to our community forum. :slight_smile:

I’m not sure if you actually tried to copy the files to your laptop before you tried to open them? When I just view files on my Fairphone on my computer and (accidentally) double-click them, I always get the same error message that your mentioned. I can only open files from my Fairphone once I have actually copied them to my computer first.


Thank you Urs :slightly_smiling_face: However I just tried that and I get ‘Can’t read file’ on pasting

You’re sure the files actually exist on your phone? MTP has some issues with refreshing file lists - I’ve seen cases where directories didn’t update properly until both the phone and the PC were rebooted.

1 Like

Maybe the problem is with KDE. I use KDE on opensuse and in the past, whenever I connected my phone to my PC and switched to MTP on the phone, the pop-up in KDE about external media showed up with two entries for “show in file explorer” (or similar wording, my system language is German). And one of them was for MTP, the other for PTP but as a user you couldn’t distinguish between the two. And IIRC choosing the wrong entry led to something like “can’t read file” or something.

If that’s the case for you, too, - seeing two entries in KDE to access the phone, try both and find the one that’s working.
At some point I found a KDE setting to adjust those entries and changed the names to include MTP and PTP so it was possible to identify the correct one.


Thank you! Now I can read the files. However when I try and create a file on the Fairphone via either file manager option, even in a new subdirectory I created via the laptop, I get ‘Writing to camera not supported’. Any idea on this?

This sounds like the PC is using PTP mode (for cameras), but I’m not sure.

1 Like