Fairphone 3 dead – London area

Hello, I’m looking for someone who has a FP3 and lives in London/surrounding.

I can’t see any angels in London and repair shops I’ve tried don’t stock fairphone parts.

The phone over the last few weeks would randomly restart / turn off but would work otherwise well. It was worse when it was low battery.

It has now stopped working completely

If I plug it in to charge I get a single red flash of the light, the ‘fairphone’ logo pops up, and then it dies and does it all over again in an endless loop.

I was hoping someone might let me trial their battery or lower module to see if that’s the problem.

Thanks!

Hello, naif and maybe obvious question. Did you try to use a different charger and a different USB cable? Does the issue persist?

Yes I did try that with a few

I’ve allowed myself to add your location to the topic title. Hope it helps to attract more locals to it. Let me or @moderators know if you want that to be taken down again.

6 Likes

Sounds like one of the “sudden death” issues to me. :frowning:
One example here, but there are more if you search the forum for this phrase:

If that’s really the case, there might not be much to do about it any more, unfortunately.

As there is still the red LED and a bootloop I would not conclude that already

Hello Lisa, I was wondering if you solved this issue yet? I have exactly the same problem. When it first started happening, I was still able to charge the phone. However, now it does not respond to a charger in any way, and it only gives this endless loop of going on and off when the battery is in there. I am wondering if I just need a new battery. But since the phone is still responding to the battery when I put in in there, I don’t know if this is the case.

No I haven’t yet…holding out for someone who may be able to help me in London. I also emailed fairphone a while ago and am just waiting for their response.

I am in Brighton. Fairphone 3 also just died!

No response from Fairphone?

This has happened to several of us. Almost every day someone reports that their F3 phone has died for no apparent reason. Fairphone has not acknowledged the issue. I sent mine to the repair centre who acknowledged that there was a problem with the motherboard and quoted £300 aprox for a replacement.

@Lisa4 and @Matt2

If either of you are contemplating replacement/repair of FP3 I am in the UK and have boxed example with charger, USB cable and choice of Green or Black case with 16/48 camera modules. It has never been used as daily driver as couldn’t get on with size. Have been reluctant to place for sale upon forum since Brexit, as end up having to discount 20% for EU sales with associated customs formalities in addition. I would be open to offers from UK.




Oh great! Thanks for letting us know. How much would you be looking for?

Hi,
Have responded to you via Personal Message. Although you have not yet spent enough time on forum to create one of your own, you should be able to reply to mine to you.

2 Likes

@Matt2 and @Lisa4 the issue has now been resolved for me (I think). After cleaning the inside of the phone and letting it rest for a few days, I was able to turn it on after a week since the problem started. How is it going for you?

5 Likes

Great to hear that you were able to make it work again!

Just in case that this is a temporary improvement, please make use of this opportunity to backup all your important data. This is a good idea anyway, even if your phone is still fine. Bad things can always happen to it.

3 Likes

No luck yet!! Tried again following your reply, but seems well and truly dead. I have heard back from Fairphone, and they have just suggested to send it back to them, or try repair it with spare parts.

They just said to send it to them, but I need to get into the phone to retrieve something important I didn’t back up, so I won’t send it as they’ll factory reset it.

Still hoping for a kind londoner to let me temporarily use their parts to see if that can fix my problem long enough to back up my info

Hi Lisa,

Several people have had problems with the power button, it seems to be a FP3 weak point. For most folks when it breaks, it doesn’t function at all but I’m wondering in your case if the power button is stuck in the depressed position?

Next time you plug the USB charger into your phone, press and hold the volume down button. If you then get the Fastboot screen and after a few seconds the phone loops again, I’d say the power button is the culprit. You navigate the fast boot menu by using the vol up / down keys and select option is using the power button. If the power button is depressed, navigation will also fail. If fastboot navigation works or the phone doesn’t loop-reboot from fastboot, then I’m wrong.

As you get the LED and continual re-booting, I agree with @yvmuell that this is not sudden death syndrome.

I’m happy to come to Brighton if you wouldn’t mind me using your phone parts - I’d only need 20 minutes!