Fairphone 2 will not accept my email address

I have a new Fairphone 2. Android will not accept my existing (not gmail) email address. I have checked passwords thoroughly. Message reads “couldn’t open connection to server”

Are you sure you’ve the correct server settings (name, port, encyption (TLS etc.))?

I guess you are trying to set up an IMAP / POP3 / Exchange account? Have you checked the server / port / security type settings? These can not always be determined automatically. You might have to check with your email provider.

I bet Galder is trying to insert his mailaddress where googlefamework wants to see his gmail-address. …

Or should we ask first where he is trying to insert the address??


Thanks for the reply. I put the settings exactly the same as on my laptop.

Yes, I am trying to insert my mail address (Thunderbird) on the page that comes up when entering the email app and one is invited to insert the mail address. I don’t particularly want a google address.

Little more info needed here. You don’t need a Gmail address!

  • Make sure you use the “Email” app (not the “Gmail” app).
  • Make sure to select the correct account type (POP3, IMAP or Exchange).
  • Check that the settings for “Server”, “Port” and “Security type” match your Thunderbird settings.
  • Also, your username might not be identical to your email address (depending on your email provider).

At what step do you get the error message?

I am using the email app.
I am copying an IMAP account setting
the settings are as in my laptop Thunderbird connection and the user name (my email) is also as in the Thunderbird account settings. On security I have tried STARTTLS and ‘None’ as in my laptop. I have not entered the optional IMAP path prefix. The message comes after all the info has been entered and a message comes up saying ‘validating server settings’ followed by ‘couldn’t finish - couldn’t ope connection to server’

Do you have internet-access while trying to setup?

If you do a web search with “couldn’t open connection to server”, you’ll get a lots of hits were this problem is discussed. So you’re not the only one with this problem, and it seems to be a bug of the default e-mail app, as different phones and different e-mail providers are affected. I just had a quick look for solutions and found the workaround to use another e-mail client like K9.

Yes I have access

Irina - I used K9 and it worked. Many thanks indeed. Graham