Fairphone 2 unusable while charging

Just for the record, I am affected by this as well. The same charger works fine with a several other smartphones, like a Sony Xperia Z5C, which is quite new and came with another charger.

It also happens when connecting the Phone to my PC, which I do regularly with other phones as well, and that is a deal breaker for doing developed with the phone.

1 Like

The problem of not being able to use the phone during charging might be related to a two-wired cable. Try a four-wired cable (one that can be used for data transfer).

@ben what’s the output current of your chargers? (PCs usually only output 500mAh, for example.)

@Stefan thanks for your suggestions. I have checked the chargers, one of the chargers seems older, 850mAh.

I have no idea what the PC outputs, but I never had such problems with another phone. The cable is definitely a quality cable which can be used for data as well. I use it do quick charge my Sony and for development every day.

I will either get my bottom module replaced due to a faulty mic or buy a new one, I will check if that improves the situation.

Yep same here… (of course as I’m having all possible problems with my phone) :frowning:

1 Like

Odd thing here is for me, that I never observed this kind of behavior, that the touch screen is completely nonfunctional for me when on charger before like say one or two months worth of monthly android (6) updates. Or say maybe when fairphone2 switched over to android6.

so it was only recently that i noticed that I can not use the fone any more when being on charging. I dont have that many cables or different chargers, so I think i could swear that it used to work before with my scenario and setup here. Well anyways, today I finally decided to look around here on the forums and found this and some threads about screen and charging.

Weird. But thanks anways.

Yep this does seem to work although I find it better closer to the phone end rather than the charger.

Also on most charger cables it is rather difficult to pass the cable through twice.


I have never had this kind of issue either with my old Samsung, Huawei, Xiaomi Pad or Lenovo Pad… No matter with which charger I plug in, no matter I’m connected to the ground or not…

What’s wrong with the FairPhone 2 ? Why is it so sensitive to this touchscreen issue ?
I even have the problem when I plug a jack to listen to music with speakers connected to earth !
Chargers are everywhere nowadays. In the cars, in the airports, in the shopping malls, or even modern powerplugs in the house. I thought the FP2 was supposed to be universal, the reason why they don’t even provide a charger with it ? An since it has such a weak authonomy, I often need to charge it during day time, with the powersource I find nearby. :frowning:
When I close the screen and open it again, it works for a few seconds then again and again …
That’s really annoying. Any real solution so far ?

These so called “ferrite sleeves” (there are more expressions for them) are also available as clip on version.


They may help in some cases, but not in all.

For info, ferrite loops didn’t help in my case. And I just discovered that a charger that worked in one Fairphone 2 didn’t work in another Fairphone 2, and vice-versa. Match between a particular charger and the charging module unfortunately can be whimsical.


That´s quite interesting to know. Someone who was successful to match a charger with his actual FP2 may be surprised when he uses it on another FP2. Several users stumbled over this screen issue already when charging.
This problem should be fixed with the next FP version. It´s essential specifically since there is no charger shipped with the phone.
Up to now I think it´s not clear if it´s a display issue or a bottom-module issue showing up with display problems when charging.
If it was a display issue it would be interesting to know if users with a replaced display could experience any difference with this effect.

Anyway FP should address this with any new step in hardware modification.

1 Like

I had to replace my screen and I didn’t experience the issue since… But I’m curious if it’s just luck (my old charger and the new screen are compatible) or rather a fix (my new screen is compatible with all chargers).

1 Like

This has definitely been fixed with the new “C2” display modules available since late 2017. There are many reports about that here on the forum. Fairphone just never confirmed this officially (as far as I know). Maybe they’re worried that too many people would make a warranty claim for a new display module if they did?

I’ve been effected by this as well and eventually just bought a new display module. That fixed it once and for all.


Good to know.

I must have missed them specifically.

I would put this as “technical changes reserved” for further advancements.

Otherwise I could get the impression that any change (for the better) could be seen as a “fix” to the available unit. And that´s surely not the right way to see it.
But, yes - there are individuals out there these days always on the hunt for a bit more benefit.

Thanks a lot, i’ve been an early adopter and my mainboard died 2 times allready, replaced within waranty, sadly before 2017 so nothing works when i plug in my charger, but maybe i’ll just buy myself the new screen, my Fairphone 2 journey has been costing the company too much allready xD after all i would still love to have more of them juicy fairphone-ethical upgrades and updates for this thing far in the future ^^


And rightfully so, if they experience troubles with the charger. If they really located the problem with the display, I am tbh deeply disappointed, that they did not even mention this possible solutin in the troubleshooting tool. Instead they locate it with the charger and give the advice to check this forum.
So - in this case - I don’t happen to agree with @Patrick1. It’s not just a change for the better, it’s a constructive error (at least in my opinion). And as a user I at least would want to be kept up to date.

1 Like

FP2 freezes when charger is connected. Normally resolves after a few minutes. Is this normal for FP2>

If the charger delivers less than 1 A (1000 mA), then touchscreen trouble was reported here before.
(In fact, I experienced this myself with a 700 mA charger, when using an 800 mA charger showed no problem.)

If it happens with different chargers, you could contact #fairphoneangels who could perhaps help with swapping modules to find a faulty module, or you could #contactsupport .

I’m using the Salcomp charger that was offered together with the FP1 a few years ago. It offers 1A output and in general the FP2 is responsive when connected to it but the screen just freezes quite often. Then I have to press the power button to switch off the screen and press it again to do the next trial. It works better if I have the phone in my hand, it works worse if it is lying on a table. The phone, however, works perfectly well when I charge it at a computer (500mA), and it works without any issues when connected to my Forumslader dynamo charger (>1A). So current doesn’t seem to be the root cause. I like the theory about the screen version but cannot test since I don’t know anyone with a new screen.

I have given up on this issue. My FP2 (2016) always has a locked screen, which means it does not respond to any touch as soon as it is connected to a wall-plugged charger, with any charger, cable combination I have used. Not mine, not from various friends.
Yet another %#@* I have never experienced with any other phone I have ever owned - brought to you by Fairphone :slight_smile:

But I shall not only rant. What I do when I know I need to use the phone while charging:

  1. Connect to any PC or Laptop. Works 100% of the time, every time.
  2. I always have my portable powerbank with me because of that and I am also tired of buying new FP2 batteries every 6 months and resetting the phone’s battery management memory according to the #batteryguide every 2 weeks.
  3. Most moderately recent cars have a USB port nowadays. That also works.
  4. Connect to your TV or MediaCenter’s USB outlet. Has worked without fail.

I don’t even care anymore why this happens. I only know this happens exclusively with the FP2. Also its my second or third bottom module.

This is the powerbank. Got it as a advertisement gift at a security con years ago.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.