English

Fairphone 2 not recognized by windows 7

Hi Irna,

I’m using Avast, is that known to cause issues?
I rebooted and uninstalled the Android driver I had on device manager but when the the drivers were being installed, Android and MTP were not found. How can I install the drivers? Can I do it manually?

Well, I also use Avast, the free version with the default anti-virus settings (no aditional features enabled) and I’ve no connection problem.

I run W7 Ultimate 64-bit on my desktop and W7 Ultimate 32-bit on my laptop. The FP2 was recognized automatically and works well in every USB mode, although Windows didn’t find all drivers.

I’ve done a quick web search and there seem to be multiple and different problems with Windows 7 (especially with the 64-bit versions) and MTP, some caused by anti-virus programs, some not. I would suggest you to do a web search and try the different solutions provided on other pages.

FP2 also connects seamlessly to W10 (64 bit), @Irina_Spitznagel ,
just to let you know this…

Hallo,
my fairphone 2 with Android 5.1 and Fairphobe OS 1.2.8 does not connect to my windows 10 PC. The cable normaly works for datatransfer, the phone shows, that it is loading. When I open the “akku” window on the phone and it just gives me the oportunity for the enegysaving mode.When I open the “Speicher” (storeage) window and tap up left it shows in grey “USB-Verbindung (PC)”, meens it is not working. The PC makes noise, that I hear something whants to connect and the PC tells me: the USB device does not work propely and windows can’t recognize it.

maybe you have a look here. @KaOe if this doesn’t already help you, please ask me again : )

I am sorry, but I don’t get the pop-up only the normal loading symbol. I just want my pictures on the PC, but they are not stored on the sd-card, so I have a second complication :frowning:.

could you post a screenshot of it here?

You have to swipe the notification bar down in order to see it.

so you’re missing this notification on your homescreen >

which may mean that you’re not actually connected to your PC other than for charging the battery (does that work?). is it possible that the firewall of your PC prevents the phone from connecting properly via USB?
do you have a chance to try connecting with another laptop/PC?

I get this message:

  1. so you’re not connected to your PC other than for charging the battery (does that at least work?).
  2. is it possible that the firewall of your PC prevents the phone from connecting properly via USB?
  3. do you have a chance to try connecting with another laptop/PC?
  4. do you have, by chance, another mini-USB/USB cable at hand? (sometimes the different types of cables are the problem)

please try to go through these 4 points, then we will see clearer, hopefully : )

Hi Christoph,
thank you for the checklist:

  1. The connection just shows the loading, and it is realy loading.
  2. I don’t know how to check the firewall.
  3. Meanwile I tryed to connect with my laptop, I got the same message (unknown USB) The Laptop has Windows 10 too. Before Windows 10 or/and Fairphobe OS 1.2.8 the connection worked.
  4. I tryed another cable, with the same result.

Next I will read about the firewall. I copyed the pictures in the fairphone on the sd-card, so I can use my pictures :sweat:

you’re welcome! from what you say i guess it’s really a firewall issue. sorry, but i’m no expert in this topic : (

The firewall is run by Kaspersky Internet Security, I have the feeling here could be the problem.

i have no own experience with this security package but assume your gut feeling is right. so disconnect WiFi, disable kaspersky and try again to connect your FP2. as a workaround, at present.

i know, it’s a nuisance to spend so much time with the device when you only want to swop some pictures. fortunately, modern devices are pretty fast, so the amount time you waste is limited (which was quite different at times when you had to install programs via piles of floppies LOL).

You swiped too much. Just swipe it down once with one finger.

that happens @Irina_Spitznagel, swiping is fun : ) but i don’t think that that’s @KaOe 's problem: on his screenshot, i don’t see the “connected in charging mode” notification below the fast-access screen (as i do when i swipe enthusiastically), see >

Oh, thanks, I didn’t even know that this notification was shown there as well :blush:.

1 Like