Fairphone 2 not recognized by windows 7

Very happy I received my Fairphone2. But trying to get it to be recognized by Windows 7 on my PC to get my personal data back on the new phone it fails. On my laptop with bluetooth the laptop can see it but complains about missing drivers. Where do I find the drivers?

I moved the topic from “Software - Android 5.1” to “FP2 Help”.

  1. Is there a notification on your phone, when you connect it?
  2. Do you connect via MTP?
  3. Have you tried another cable?

nothing is popping up after connecting it with usb like I am used to with my first fairphone, I do not have the chance in choosing MTP. -debugging is on. In linux “adb device” does not show the phone. I tried 3 cables.

Hm… Did you try to connect to another PC?

If nothing else comes to mind, I’d try a factory reset. :slight_smile:

Have a look on the thread on adb. The proposed solution worked like a charm for me…

@merci: I think that @wolan cannot “uncheck all boxes in USB connection popup”, if nothing pops up. :slight_smile:

@Stefan: There is no pop-up indeed. Once you have enabled dev options and USB debugging on your phone you see a small icon (looks like a devil’s head on a stick, “USB debugging connected”) in the upper left appearing when you connect your phone to the computer by USB. You can then swipe from the top: This allows you to either disable USB debugging or to change the USB options under “Connected as an installer”. One of the options is “Mount SD card” which you need to uncheck even if no SD card is inserted…
@wolan: Hope this helps.


I don’t think @wolan has enabled dev options, so he should have the notification.

@wolan If you don’t see the notification when sliding from the top down you could go to settings > storage > tap the 3 dots in the top right corner > USB computer connection.

For me (mac) it works best to enable MTP, but maybe for Win it’s better to uncheck all boxes.

That little devils head was the solution,- FP2 now is recognized by my computer,- but: with MyPhoneExplorer FP1 is no problem, but is complainig about “no USB connection” when FP2 is connected. Anyway, thanks a lot so far.

Strange thing:

I just also tried to connect my FP2 to my work notebook which runs on Win 7.

  • First I connected the phone (via cable) as MTP device, and I got an error message on the computer the driver wouldn’t be found.

  • Also error message when not checking any option

  • The option “Mount SD card” did work, though no access to internal drive, only the SD card (as the option’s title suggests ;-))

  • Then MTP again, nothing.

  • Then I connected it with PTP (camera) option and got access to my pictures (on the internal drive)

  • Then I tried MTP again, and suddenly it worked normal!

Anyhow, now I can access the FP2 on Win7 via MTP flawlessly (and plug out/in again and it works repeatedly)!


If anyone can tell me what I have to do to connect my fp2 to a windows 7 PC, I would be very grateful!

I’m having the same problem, only then with Windows 10. When I connect my phone with an USB cable to my laptop nothing hapens; no notifications on my phone or laptop and I don’t see the phone in on my laptop.

I’m completely new to Android, and am having some trouble trying to execute the solutions in this topic.
I have tried going to the settings -> Storage -> tap the 3 dots in the top right corner. It then shows me “USB computer connection”, but its grey and I cannot tap the words.

Merci mentioned something you can do after you have enabled dev options and USB debugging on your phone. How do I do this?

When you plug in your phone to the PC, have a look at the phone’s notification bar (at the very top). When you swipe it down, in the top left corner there should be a menue with usb options. Select MTP and it should work.

1 Like


I just received my Fairphone 2 yesterday but when trying to connect it to my pc and view its files, it is not appearing in ‘My Computer’. I’ve tried with several cables and have tried the variations of ‘USB options’ (e.g. MTP, PTP, etc). What else can I try? This is extremely frustrating after a lengthy wait for the phone in the first place…

Well, MTP is the best option to see your filees and normally it should work… Did you already try another USB port? Does your phone charge when connected to your PC? Does your PC react when you plug your phone in (sound, looking for drivers)? Is there any security software installed on your PC that might block the access to your phone?

sure that’s frustrating!

do you have a chance to try connect your FP2 to a different laptop/PC? in the past, i had no issues connecting my FP1 to my laptop (MTP, PTP) but this did never work on the PC of my son (no firewall problem) for reasons we never figured out.

just to make sure that you used the right way to connect:

  • once you have connected your FP2 to your PC via USB-cable, does the phone charge (battery icon with lightning)?
  • do you get the notification “Connected in charging mode”? if not, try swiping down from top to see the notification.
  • there’s a hint in this notifiction: “Touch for other USB options”. if you tap on that you should see a popup with the options MTP, PTP etc.

Hi Irna,

I tried another port, yes. If it makes any difference, my pc never makes the ‘plugged in’ noise, only the ‘unplugged’ one, if that makes sense.
The phone does charge when using a 1A cable but I have no 1A cables that are usable for file transfer.
No security issues to my knowledge. Thanks for the reply.

Hi Christoph,

It is recognised instantly by a W10 pc.
Phone doesn’t charge unless I use a charging cable but I have played with the USB options, as I mentioned in my original post. Thanks.

so it’s probably a firewall issue, as @Irina_Spitznagel mentioned. too bad.

Sorry, I just thought about my previous post and it was a bit stupid, because if you can play around with the USB options of your FP2, they are somehow connected. And if it connects to another PC, the hardware is ok. So try the following:

  • Check you firewall/anti virus etc. if there’s an option marked that might prevent the access to your phone
  • Reboot your PC with the phone connected. Does it look for drivers?
  • Maybe there’s a conflict with older Android drivers. Go to Control Panel --> Device Manager and look for them. Uninstall them (mark the option to delete the files from the PC as well) and reboot your PC.