English

Fairphone 2 : no signal

Hello,
I am not able to connect to the provider network with my FP2.
I tried to put my SIL card in another phone (Samsung) and it is working well.
Does anybody face this kind of issue ?

I tried to reassemble the modules, but it didn’t help.

The SD card slot is broken and I was wondering it could be a solution to replace the core module to fix the both issues.

Regards,
Xavier.

Has your SIM card ever worked fine in your FP2? Which provider are you with?

1 Like

Did that happen just out of the blue? Or didn’t you use the phone for a while? Or did this SIM never worked at all?
Which software are you running on the phone?

1 Like

The phone is running with /e/ OS version 0.17.
I tried to put the SIM card of a friend in my FP2, and it is not working.

My provider is Sosh (from Orange company).

Did the SIM happen to work with this phone and software? If not, what was the last working configuration?

2 Likes

Yes it worked few months ago.
Then I changed my provider, it didn’t work with the new one.

So I came back to the previous one, but it’s not working any more.

Did it ever work with /e/ OS?

1 Like

Hi! That’s funny, I had some signal problems myself (but it was my fault, I was messing around in the settings).
I found that resetting network settings solved my problem.
It’s in Settings > System > Reset options

It will reset any and all setting you have for Wi-Fi, mobile and Bluetooth, though.

3 Likes

Hello
I did few testing.
I installed LineageOS 18.1 and it worked when I was in another place (few km from my home).
I did the same by installing Fairphone OS 21.05, and it worked when I moved to another place.

At home, it is not working for both (it is working on another phone with the same SIM card).

It seems that the FP2 antenna is not enough powerful to connect to the network compared to the Samsung one.

1 Like

Your FP2 might have a loose antenna:

2 Likes