Fairphone 2 help needed: no os, no twrp, no usb debugging anymore - just fastboot mode

Hello everyone,

I have a serious problem with my fairphone 2, which ran fine with the lastest Fairphone Open Release until yesterday. Yesterday unfortunately I deactivated the usb debugging feature by mistake and forgot to turn the feature on again. When I later restarted the phone, I was not able to start it anymore. I am also not able to access twrp anymore. The only thing that starts automatically when you turn on the phone is the fastboot mode.

When I connect the phone in that mode to my Computer (Linux Ubuntu 18.04) the phone is recognized perfectly when I type “fastboot devices”. I am also able to flash /boot a twrp image without errors. Nevertheless, twrp will not start regardless whatever i am trying to do. My guess was that it could have to do something with the disabled usb-debugging on the phone.

I am sitting here for hour now to find a solution and have read each related post I could find here with no result. I would very much appreciate any help or hint that helps me to bring my phone back to life. Thank you very much!

Have you tried reinstalling the OS via fastboot?

Also, if the phone automatically starts into fastboot mode maybe the Volume down button is stuck and that’s why you can’t boot normally.

1 Like

Thanks for you quick reply! I guess the volume button works fine, there where no issues at all with the button before. I can reinstall the OS with fastboot, but the system does not start after re-installing. The phone just remains in the fast boot mode again. My guess was it could have to do with the disabled usb debugging function may be?

I don’t think you should need USB debugging for fastboot - also if that was the case you’d get an error.
Have you tried fastboot reboot?

1 Like

just one additional remark: when I try to boot with the volume up button pressed the screen flashes several times showing appearing and disappering the fairphone logo. when I realease the button then the phone falls back to the fastboot mode / screen.

That sounds strange and definitely like there is something wrong with the button. :confused:

1 Like

yes, “fastboot reboot” just results in the fastboot mode again.

After frustrating hours of or work I was at least able to boot into twrp without flashing using the given description here: https://forum.fairphone.com/tags/twrpwoflashing

But I have no idea how to continue from this point now as I have no OS left on the phone. How can I bring an image on the phone again that just bootet into twrp wihout flashing. The only thing I have now is the twrp access with nothing else left on the phone? Can you help me? I would really appreciate any help I can get at this point!

You can try to install the “OTA” file from here with TWRP (not anything “Manual …”, that’s for fastboot) …


But I would first try to resolve the button thing … have you tried to boot the phone with the case taken off?

Thank you very much for your reply! yes, the button works. I guess the real problem was that the battery was nearly down. After some charging I was able to boot into twrp at least using this description: ✏ How to use TWRP without flashing it (e.g. for Backup)

My phone now is connected with usb cable to my ubuntu pc and I was booting using fastboot into the twrp with the command from the description: fastboot boot fp2-sibon-16.10.0-signed-recovery.img

So I am in TWRP mode with the phone now. I have also the OTA file from your link: https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-downloads.html

But what can I do with this file now? How can I bring a OS on the ohone again?

You can’t really say that when all you get by turning on the phone is fastboot mode all the time, can you :wink: ?

If you have a working fastboot command, you should have adb, too.
With TWRP running, connect the phone to your computer via USB and see whether adb devices doesn’t give you an empty line (much like fastboot devices you mentioned earlier).
Then in TWRP choose Advanced, then ADB Sideload.
On your computer, you can then adb sideload filename (filename being the filename of the OTA file you downloaded).

yes, the command adb devices gives me the output: “List of devices attached
f65fb624 recovery” now. But I still do not get which file from the OTA download I should use. The OTA Download results in a zip folder called 19.08.1-sibon-fad0fe00-ota that contains when unziped different files and folders. So which file do you mean?

would it also be possible to download an image file on a sd card, insert it into the phone and install the image file from the twrp screen on the phone now?

Just use this ZIP file as it is, don’t extract it.

You can do that if you want … with the ZIP file you downloaded.

thank you! what would you recommend as the better way? Using the command " adb sideload 19.08.1-sibon-fad0fe00-ota.zip" on the computer? Or better the sd card way?

unfortunately adb sideload 19.08.1-sibon-fad0fe00-ota.zip gives me an error message with the output:
adb: sideload connection failed: closed
adb: trying pre-KitKat sideload method…
adb: pre-KitKat sideload connection failed: closed

may be its because usb debugging is disabled on the phone as I wrote in my first post?
So better the sd card method then?

So did you try that? And what was the result?

Posting is limited for users on their first day here.

According to PMs to me @krummelaake could successfully install Fairphone Open OS via TWRP, but rebooting still results in fastboot mode nonetheless.

As for what could be the problem, I answered that the problem still could be that the Volume - key is stuck or malfunctioning.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.