Fairphone 2 completely unusable


I was using my Fairphone as usual when it turned off by itself. I tried to restart it a few times, and also to take off the battery and the SIM card, but everytime it turns on again, I can’t open my apps and the message: the process com.android.phone has stopped appears.

I also tried to put my phone on recovery mode and follow those steps: https://fairphone.zendesk.com/hc/en-us/articles/201654943--Resting-Android-robot-No-Command-Black-screen-on-reboot but after selecting the option “apply update from sdcard”, I can’t do anything.

Thank you for your help.

Please remove the screen and all modules from your phone and put them back in.

If that does not help, please contact support. I think your phone has a severe problem and needs to be completely replaced.

You’re linking to instructions for the FP1, if your intention is to reinstall a system update on the FP2 (you’ve posted in the FP2 forum and your profile lists you as having an FP2) you may have better luck with one the different methods explained here.

But as @TobiasF mentioned, check whether the connections between the modules are still fine. You can also rule out issues caused by any apps that you’ve installed by starting in safe mode. If that doesn’t help, try the the update again. A last ditched attempt to avoid contacting support for a replacement would be performing a factory reset, but this does delete all the data on your phone.

1 Like

I experienced the same problem two days ago.

My FP2 have been running for one and a half year, with random resets, but I could live with that.

Two days ago after a random reset the boot was stacked. After trying to reset the phone, allways the same stacked boot page, or autor-restarting after few seconds during boot.

It is completelly impossible to get the phone booted, also the starting in safe mode is not possible.

Any help?

Are you sure? This:

doesn’t sound the same as:

Assuming it doesn’t boot:

  • Check whether your power button isn’t stuck. Removing the case can be useful to check this.
  • Check whether the battery charges fully (i.e. when you plug in the phone (but don’t start it), does the charging light go green after a couple of hours?). If it doesn’t, follow the official troubleshooting guide: Battery > Can’t Charge. The guide will tell take you through the process step by step based on the yes/no answers.

Same for me, as described in my other post FP2 does not boot.
No buttons blocked and fully charged battery…
Any hints would be highly appreciated!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.