Facebook-app keeps crashing the FP1 Kola Nut 1.8.7

My Facebook-app keeps crashing my FairPhone 1 wit Kola Nut version 1.8.7 over and over again.
I allready did reset my phone a couple of times, the normal way but also by ‘Hard Reset’.

The FB-app freezes the screen and keeps the Phone from reacting on any of my interactions. Not even by holding the home-‘button’ or something like that.

I realy like to keep this newest version of the operatingsystem or shell but not like this.

Before I stated:
> Just re-installed the older Fairphoneversion 1.6 and the FB-app works like a charm. :frowning:
but just some minutes ago FB freezed my Phone once again. Seems to be a bigger bug than expected… If someone has some of a sollution for me: please!

Since I’m sure many people use the FB app with FP 1.8.7 I don’t think it’s really a bug in the OS. Maybe something went wrong when you first installed 1.8.7. You could try updating again and see if it works then.

One more thing that comes to mind: After you did a hard reset, did you reinstall the app or restore it from a backup? Maybe whatever was wrong with the app was saved in the backup as well.

If nothing else helps you could try an alternative FB app like Face Slim or Tinfoil for Facebook. These apps are free and better for your privacy. :smile:

1 Like

Let me try that.
Best option is to fix the problem better than to work around it but okay, I’ll try your suggestions. Tenx!

I downloaded the app from the Playstore by the way

Didn’t help at all. Tried another hard reset and used my Gmail to register without checking the backup option and downloaded Facebook from PlayStore. Same freeze, just by scrolling down in the Facebook-app…

That’s really strange. Then I’m all out of guesses. :confused:

Have you checked how “full” your Fairphone storage is?

12,04 GB free. Couldn’t be more clean because I just did a hard reset and didn’t install anything except for the Facebookapp.

Now I’m testing my google-account on an old Samsung to see if FB reacts normale to that.


I’m having the same issue. It’s getting really annoying tbh…

On the old Samsung Galaxy S2 the FB-app works great.

Nog I’m installing it again after a hard-reset on my FP1 using a new Gmailadress.

Using a new gmail-adres after another hard-reset seems to work!
Now the Fabebookapp doesn’t crash my phone anymore but…

I do everything using that mailadress… I have that adress since I stumbled upon the internet when everybody else was using pigeons to send mail :frowning: I linked it to every service taken over by Google like Youtube, of their own ‘Drive’.

What to do? And how did this go wrong?

I’m not using the Facebook app but have you already looked into the comments on the app’s Play Store site? Many people have complains about the app not working. Might be resolved within the next week or so?

That would be great!

I’m realy trying to figure it out by analysing different situations but the sollution doesn’t make any sense… Thanx.

Have you tried to log in via webbrowser in the meantime? I couldn’t logon into the app for a while and searched long for the problem with the app - but the problem was that i didn’t had used a real name - facebook noticed that and locked my account. I was able to login again via tha app after i changed my name in a normal webbrowser…

1 Like

Good one. I login several times using multiple devices such as an iPad, laptop and even the Firefox-app on my FP1 so that shouldn’t be the problem. Also my Facebook-id is my own last name. :smile:

Thanx for the reply :+1:

1 Like

Happy news today: after another update of the Facebookapp I was able to browse around for many minutes! Without the app crashing my Phone again!