Facebook app causing severe problems (December 2016 app update)

Since its last update, the Facebook app causes severe problems like phone freezes, crashes, battery drain, problems with instagram etc. (see here for example)

If you lately experience issues like this, just uninstall the app. Probably your problems are solved.


Perhaps the facebookapp on F-Droid is an option.
You have on F-Droid three apps for Facebook:
Face Slim, SlimSocial for Facebook or Tinfoil for Facebook.


Yes, I use Face Slim and it works well.

Another alternative is to just open Facebook with the browser.


Facebook with Browser doesn’t work for me. Text entry is all over the place - it gives you a tiny 3-line window which is very difficult to review without being able to scroll up/down. Also the cursor leaps about and you insert words in the middle of other words. Maddening.
I will try Tinfoil but do I need this F-Droid thing first?

You can download the .apk file directly from the F-Droid website, so no need to install F-Droid first.
But anyway you’ll need to allow “unknown sources” in settings > security. (you can disable it again afterwards)

Major problems today.
Firstly the browser won’t open FB, it just doesn’t load. Every other site OK.
Then, I installed Tinfoil, which worked fine to start with.
Cancelling a half-written post ruined it - it wouldn’t let me Cancel or continue. Tinfoil now also useless, it just white-screens me even after phone restart, I will have to uninstall.
Admittedly FB has been intermittent on a laptop too today.
Will it all be fine again tomorrow…?

You could also try Face Slim or SlimSocial for Facebook, both to be found in F-droid.

1 Like

If an app acts weird it’s in most cases sufficient to go to that app in Settings > Apps and in the app into screen press Clear cache.


FB freezes (almost) everytime I use the back button after watching a video. Then I have to kill the app if I want to use it again.

This problem appeared at least 6 months ago, and still happening after updates and factory reset.

Am I the only one with this issue ?



Still going on for me.

Used to be able to do this no problem. Not sure what has changed but now I can’t upload to Facebook at all. Phone just freezes, restarts by itself…does not upload anything. I’ve unistalled and reinstalled Facebook, have also cleared data, cache all that…still nothing. I can see the loading tab on the Facebook app, gets to 42% then just stops. Very frustrating! Can anyone help? I’ve tried unticking box on privacy impact as that seems to have worked for people, but it has made no difference :frowning:

I moved your post here - you’ll see you’re not the only one with FB issues. It’s best to uninstall the official app and try an alternative.

The privacy impact thing was a bug that was fixed a long time ago.


I have the same issue. However, the phone doesn’t freeze, but just reboots 4 seconds after starting the Facebook app. After the reboot, I can use the app again for a while. And a few hours later I have the same problem again.

Yes I do think that lots of my problems are down to the FB app. But not all by any means. It ALWAYS seems to reboot when it wants to update an app. Nothing to do with facebook. Any ideas what this might be?

Did you uninstall FB? Only then you’ll know if it indeed has nothing to do with FB, in which case please continue here - as this is not the right topic for you then.


Just scrolling down the FP1 forum I’m coming to the same conclusion. It’s looking like an experimental platform for survivors and experts, rather than a viable smartphone.
Mine started with Facebook, I’m now running Tinfoil but that’s not without its problems (copy and paste a web page? - not easy matey!) And Twitter is almost unuseable too; if you don’t do things in a very prescribed order, you’ll get hourglass and unsent tweets.
I’m reluctantly contemplating replacement, after all it’s 2 1/4 years old and therefore obsolete, right?

Obviously you looked in the wrong places! :wink:

Not Fairphone’s fault! Issues started with an update of the Facebook app: Facebook app causing severe problems (December 2016 app update) You could try to roll back to an earlier version of the Facebook app (APK Mirror is trusted by a lot of people since they are run by AndroidPolice.com).

There is a very powerful (and open source!) Twitter app out there: https://forum.fairphone.com/search?q=twidere

1 Like

Hi Stefan, yes I know it’s not Fairphone’s fault, it’s just that the world has moved on since Android 4 and new stuff doesn’t work. I’m not gutted that I can’t post on FB in lurid colours… I took the advice to use Tinfoil but as I say, that has its bad days too.
Will try your Twitter suggestion, thanks.
But it does look like the FP1 is heading surely for the door

I, personally, see it the other way round. Facebook doesn’t respect my lifestyle because I don’t want to buy the latest gadgets, but they are trying to force me to do it. An open network would allow me to use legacy app versions to access the network.

PS.: I’ve been using my Fairphone 1 for 3 years (most of the time even without Google Apps).


I don’t approve of built-in or forced obsolescence, but it happens.
My laptop is slow and clunky on internet access, all of 3 years old. Also does good impression of fan heater… Resisting the urge to replace.