Error installing OpenOS over latest stock OS

Hi !
I’m a fresh user of FP2 (received yesterday) and I want to install the FPOOS before really using the phone.
I’ve downloaded the correct zip (I think) : the one labeled “OTA Build switcher”. Then I open it with the “updater”, but I only get the following message (immediately) :

Fairphone Updater
Install 21
Restart your phone to complete the update

Clicking CANCEL does not really help, and clicking RESTART only shows a small notif

File not found : /cache/

I must add that yesterday, the first thing I did was to update to the latest stock OS, but first attempt failed with the “just a moment” popup stuck for few hours. So I killed it, cleared data/cache, restarted the phone, and executed the update again (successfully this time). I’m not sure if that’s related.

Of course, clearing data/cache for the updater app does not help now.

The problem is that the latest Open OS version is based on the stock OS version 1.4.2 which is not the latest version (1.5.1) you probably updated to. So, you might have a look into this thread. There are two options for you now: either you wait another couple of days/weeks until the release of the next Open OS version (which will most likely happen by the end of this month) or you try flashing the image via fastboot (see linked thread).

1 Like

Thanks, I did not see this thread when looking for similar problem. Will wait until the next release or use fastboot if it’s not released by the end of the week !

1 Like

If I remember right, installing FPOOS will anyway delete your data. So in my opinion there’s no reason to wait if you want to switch, and to just flash an older FPOS version first.

The only difference I see is the time it takes to learn/use fastboot. I’ve tried via the recovery during lunch break but it was not successful (I thought it was worth the try). I’ve never used fastboot, so that may be a good opportunity :slight_smile:

1 Like

Indeed it would be a good opportunity in this case. :slight_smile:

I think having ADB/fastboot set up on your computer is aways good to have, as it can be very valuable and useful if you ever experience some serious issues with your phone.

ADB/Fastboot are great tools, having it ready and available in case something happens or goes wrong, can be very helpful.

Just heard the news: There is a new release for the FP Open OS. :smiley: Have a look here.


Hey MarcB, the latest Fairphone Open release has just been set live.
You can use that to switch from 1.5.1

edit: @Juli_R beat me to the punch. :slight_smile:


Thanks for the update ! Download is already ongoing ! :slight_smile:

1 Like

I’ve downloaded the OTA Build switcher, and after executing the Updater on the zip file, I still get the same behavior as in my original message, except that the text has “Install 28” instead of “Install 21”.

I guess I’ll have to use fastboot… Or maybe I could try to wipe data from recovery first and then start the updater again…

You could also try wiping cache and data of the Updater app, then reboot and try downloading the update again. And you might want to have a look into this useful wiki for troubleshooting. Anyway, to know how to use ADB/Fastboot is quite useful as @freibadschwimmer already mentioned. :slight_smile:

It looks like you tapped the ‘Download complete’ notification, but instead you should open Amaze (file manager) and tap the downloaded file from there :slight_smile:. Fairphone Updater should then show the full filename, instead of a number.

1 Like

That was it ! Maybe that would be good to have this somewhere… Or maybe it’s already the case and I’ve not been able to see it…

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.