"error downloading config file" or "Fehler beim runterladen von config file"


at my Fairphone 1 the message “error downloading config file” keeps popping up on a regular Basis.

How bad is that or what can I do against it?
Do have to reset the phone completely?

I have to admit that I did some adjustments to hide the Status of the phone to be rooted.
First, I had Xposed Framework and Root Cloak installed.
Now, I have uninstalled those apps and have installed Cydia Substrate and Root Cloak Plus instead.

However, I did that already some time ago, so no clue if this has to do with it.

I am happy for every hint.

Thank you in advance.

Best regards

Is it a popup with buttons or a notification in the notification drawer or a toast? Please describe the message in more detail or post a screenshot. :slight_smile:

It is a notification, white text in a dark text box at the bottom of the screen, no buttons.
It looks similar like when e.g. super user is granted from the app Droidwall

Ok, so it is a toast. This app logs toasts and I have just successfully tested it:

It will tell you the app that issued the toast. Please post again, when you have found the causing app of the toast message.

Thank you for this hint!

So, it’s the Fairphone Updater.

What can I do now?

Try clearing the updater app’s data in settings -> apps -> all.

1 Like

I did clear the data.
It keeps popping up.

Then the next thing I’d try is manually reinstalling/upgrading the OS.

An alternative strategy is to just not have the updater running, as there won’t be any updates for the FP1 anyway. I stopped it from starting using autostarts (now gone from F-droid, unfortunately), and haven’t had adverse effects. Based on that, my expectation is that if you can disable the app altogether it shouldn’t cause any issues. If you have adb installed on your computer, and usb debugging activated on the phone, connect the phone and on the computer do:

adb shell
pm disable com.fairphone.updater


It’s still available in the Archive repository that can be activated in F-Droid’s settings.

1 Like


sorry, that I did not reply for some days. It took me a little bit to take the time to implement this.
I did so at the end of last week.

Since then, there was no such toast. So, it seems to work!

Thank you so much for this hint!

Best regards