Endless Optimisation Restart Loop after OOS 17.01 update (encrypted + OpenGAPPS)

Well, I have to admit I never tried to make a factory reset from TWRP, but maybe it indeed needs to mount /data for wiping it.

For the exercise of doing a factory reset, you could also (temporarily) install the default Android recovery from a FPOS image, and then try to wipe /data from there.

If flashing the whole system image did not help, try to use the wipe option (-w) in fastboot. This should erase userdata & cache.

@freibadschwimmer did you apply the 17.01 update without this issue or are you sitting this one out?

I haven’t yet installed it, maybe I’ll give it a shot in the evening.

1 Like

@zybque was your phone encrypted? (As reinstalling openGAPPs got you out of the boot loop).
@goody , @meoblast001 What’s the error message you get when installing the openGAPPs package from recovery? Also, which versionnumber of openGAPPs are you using?

Also, as I replied to another post:
fastboot -w will erase userdata, but may leave encryption intact
fastboot format userdata is more likely to wipe out encryption along with the data.

1 Like

@Johannes No encryption.

I tried it several times and I always get back into the loop.

I upgrade the openOS with an encrypted FP2 with openGAPPS. And when things went wrong I read on the Forum that there are problem. It shouldn’t be possible to break a FP with updating the OS.

Anyway, how can I get my phone working again, when volume up and power on doesn’t work?


I finally succeeded with volume up and power to enter TWRP mode
and after reflashing openGAPPS my FP2 seems to work.

1 Like

I updated now as well to FPOOS 17.01, on an encrypted devices, and also encountered problems (maybe also @anon36364121 might be interested) .

I was following the update guide.
After the initial update process is finished in TWRP, and when the phone reboots, I usually go to recovery again right away to reinstall opengapps & xposed. However, I could not access recovery! When pressing [power] + [Vol up] the phone just rebooted twice after a short time (not sure if I can talk about a loop, as I aborted after not being able to enter recovery).
What I did to solve the problem was to install the community port of TWRP (as I still could get into fastboot). After this I could enter as usual into recovery and installed opengapps, xposed & Fdroid.

After that the phone rebooted normally, and I am running 17.01 now.

I tried to flash again the TWRP shipped with 17.01 manual-userdebug file and then could access the recovery as usual. I don’t know why it did not work after the update (which I initiated through the FP updater). It could be that either the recovery from the ota-update file was faulty or did not get installed properly. Though I didn’t experiment too much with it, I just tried to get my phone working again asap.

Anyhow, now running 17.01. Thanks for finally fixing the video focus :smiley:


Wohoo, though reflashing Open GApps, I got out of the bootloop! Thank you soooo much! At least I have a working phone now! Now I try to get a proper factory reset via the GUI. So thanks again and let’s see if everything works fine…


Hey, now I tried to get a full factory reset via the Android settings but it didn’t secceded. I really don’t know how to get rid of encryption and how to get a clean Open Android… Does anybody know?

I just had a little chat with @anon36364121 who is not sure he sees a specific issue with encryption here.

Is someone with encryption and OpenGapps brave enough to try updating to 17.02 - following the update guide to avoid the usual issues that may arise - and see if they experience this issue again?
“This issue” means you get into a bootloop without the ability to:

  • enter recovery or
  • re-flash OpenGAPPS or
  • do a hard reset.

Taking into consideration some good advise by @anon36364121 I have modified the update guide. It is now recommended to install all packages (fp-update file, xposed, gapps, …) in one batch from TWRP. This is faster and smoother, as you only once need to access the recovery, without any hassle after the first installation.

I just followed the modified update guide and it worked smoothly.


Thank you, Framb00s, and all the others. Flashing GApps got me out of a two day boot loop. Why do updates never go smoothly? :wink:

I want to upgrade to 17.02 but after the problems on my encrypted FP2 with 17.01 I’m hesitating.

I try to follow the upgrade guide but it is hard to understand for someone used to IOS.

I have several questions, the first one is
Why do I need 1.3 Xposed framework (installer134)?
Is Xposed normally an OOS application?

You don’t need the Xposed framework. The Xposed framework is a prerequesite for a lot of useful modules like GravityBox (modify almost anything of your phone’s behaviour and look) or Xprivacy (permissions management). I use both and wouldn’t want to miss them, but they are not needed for FP Open OS to work.

So bottom line: You can skip the Xposed part altogether.

Thank you for this quick answer.:slight_smile:

1 Like

Regarding the update guide:
Does FDroid need to be a system app?

I tried: ALTERNATIVE: Download “/system App Mover12” from F-Droid and make F-Droid a system app (for users who don’t know how to use ADB)

I installed system/app mover but it does nothing it needs something installed with Busybox so I installed Busybox, but it needs root access.

So my question: Does FDroid needs to be a system app to upgrade a encrypted FPOOS?


No you don’t have to do anything you haven’t done before the update.

The gist of the updateguide is: All modifications you did before the update (e.g. by flashing something via TWRP) you’ll have to redo after every update - and do so before rebooting. So: Boot to TWRP - flash the update - flash your other modifications - reboot to system.
I think I’ll add this to the guide, to make it more clear you don’t need to do everything in the guide.

Thanks, I’ll try it.

Quoting myself…

I hope that someone can help me with either disabling encryption or telling me how to flash Xposed and OpenGAPPS after all…

I don’t think that flashing gapps or xposed had anything to do with encryption, as encryption only concerns /data partition, while gapps and xposed are installed on /system.

If you encounter problems while flashing with your recovery, you could try though to use a different recovery version for flashing. Though I’m not sure if this helps, but worth a try.

Getting rid of encryption is, to my knowledge, only possible through a factory reset and erasing/wiping /data partition.