Endless fastboot installation - still waiting to complete... :(

Following the steps described here…


… I tried to manually update Android on my FP2.

The script does not show any errors, it keeps running, and looking at the Linux process I can see that fastboot uses 3 to 4% of CPU and is still active.

But the description on the page linked above tells me

the process will be over in a couple of minutes

so I ask myself after one hour of waiting: How many more minutes to go? :confused:

Can anyone help?

does fastboot devices provide any output?

$ sudo fastboot devices
[…]
fed2f60d fastboot

are you running the updater as root as well?

1 Like

No, the instruction didn’t say that. And now I don’t want to stop the running process because this could break the phone (I think).

What’s the last output of flash-for-unix.sh?
Just before it starts sending data, it should say ‘Proceeding to flash the device.’.

$ sh flash-for-unix.sh
** Fairphone OS 17.09.3 Manual Flashing Script **

Validating files…
Validation complete.

That’s all.

In that case I don’t think it has touched the device yet. It should be safe to stop the script.

It may work better running as root - try fastboot devices without root to see if that throws an error. I think the error handling in the script hasn’t been properly designed to detect permissions errors.

1 Like

Yes, fastboot devices throws a permission error. That’s why I used sudo.

But you are sure, it is no problem to stop the script while Fastboot still uses CPU?

Okay, I tried sudo sh flash-for-unix.sh and now the script continues. :thumbsup:

@staff: Who can change the instruction?

Thank you for your help, @Johannes! :clap: :thumbsup:

Glad it worked out, sorry for not answering the question about CPU usage - I was away from my computer for a while.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.