English

Encrypted FPOOS 18.10.0 upgrade: TWRP 3.2.2 & 3.2.3 install fail?

[EDITED to correct TWRP version typo]

How does one upgrade an encrypted FP2 running FPOOS to 18.10.0?

So far as I understand, I need an upgraded TWRP; it appears that TWRP 3.2.1 (which I used to upgrade to 18.0.4) is insufficient because it fails a digest check on the .zip. However with either TWRP 3.2.2 or 3.2.3, whether I install them using the TWRP app or from TWRP itself, my FP2 hangs at the Fairphone logo when I reboot to recovery/TWRP with Vol+ pressed. After a reboot to FPOOS, the next reboot to TWRP finds me back at the default 3.0.2.

Anybody else experienced this?

Previously, my FP2 displayed an “upgrade available” message for a short while after 18.10 came out, but it then stopped. Even after I manually upgraded the Fairphone updater app to the latest version, it still didn’t detect an upgrade; however after manually downloading the new sibon .zip I found I could open that file using the updater: doing so only paused for a while, then rebooted me to TWRP.

I experience this “reset behavior” as well, and I am on 18.04.1.
Haven’t tried higher TWRP higher than 3.2.1, and maybe someone (that has more time than me) should verify if there is a working TWRP version (or whatever is causing the TWRP reset) for us that are using Encrypted FPOOS.

Or: It could be that TWRP 3.2.1 is the only working version, and in that case the fail on the “digest check” is correct. Maybe the 18.10 is broken.

Myself also got a message that “Android 7 is available”, but because that message never got back, I instead noticed that if entering “Advanced mode”, there is no longer any link to “re-install official operating system”. So my guess on this is that something went wrong, and that the highest FPOOS upgrade (as of this date) is still 18.04.1

There is no such thing as TWRP 3.3.2. The latest version at this time of writing is 3.2.3:

https://twrp.me/site/update/2018/08/06/twrp-3.2.3-0-released.html

In TWRP there’s a way to disable the digest check.

3.3.2↔3.2.3 typo corrected.

TWRP 3.2.1 appears to be known to be insufficiently recent precisely because it is incapable of ignoring the digest check: even if you clear the check box to disable digest checking, the 18.10 .zip fails a digest check and so can’t be installed. Is there a way to provide the digest?

If you have the stock recovery from Fairphone Open OS 18.04 the upgrade should usually work (though some system modifications may cause problems). If your phone was encrypted in Android 5, you will need to disable secure boot before updating. If you want to flash things like openGapps, you will need to update TWRP after the update, as is discussed here.

To clarify for those finding this topic later, this is the expected behaviour. If the first boot after installing a TWRP version not released by Fairphone is not back into TWRP (but into the regular system) the update will not be persistent - i.e. it reverts to original version. The issue here, is that the reboot to TWRP isn’t working:

This is strange. It almost sounds like you’re in bootloader mode. When it stalls on the logo, does the phone respond to fastboot commands?

Which file exactly? The files ending in manual.zip will not install via TWRP. The ones ending in ota.zip may not work with some system modifications.

2 Likes

Hm. So I was using the fp2-sibon-18.10.0-manual.zip file linked from the 18.10 release notes page. I’m pretty sure that previously I had to upgrade by downloading a file for 18.0.4.1 and installing it from TWRP, so was attempting to repeat that process. Seems unfortunate that that no longer works.

This then gets back to my original question: how does one upgrade an encrypted FP2 running FPOOS to 18.10.0?

My phone is no longer displaying the “update available” message; the Fairphone Updater lists no updates, even though I’ve upgraded it to 1.39.15; and opening the fp2-sibon-18.10.0-manual.zip file using the Updater simply reboots to TWRP, with ensuing fail. Is there an -ota.zip somewhere that the Updater can use successfully?

Is the only option for encrypted FPOOS then the final “fastboot” process outlined in the release notes? Where is fastboot documented? Searching for “fastboot” on code.fairphone.com only produces results which seem to assume (like the release notes) that you already know what it means.

Installing manual update files via TWRP never worked, they are meant to be installed via fastboot.

Installing the OTA files via TWRP works, there’s one for 18.10.0, too.

Same thing … use the OTA file with the Updater, not the manual file.
The Updater reboots to TWRP because TWRP then should install the update file … not happening with the manual update file.

Here for example: #dic:fastboot .

3 Likes

I experienced a very similar problem. I’m also running FPOOS encrypted and got the message that I could update to the 18.10.0 version. After my first attempt my phone booted in the TWRP 3.0.2 boot screen. I never even got in the GUI of TWRP. I just could stare at the bootscreen.

So I tried an other time and again the same result. So I did an update of TWRP as well (with the app) and now the updater doesn’t mention any update any more.

How shall I proceed?

… or you can try to open the OTA file with the Updater App, it will reboot into TWRP and in an ideal case install the file automatically.

Thanks @AnotherElk: with that pointer I can confirm a (so far!) successful upgrade to 18.10.0. I downloaded 18.10.0-sibon-280f64b0-ota.zip (as linked from the code.fairphone.com “Download Releases” page you point at) and then, after re-upgrading my TWRP to 3.2.1, was able to install from TWRP.

In case anybody from the FP team reads this, could I suggest you please mention some of the following in future release notes?

  • Link to the -ota file from the release notes.
  • Explain the difference between the -ota and -manual files.
  • Acknowledge the TWRP-based upgrade path and encrypted dependence on TWRP 3.2.1 for upgrade. For people running encrypted FPOOS I think this is the most convenient option, since it allows you to upgrade from the 'phone without using another computer. It is in principle very easy once you have all the parts.
  • Link mention of fastboot to something explanatory (e.g. the link @AnotherElk provided).

I realise that release notes can’t aim to cover everyone and all circumstances, but surely running an encrypted FPOOS isn’t that rare!

Retrying this, I find the following:

  • Installing TWRP 3.2.2 to recovery and then rebooting to recovery leaves me at the initial white-on-black Fairphone logo permanently. A long press on the power button results in reboot to FPOOS. While in this state, plugging the 'phone into my Linux box and typing (for example) fastboot reboot has no effect (if I reboot the phone with Vol- pressed then fastboot reboot reboots my phone as expected).
  • Installing TWRP 3.2.3 to recovery and then rebooting to recovery now seems to work, except that the version number that TWRP displays on reboot is 3.1.1-0. Since I think I read that that’s now the fallback TWRP for 18.10, is it possible that the install silently failed?
  • Installing TWRP 3.2.1 to recovery and then rebooting to recovery works as expected, displaying a version number of 3.2.1-0.

Thanks! I the end it worked wonderful. I just took away my security log in, like they mentioned on the FPOOS webpage. And the update ran smoothly. I’m now enjoining an android 7 phone.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.