Enable HD Voice on the Fairphone 1?

I got answer from Fairphone support:
(For other interested people)

Dear Dominic,

Sorry for not coming back to you earlier.
I have finally found the reason why it is not working. We had to disable it because of compatibility issues with the T-mobile network.

We do not have plans to enable it again at the moment because of the limited resources we have.


the thing is that we had to turn it off inside the modem firmware.
This is not something you have access to, so no, I am sorry but you cannot set it by yourself


Oops, I have spoken too quickly.
Just got note from the software team that as this was related to the modem firmware, it won’t happen because we cannot tamper with it. That sucks