Enable 3G needs plane mode first

So my phone’s 3G is always disabled.

But sometimes I need to activate it. And it also activates itself when I receive a MMS.

My problem is that when I turn it off, for some reason, I can’t turn it on again. I need to go to plane mode, and then hopefully it works again.

I am aware there may be just a few of us disabling 3G by default, but it is a pain not to being able to use the 3G switch as expected.

I hope I was clear. :confused:

Thanks in advance

Are you talking about 3G (UMTS in Germany) in general, or data connectivity? I guess the former, right?

A possible workaround could be using GravityBox (from the XPosed Framework), go to Statusbar tweaks, select QuickSettings management, then choose to show “Network mode” under Statusbar QuickSetting tiles. When you go to the Quick settings now by opening the notification drawer (downswipe) and the do a sideswipe, you should see which network mode you are running at a glance, and can change it by a tap.

Would that help?