Editing a contact doesn't work

So I added a contact, but misspelled the name. Went back and edited the name. All seems fine. I press done and goes out of the settings screen. The old misspelled name is still there. So I go back to edit it, in the dit screen the name is already corrected from before.

Why wont my phone mirror the edit? I tried both from phone dialling and people.


where is “there”? On a widget at your Homescreen? Widgets often take a while before they refresh.


I don’t think I ever went into widgets. I went into contacts or whatsapp and the misspelled name is still there. But when I go into editing the name has been corrected. I know it sounds strange…

Is it maybe an issue with the extended names? You can click on the small arrow downwards (like a small v) next to the name, when you are in the edit menu, and it will expand to insert First, Last, Middle, … names. Maybe there is an entry that doesn’t match?


I don’t use WhatsApp but many chat programs have there own Adressbuch and just connect the contacts to your address book.

Maybe you have just edited the contract of the “normal” addressbook but not the WhatsApp contact.

Is there an option to edit the contract directly at WhatsApp?


Tried both, nothing happens. It’s still the same in all the places.

Thank you for your help though. I think the only way is to delete the contact and fill it in again.