Edge when enabling second sim card

I have an issue with my Fairphone2, I wasn’t able to solve. I got a second SIM 2 weeks ago, and I had some troubles with Mobile data connection. I need to use SIM 2 data connection while maintaining SIM 1 enabled but I noticed that when I disable SIM 1, SIM 2 connection works properly (3g connection gets available and I can use internet); instead, when I enable SIM 1 again data connection stuck into Edge and can hardly ever use it.
At the moment my configuration is the following:
Sim 1 -> enabled -> preferred network type: 2G
Sim 2 -> enabled -> preferred network type: 4G

Preferred SIM
Mobile data: sim 2

In Data usage section I also disabled Mobile data for SIM 1, and I left it enabled for SIM 2.

Is something wrong with my config?

I would be grateful for any help and advice!

You can’t have both Sims on3/4G.
Only one Sim can have 3/4G. So you have to choose which Sim gets 3/4G.


Hello @Lidwien,
thanks a lot for your reply! I checked options on Sim 1 card, and all I can choose is 2G or 3G or 4G. For this reason, I thought to configure Sim 1 as 2G and Sim 2 (that I want to use for Mobile data connection) as 4G.
Could you suggest me something different I have to do?
Thanks a lot,

Yes, that is indeed what you should do. Maybe you just need to switch it back and forth once, setting SIM2 to 2G and then back to 4G?

You can also try swapping your SIMs and then setting SIM2 to 2G and SIM1 to 4G.


Have you already tried switching the cards?
Otherwise your settings seem correct, especially since it’s working when you use the second SIM only.
Or maybe it’s a problem caused by the first SIM?
You could ask your operator for a new one (an exchange might be for free even); possibly there’s a new version available. Your operator should at least be able to tell you, if the SIM might be causing problems when being used in a 2 SIM environment.
An internet-search could be helpful in this case as well, as you surely would not be the first one to run into trouble. Try searching for the SIM-card version number that is printed on top of the card together with the provider.
All of this is just wild guessing unfortunately.


@AlbertJP Thanks a lot for your reply, I’ll try both solutions!

@BertG thanks to you too for the advice, I’ve been searching a lot on the net during these days about this problem but I didn’t find anything useful to solve it. No, I didn’t switch the cards yet, I will try! If I won’t solve I’ll try to ask SIM1 operator too.

Hello guys,
Thanks to your advice it seems I can now use my new Sim data connection properly! First I tried switching back and forth SIM2 setting to 2G and back to 4G (I rebooted my phone too after each setting change), but that didn’t solve. Than I swapped the SIMs, and that worked perfectly! I will ask my older SIM operator to provide me a new one too, I think that is a good thing anyway. You all have been really precious, I’m going to check the topic as solved.
Have a great evening,

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.