English

Early test with Swiss COVID-19 app

Today, I read a blick.ch article about the new COVID-19 tracing app, because the Google Play Store link has been “leaked”.

So just for interest, I tried it out. Result see the following screenshots:
Screenshot_20200527-083653
Screenshot_20200527-083706
So the question just is: Are there any plans for shipping a new Android OS image via Fairphone Updater containing the new API for tracing apps?

Do you have this problem on a Fairphone 2 or 3?

1 Like

It’s on the Fairphone 2.
OS = current 19.11.2 image.
Probably

might be interesting for the Fairphone OS developers.

I’m using SwissCovid/SwissPT and it’s working with my FP3 :slight_smile:
afaik the API is provided by Google Play Services to provide the API for older devices too.
Thus you should check wheter your Play Store/Play Services are up to date

2 Likes

Thanks for the hint about the Play Services component. I recommend to provide easy understandable instruction how to update this component. Otherwise, all planned COVID-19 apps would be result in a big failure when the majority of Android users cannot use it because of lacking this API…

Apart from the fact that I personally would never use these apps, that’s not true. The austrian red cross app doesn’t use this API, in fact I didn’t know until now that there even are apps that use it.

1 Like

that’s no true anymore.
I’ve read that they’re planning to switch to the decentralised dp-3t based standart as their current structure is way less privacy preserving than dp-3t:

normally those updates are provided through Play Store. I’d recommend you to check for updates there :slight_smile:

PS. what really bothers me is that there is currently no way to use the CovidSwiss-app without Google Play Services as the funtionality is based on the Google Exposure Notification API
I’d like to switch to LOS on my FP3. But at least I’m not the only one with that issue: https://github.com/DP-3T/dp3t-app-android-ch/issues/59

3 Likes

Without large comments:
Screenshot_20200528-190128_AppStore_aktuell

Screenshot_20200528-190142_OS_aktuell

If somebody knows a further menu option where software can be updated, please let me know.

I have Google Play services v20.15.16 from may 4th
photo_2020-05-28_20-14-50 photo_2020-05-28_20-15-06

You might check this on your FP. There is also an option to join the beta-program.
But I think Google has a shedule on how they are providing updates. Therefore not every update is available at the same moment on all devices…

1 Like

I believe those kind of updates you won’t notice as a regular app update. The play store becomes active sometimes a few times per day by itself updating Google Play services with some “security policy” and maybe - an explicit notification of this kind I’ve personally not seen so far - some API changes. I get the mentioned updates only when connected via Wifi.

I believe, you do see the downloading & installing status bar in the top drawer when it’s busy, just like for any app update from the Play Store. But that can easily go unnoticed if your phone is always connected to wifi.

In the meantime, a new version of the COVID-19 tracing app has been released. So the error message changed:
Screenshot_20200531-195923
About Google play service:
Screenshot_20200531-200016_Vers
It’s the same version as posted by HolosericaCaligo.

In the mean time, the Swiss government started a penetration test at

https://www.melani.admin.ch/melani/de/home/public-security-test/scope_and_rules.html

Is it possible that the question of the new API necessary for the COVID apps is related to the Android version?
FP2 is on Android 7, FP3 is on Android 9…
I’m on LineageOS 17.1, that is Android 10, but without Play Services and I get the following information: Screenshot_20200531-211038_SwissCovid

1 Like

Android 7 should be supported by the API.

The only thing I found regarding the error code 39501 is this issue-post on github:

There was a newer Android-OS involved and even newer Play Store Services than in your case.
One thing what was mentioned there was that he used his smartphone with a second user.

I think the devs there could help you more…

1 Like

Hello Meilebiz,
Are you running Fairphone OS with Google Services or the Open Source version?
Thank you!

Hello
I have a FP2, OS 19.11.2 with root and Google Play Services 20.18.17 (last update 15.5.2020) and I get the same Message like Meilebiz.

I think it’s not the OS or the Google Play Services, but something with the Bluetooth Software. I tried to find an app to add the support for Bluetooth Multiple Advertisement - but it is a Topic to complicated for me…
So, if someone has an idea or a hint - it would be welcome!

Hello everyone,
I’ve had the same two error messages on my FP2 with the SwissCovid App. But since this morning, they are gone and the tracing is activated. My Playstore Version is 20.3.12-all.

Wonders happen: It works now. :slight_smile:
Screenshot_20200604-125821
So I checked the Google Play Services version again:
Screenshot_20200604-125747_Vers
So for me, I just looks like 20.15.16 just was obsolete for the new API.
So the solution is just: Upgrading Play Services to 20.18.17 or later is necessary.

Note: I didn’t manually update anything, is was updated automatically.

For the interested guys here:
Screenshot_20200604-131355_Vers2
This screenshot shows the recently upgraded components and apps. I suppose that Google Play Services is covered by the Google app itself.

1 Like

Did anyone verify if the switch covid 19 app, which uses Google Notification Exposure, actually is able to send Bluetooth LE beacons?

At least in the German Corona-Warn-App it looks like the Fairphone 2 is lacking some Bluetooth LE capabilities to actually send any BLE Beacons due to lack of Bluetooth LE “peripheral mode support”.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.