/e/ - Screen rotation problem

Ok, I just installed UBports on a Fairphone 2 (Oh, the installer works, when did that happen :slight_smile: ?).

I rebooted into fastboot mode … it’s as you say, UBports changed the splash screen … but that doesn’t matter.

fastboot devices found my phone.

And fastboot flash recovery twrp-3.3.1-1-FP2.img successfully flashed TWRP to the phone. Looks like this:

>fastboot flash recovery twrp-3.3.1-1-FP2.img
Sending 'recovery' (10384 KB)                      OKAY [  0.333s]
Writing 'recovery'                                 OKAY [  0.117s]
Finished. Total time: 0.508s

And now I have TWRP when I boot into recovery.

Sorry, I don’t see what’s wrong on your side. I’m using Windows, though.

Maybe try a different cable?
Or the official platform tools (could be newer than what your Linux has)?

1 Like

Thanks that you take so much time for my problem.
Well, I am with the actual adb and fastboot tools.
Trying UBPorts installer anew. He’s stuck too.

I guess I bricked the phone… I can’t restart or switch it off anymore, unless by taking out the battery. I can’t enable developer options since there is no OS. :grimacing:

You “just” need to get the fastboot command to work somehow, as it seems booting into fastboot mode still works.
Can you try on another computer? Windows preferrably (tends to give less trouble with this)?

Keeping the power button pressed for approx. 15 seconds should force a reboot.

Same thing, waiting for device

That works, it restarts in the same “Fairphone powered by ubuntu”-screen at which I glare the whole evening… :crazy_face:

It would be good to be certain the phone is really in fastboot mode and not just hanging while trying to boot.

Do you still get into the UBports recovery by keeping Volume + pressed when starting or rebooting the phone?
(This recovery takes a while to start.)
There should be an option somewhere to reboot to bootloader or fastboot mode. That should definitively reboot the phone into fastboot mode.

Then … If fastboot on two different computers doesn’t find the phone in fastboot mode, there could be something wrong with the cable or with the USB port of the phone … which reminds me …

1 Like

Awesome hint! Yesterday it was too late, I didn’t see it anymore and was too tired, but this morning with a fresh head I tried to boot into recovery - and TWRP is there! :sweat_smile:
I think from there we can try to manage something… I am looking now into it.

Thanks for the hint! :sunflower:

So… I tinkered around with it.

  • adb works now, and with sideload I could install a fresh /e/. I think it works, I just played around a bit.

  • But the original problem is still not solved: still no sensors working (unless GPS and audio).

  • I tried to recover a TWRP-backup of my system, which didn’t work. And still the UBports boot screen.

  • I couldn’t make fastboot work. Still waiting for devices.

Hmm. :thinking:

If you could do adb sideload, then cable and USB port are ok.
Go to TWRP’s Reboot menu and reboot to Bootloader. Then try fastboot again.

This will not change until you fastboot flash splash splash.img.
You can get the original splash.img from the manual Fairphone OS install file, or the Fairphone Open OS one.

I’m not certain whether TWRP could install splash.img to the splash partition, although it can install recovery images to the recovery partition … perhaps worth a try, too.

TWRP most certainly didn’t say that it “didn’t work” and nothing else :wink: .

1 Like

Cool, yeah, that works! Thanks for helping me understand that better!

True. In fact TWRP was happy (installation successful), but when I start /e/, it is like a fresh install (I need to set up my accounts and my settings etc…). It this normal for an TWRP backup? I was aware that /data/media is not backed up, but I thought I could go back to my set up system…

I heard about LOS 17.1 being out for the FP2. So I thought, if I already have to reinstall everything, I can flash LOS 17.1 just to give it a try and go back to /e/ later. The installation went well with the LOS recovery, and now I am running LOS 17.1 - and the best thing: SENSORS WORK AGAIN! As @stanzi I can’t explain why, but they work! The first time that I could use the Calibration Tool! I hope the sensors will keep working when I go back to /e/ … but that will be another story for another day.

Big THANKS to @stanzi and especially @AnotherElk for the great help and taking the time to think and try on their side!!! :heart:



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.