/e/ for FP3 (Google free OS)

Got it, so it’s doable, great! Thank you!

This explanation of course requires (Debian) Linux.
For us (stupid) Windows users it seems to be a bit more compicated. :wink:
@AnotherElk has already posted a solution in posting #39 in this thread

1 Like

I haven’t tried root yet (stupidly locked the bootloader before realising that I could easily have rooted my phone at that point), but otherwise I’m really happy with /e/. Even the power consumption is visibly better. After the latest update, LiveDisplay also works, so I uninstalled Red Moon, which I had installed as a replacement.

Now my only issue is that I don’t have TTS installed, which is a bit weird when using the GPS. I tried Espeak from F-Droid but it crashes, so I tried Flite and it works. I can now at least use my GPS navigation voice in English. It doesn’t have Greek installed, which offers a lot of hilarious moments when driving in Greece. But that’s currently the least of my worries.


For reference when using OsmAnd for navigation …


Fastboot should work very similar on Windows.

You can run a virtual machine from Windows with any Debian-based distribution installed just for this purpose. The process is very straight forward and knowing how to run a virtual machine may very well be worth your time, since there are many uses for it.

Another alternative is to create a bootable USB stick so that you can run Linux without install it.

1 Like

[does anyone know whether] Does the system is rooted by default on /e/ ? Or is it rootable easily ?


Wrote several posts ago in this thread:

In order to root /e/, I did this :
Assuming that :

  • you have downloaded Magisk-v20.4.zip to your pc
  • you flashed /e/ partitions (following those instructions )
  • you left the bootloader unlocked
  • your phone is still connected to the pc via usb
  1. Boot into recovery (the /e/ recovery)
  2. Tap on “update” button
  3. Then tap on “adb sideload”
  4. On your pc run adb sideload Magisk-v20.4.zip
  5. On the phone you’ll have to confirm flashing an untrusted update
  6. At the end of the process, go back to the system and wipe the data (not the system)
  7. Then reboot normally (the system will reboot once)
  8. And finally install MagiskManager-v7.5.1.apk
  9. Do not lock back the bootloader : it will corrupt the system

Final observations :

  • It could be possible to install MagiskManager-v7.5.1.apk first and then install root from it : there is an option to do so but I didn’t tried it…
  • The developer options (in the main system menu) won’t show that the system is rooted even if it is (it will only show something like adb root and no application root )
  • I corrupted the system by locking back the bootloader (sometimes I do stupid things). But it’s quite easy to solve this problem : just flash everything back, following again the install instructions of /e/ .
  • I read somewhere (sorry l forgot the original post) that this operation might have to be repeated after each update (does it mean that we’ll have to backup the data each time ? I don’t know…)

Just installed it, and extremely happy with it, Fairphone + no Apple/Google involved! Everything works great, except for some very minor thingies. Thank you very much, I’m very grateful. It feels like I’m finally dodging the bad guys (well at least, phone-wise).


I put /e/ on my FP3 2 weeks ago and rooted it just as lost_geographer described. I’m very satisfied with /e/ but I have random system crashes. The phone just turns off. Sometimes while I’m using it, sometimes while I’m not. Most times it happens when I see the the light blinking because of a message I got and try to unlock the phone with fingerprint, after a short vibration the phone is turned off. It also happens more frequently while I’m at my university and connected to eduroam. Is there some way to track this in more detail?

Thank you for these instructions!

I followed them and now whenever I boot my Fairphone 3, there would be an initial screen warning that there’s not way to check my system for corruption that makes me wait 5 seconds before booting /e/ OS. Is this normal/expected given the unlocked bootloader and I can safely ignore it? Thanks!

Yes. This is perfectly normal.

1 Like

Got it, thank you! :slight_smile:

Hi Bert, I am at exactly this same (anxious) point to really go ahead and install /e/ on my new FP3. ADB and |Fastboot are installed and running properly, bootloader on the device is unlocked. I downloaded the dev file on my pc.

You are quite right that the explanation on the install page is indeed somewhat incomplete. Like you, I am also trying to figure out in what folder I should unzip this dev file in Win 10. Apparently you found out, but I can’t see that you mention the folder. Should it be unzipped in the platform-tools folder on your pc? Because if it’s not, then how can the pc/adb (in cmd) ‘find’ the unzipped os-files?
I assume it should not be unzipped on the device itself?

And btw, in cmd (on Win 10) ‘unzip’ is an ‘unknown command’. Even if you add the pathway to the unzipped folder.

Hope you or someone else can shed some light on this, so I can really move on…!
Thank you!

1 Like

Hi Jella,

I unzipped the file under windows file-manager and not in the terminal-application-window.
Yes, if I recall it right, I unzipped the image-files to the platform-tools folder.
I just took care, that I was working in the directory, where the files were located (so I did not need to add a path).

I keep my fingers crossed. And if the files should not be found, I guess this can do no harm.

I can confirm that you have to unzip the files in the platform tools folder. When you are in Terminal, you have to work from that folder, otherwise it won’t work.
It’s true maybe they should have made it clear.
Maybe they didn’t because it’s probably kind of obvious when you know your way around that kind of thing!

The thing is: strictly speaking it does not matter all all where you unzip the folder to if you know how the command line works (nowadays most people usually never need to).

It seems that it’s easiest for most people to just put everything into the same folder. But then you got to hope that not two archives contain files with the same name. For the platform tools and custom ROM images this seems to be rarely the case, so it’s ok here. But strictly speaking it’s not a requirement.

But then you have to add the path to the files to the command. And that explanation is clearly missing.
And who - in times of graphic user interfaces - is still used to command-line operations.
Clearly a Linux user has done the explanation. :wink:

Has anyone already successfully kept root during an /e/ update without the need of a wipe?

You still have to flash the Magisk zip using the adb sideload after each update.
I didn’t wipe the data after the last 2 updates of /e/ and I had no problems apparently.