English

/e/ for FP3 (Google free OS)

Where do you see the apps registered in microG ? I would like to show you what I have to see if it’s related to it.

settings -> microG -> Google Cloud Messaging

:hugs: But I wanna get rid of the “Google Play services”

1 Like

I’ve desactivated microG and I receive push notifications (from Telegram, QKSMS and others), so I think the problem is somewhere else ^^ (Or I did’nt get the thing). Screenshot_20200509-000039_microG_Services_Core

SMS are pushed by your network provider and Telegram FLOSS (the F-Droid build) maintaines a background connection to Telegram servers to allow for timely messages.

If you have WhatsApp, you will notice that some messages only arrive when you open the app.

2 Likes

MicroG settings > Google Cloud Messaging

I had the microg “installed but not connected” bug.
I fixed it doing this :

  • Reset the phone (flashing unlock/flashing lock is enough since it erases userdata)
  • Before installing any app :
    • Open the dialer
    • Type *#*#2432546#*#* (*#*#CHECKIN#*#*) to force the registration to GCM
  • Install my apps & restore my data.
4 Likes

OK, so I finally walked the mile and installed /e/!
I’ts fairly easy if you’ve already messed around a bit with fastboot previously, which was my case, even though I have no programming skills. Just stick to the guide and it all goes smoothly.
I’d already tested /e/ on my backup FP2 and migrated my contacts and calendar to their nextcloud server beforehand. Same for SMS and call log.
Both my SIMs worked fine from the start, data and everything.
On the other hand I don’t have visual voicemail on the dialer anymore and can’t find it anywhere.
Considering Bliss launcher, while it might be a comfort for people considering switching from an iphone, I’m far too used to Lineage and I installed Trebuchet… What a bliss! :laughing:
Couldn’t get my way around /e/ email app and installed Fairemail which seems to do the job.
I found out I’m in fact using /e/ as a Lineage 16+microG install!
I fiddled around with my smartphone for part of the day. All works well except for a few freezes, but I was doing a lot at the same time.
I found out I was missing some Gmaps features so I installed an older version (9.84) which doesn’t bother me with the g***** play services message and seems to work fine without logging in to an account. Waze works fine on the other hand.
Going completely G***** free isn’t that easy, it’s something like an addiction and takes time!
I’m probably also going to miss Android Auto a bit, but not a big deal.
All my other apps I got from /e/ store or Aurora. They all work fine including the banking apps.

5 Likes

Which features?

I was positively surprised about the preinstalled Magic Earth App … it has real-time traffic data (congestions, road blocks, etc.).

Formerly I just used Firefox/Fennec’s feature to put a website link to the home screen, so that the website would open without the browser UI and thus feel like an App. This way a link to the Google Maps website did suffice as an OsmAnd alternative when needed.

/e/'s store includes a lot of cost-free Play Store Apps via Cleanapk.org … Which ones were you missing? Or were the versions outdated compared to Aurora (I have read about this but didn’t find an example myself yet)?

One feature I like in Gmaps is that i can look up a shop/ restaurant or anything else and get all their details and call them immediately or start navigation.
Magic earth I agree is very good but lacks this “search anything you want” ability. I’m pretty sure I’ll eventually find an alternative.
As you say, maybe a simple li,k on the homescreen…
Concerning the apps, one of my banking apps wasn’t on the /e/ store and several I use for work (medical).

2 Likes

You can submit any app for proposal (settings -> request app) in /e/ apps (but naturally you still can’t have it at once then).

5 Likes

True.
I noticed today that sometimes the /e/ store kind of disconnected and gave a “no result” to a search. When restarted, it gives a result for the same search. This probably caused me to wrongly assume that some apps weren’t on the /e/ store.
Will see in the coming days…
I can also confirm that the fingerprint sensor works much better. It didn’t rally bother me before, but I’ve noticed much less “false tries”.
Wifi calls also work with one of my 2 SIMs (SFR France). The other not working (Bouygues Telecom France) is due to provider restrictions. Although SFR doesn’t officially support Wifi calls on FP3 either.
So for those who were asking, Wifi calling with /e/ is working!
Can someone confirm if visual voicemail is working or not?

2 Likes

Just flashed /e/ on my wifes FP3.

I have to admit, that I was a bit anxious, since I haven’t used a terminal application in years.
But everything worked like a charm.
Still I would not advise this for technically inexperienced people.
The explanation on the install page in some points is a bit incomplete.
E.g. there is no mentioning to start a terminal application (this obviously seems to be such a basic thing, that is is omitted on the adb/fastboot page as well); and there is no mentioning where to unzip the /e/-image files.

But for me it worked and feels great.
And all the apps needed are available in the /e/-store.
I love it!!

4 Likes

There is also a more detailed installation howto: https://community.e.foundation/t/how-to-flash-e-os-on-fairphone-3-using-debian-based-gnu-linux/15498?u=ingo_fp_angel

4 Likes

Is there one such explanation for us Windows users? :wink:

My guess would be, that the average Linux user is much more used to the terminal application and command-line tools than the IOs or Windows user. But I can be wrong of course.

I have /e/ installed for almost 2 weeks now.
I was a bit worried about power consumption and applications without running Google services. But almost everything works like a charm. For local apps (like weather, local news etc.) I use Aurora store but I almost do not need to open it.
Only thing that worries me is my local bank app - as soon as it does not find Google Play in device, it shuts off - so I’m forced to access my account through web browser.
I have suspicion that Google SafetyNet service is not available yet which should cause the problems. Also I did not manage to get Google Pay working - stuck on login and does not open microG account.

About installation: BertG is right but the guide says “do not install until you know what you are doing” so you should probably be able to figure out some process details like where to unzip or what to do in command line or terminal.

2 Likes

You are soooo right.
That’s what made me so hesitant.

And maybe the warning does work in this kind of circumstances; but usually there will be one or the other odd user giving it a try anyway or skipping that kind of information by jumping straight to the start of the process. (The acronym DAU could have some meaning here, though it seems a bit harsh in this case.)

1 Like

But real-time traffic was from my (single-time) experience less reliable than gmaps. And a feature I really like with gmaps and haven’t found somewhere else are route alternatives while driving.

The fdroid Opencamera App works for me though.

Including HDR modes etc.? Normal functions of the /e/ fork of opencamera work, too, just not HDR for example.

I can confirm HDR mode doesn’t work. The app stops after the photo is taken.