/e/ for FP3 (Google free OS)

Oh ok, I never had that chance with the fp3 stock rom. I will see what happens with /e/ updates… :smiley:

In order to root /e/, I did this :
Assuming that :

  • you have downloaded Magisk-v20.4.zip to your pc
  • you flashed /e/ partitions (following those instructions)
  • you left the bootloader unlocked
  • your phone is still connected to the pc via usb
  1. Boot into recovery (the /e/ recovery)
  2. Tap on “update” button
  3. Then tap on “adb sideload”
  4. On your pc run adb sideload Magisk-v20.4.zip
  5. On the phone you’ll have to confirm flashing an untrusted update
  6. At the end of the process, go back to the system and wipe the data (not the system).
  7. Then reboot normally (the system will reboot once)
  8. And finally install MagiskManager-v7.5.1.apk
  9. Do not lock back the bootloader : it will corrupt the system (but it’s quite easy to solve this problem : just flash everything back, following again the install instructions of /e/).

Final observations :

  • The developer options (in the main system menu) won’t show that the system is rooted even if it is (it will only show something like adb root and no application root)
  • Step 6, the data wipe, is just recommended once. It is not necessary when you’ll root again the system, after an OTA update.

Thank you for your good description @lost_geographer

I was afraid the booloader would break. The question if you have to repeat this after every update, probably yes, who says that you have to do a factory reset when you install magisk?

How can I get the app data of my apps from Fairphone OS over to /e/? E.g. KISS settings, WhatsApp settings (without Google) etc.

I moved from Lineage OS 16 to /e/ and used adb backup/restore to get data over for the applications I cared about. But that’s a rather tricky process with a lot of hoops to jump through so only recommended if you have some terminal/Linux experience really.

It would be interesting to hear if someone else had a better non-root way of migrating to a new OS!

1 Like

I (1) have experience with Terminal and Linux, (2) am not rooted. The last time I tried adb backup was with my FP1, which never succeeded…

You might have a look here (it might help even though it’s not exactly referring to moving from FPOS -> /e/).

Regarding the factory reset, I followed the official magisk instructions here (stage 9).

Okay it seems magisk is already prepared to keep its root at OTA.
-> https://www.thecustomdroid.com/install-ota-update-rooted-android-device-guide/
We will see if it works when the first OTA update arrives.

Until then we should probably recommend for all who want or need root to not close the bootloader.


Then a follow-up tip: I used adb backup of the whole phone (all apps), and then used this guide to extract one app at a time. After the upgrade I used adb restore (after first installing the apk with adb install). That worked every time!

Use the same guide to verify that all applications you care about are included in the backup first, quite a few have the no backup flag and are omitted.

1 Like

adb restore did not work for me (no data recovered). Maybe that was because I have no root access on both phones. I modified the complete ab-file so that I would restore only one app, but that did not work as well. (But maybe I should have read the guide because I did not include/change any file-lists)

I could transfer few apps with helium in a very tedious work and contacts and SMS via MyPhoneExplorer. Whatsapp (and other messengers) offer a backup-file to transfer settings and chat-protocols. But in general I’m in the lucky situation that I want to transfer data prom an old phone to FP3, so I’m sure no data is lost…

Edit: at least for single app backup it works, so the filelist is really important.

Well if you are using exchange you can’t have privacy, that’s a microsoft project.

1 Like

It is exchange like, but it runs on Linux. It is called kopano.

Just installed and that was really quick, the process is really safe so the risk to brick your device is really near 0 but the 0 risk doesn’t exist so I invite you to don’t be afraid by the flash.

Just one thing: If you’re experiencing some issue to connect on wifi, then do not forget to turn off the DNS server of your ISP and keep the one provided by default , Quad9.

My first impressions are really good, their launcher is far from what could appreciate the Android universe but I agree with their bet to focus on efficiency and professional looking.

I need some extra time to do my confirmed conclusions on the OS, but if my good impressions are confirmed then I hope they will pursue their closed partnership with FP and why not proposed their OS as start of day 1 for FP4 ?

Can anyone explain to me the warning shown on the /e/ installation page?

Warning : Do not attempt to downgrade your smartphone in case you are on Android Q / LOS 17.0 or Android Pie / LOS 16.x.

Downgrading a device from Q or Pie to Oreo or Nougat operating system can cause your device to brick and become unusable.

FP3 ships with Android Pie, but how is the downgrade to Oreo or Nougat relevant if we’re installing /e/ ?


Just a little update /e/ is working very fine so far. The message LEDs are also working.

What I have not tried yet:

GPS (route planning),
Blutoothconnect to my car-audio


I use it too, and I like it a lot. Real google free :slight_smile: (I was also on the alpha test).

It’s my opinion to notice after increased battery consumption, but I’m sure that will be patched out.

mcdaniels: GPS works for me.

1 Like

I had a somewhat obscure battery drain from the start, it was looking better after a factory reset.
Today Android’s optimisation seems to kick in, it’s really looking good today.

1 Like

That’s my third day with /e/ on board and I’m still impressed by the quality of the ROM: Really, if you could find any inconveniences to the default OS, move on /e/ before do any decisions to go back on another device.

The phone became really another one, only for the improved fingerprint reader that deserves some efforts!

Style no improvements when trying to use multi-touch with the phone sits on soft surface, so that confirms this problem is related to phone design

1 Like

This message has been taken from other branches of /e/, which are based on Nougat.
The fp3 branch of /e/ is based on LOS16, which is Pie, so this message is not relevant here.
I’ve seen a discussion about this on /e/ forum. They are aware of it and will fix it.