Driver for MT65XX not found by Windows 8.1

  • When I connect my FP1 (1st edition - Kola nut 1.8.7 - Android 4.2.2) to my “Windows 8.1 Pro N” with a (verified) USB cable under MTP protocol, the FP1 is reacting by showing a notification proposing a direct access to USB connection type management >> FP1 works fine.
  • On my Windows 8.1 Pro N, I hear a sound informing me that a USB device has been connected.
    And in the device manager, I find a new entry “other device” for a “MT65xx device”, with a warning sign because it is missing the related driver (never found so far, neither manually nor automatically).
    So, no popup related to the new device connected and, when opening Explorer, the FP1 is not visible at all.

Any suggestion?
Thanks in advance - Have a nice day.

1 Like

This could help:

The links in that post are in German (the German speaking community has done some great job in that regard), but you’ll find English tutorials too, I guess.

You basically need to download the standard Android for Windows driver and add the lines from the post above (the lines about HTC…).

PS: I moved your post and renamed it to make it easier to find.

1 Like

Thanks for your (quick) reply.

I did try the proposed solution, but did not succeed: the driver installation fails at the end of the process. Having an error code 10, I suspect the driver is for an older Windows version format not supported anymore by Win 8.1 Pro N.

I can’t believe I am the only one with a FP1 trying to connect to Win8 thru MTP.
So, if someone has a tip… thanks in advance.

Hey, I found this:

It’s by Fairphone’s software guy @keesj, so you should be on the safe side. You should also read the posts below the above one.

1 Like

With your tip, I did succeed to install the driver (after special F7 reboots).
But the driver is not accepted by the system, as marked by the yallow triangle.
And when I connect my Fairphone in either MTP or PTP,

  • it does still appear as ‘MT65xx Android Phone’ in the ‘Device Manager’ (see picture)
  • it does still miss in a Windows Explorer (i.e. not visible at all)
    To be continued…

Maybe enabling “USB-Debugging” in Settings > Developer options changes anything?

Thanks for the tip, but unfortunatelly I already did try with and without this setting and had the same result: Fairphone not visible.
I will try this week-end on a friend’s laptop to clarify (i hope…) the source of the issue (i.e. either the smartphone or the laptop).

1 Like

I did succeed in testing the Fairphone on another laptop: it was visible as MTP.
So, it is not the smartphone that is the issue, but the Windows 8.1 Pro itself.
I have now to investigate what and how to fix there - any hint is welcome.


Same issue (I can’t connect the phone to trandfer files, the phone doesn’t appear on the computer screen, and I have a “MT65xx Android phone” in the list of devices with an error icon) but I use a W7 64 bit pro computer.
I could plug and use the phone normally before (I last did it a few weeks ago) and never seemed to need any driver. I don’t know what has changed. I did apply for a free W10 but it is still unavailable for my computer so I’m still in W7.

@Scarlett: Actually this topic is specifically about Windows 8.1. I think there are other topics, who deal with Windows 7. Have you searched around a bit on the forum and tried some proposed solutions (if yes, what did you try?)

@ all: A while back I wrote tutorials about transferring files wirelessly. Look here:

Yeah well this topic is describing wery accurately my issue while others are not (yes I checked first, and no I didn’t try the proposed solutions as they do not suit my problem).
If I am having the same issue on W7 I assume that is interesting information as it may indicate the issue is common to both versions of windows.

I know I can transfer files wirelessly, via google drive or others. But I used to be able to do it with the cable and I can’t anymore, so I know there is a problem and I want to fix it.

I moved from W7 to W10, the problem still occurrs.