English

Does Lineage OS work with hardware keyboards?

Hi,
does anybody have experiences with using a hardware keyboard at a FP2 with Lineage OS?
I just tried it (with a Samsung phone because my FP2 doesn’t work at all). My experiences with a “1by one” BT keyboard:
The ‘QWERTZ’ keyboard works at my desktop computer without any problem. The keyboard itself can be adjusted to ‘Android’ or ‘Windows’, but I couldn’t find any differences with changing this adjustment.
At the Samsung phone with LOS version 14.1.2 the keyboard works as if it is a ‘QWERTY’ one, that means, that the characters ‘Y’ and ‘Z’ are interchanged and all the special characters are at wrong places. So it is impossible to work with this keyboard at the LOS phone.
I tried it with other BT keyboards, but it is the same!

What are your experiences with LOS, FP OS and FP OOS?

Normal USB keyboards (also wireless ones) work via USB OTG adapters without a problem in Fairphone Open OS and LineageOS.

So hardware keyboard support is built in in Android in general, I just don’t have a Bluetooth keyboard to test, so I can’t check that, sorry.

1 Like

Thank you @AnotherElk for your quick response!
I also tested it with an USB ‘QWERTZ’ keyboard over USB OTG at the LOS phone and have had the same issues as with the BT keyboard!

Just checked with my Logitech wireless USB keyboard again …

When I connect it via USB OTG in LineageOS, I get a notification leading to the settings for the physical keyboard (Settings - Languages and input - Physical keyboard), and there it showed German as the language for the Android AOSP keyboard, but you’re right, by default it used the QWERTY layout nonetheless.

But the notification was still there, and so I just explicitly set the setting to German (again), and now the notification is gone, and the layout is QWERTZ.

So, if you get this notification, too, then go to the settings as it suggests, and really set the language, even if it seems already set correctly.

2 Likes

Thanks again! It may help to find out, why it doesn’t work at my phone.
I didn’t get a notification like you, and looking at the phones settings I can’t find settings for a physical keyboard. There is only (in German) ‘Aktuelle Tastatur’ and ‘Bildschirmtastatur’. Under ‘actual keyboard’ it is set to ‘Deutsch AnySoftKeyboard’.
It may be, that the Samsung Lineage is different from the FP LOS? In this case I have to search at other places than the FP forum.

In a German LineageOS it is Einstellungen - Sprachen & Eingabe - Aktuelle Tastatur … default setting on the Fairphone 2 in this case seems to be “Deutsch - Android-Tastatur (AOSP)”.

Seems strange for a LineageOS out of the box, this sounds more like an alternative keyboard App installed afterwards (here it is on Google Play), but who knows (I don’t).

Could you change the keyboard setting to AOSP or is AnySoftKeyboard the only option there?
Perhaps AnySoftKeyboard is in the App list and gives you extra settings and you can set the layout there? This here suggests you could “select the desired layout from AnySoftKeyboard’s Settings->Keyboards menu”.

I had tested an USB OTG keyboard once and didn’t notice anything special. But to be honest, I didn’t pay attention to the fact if it was QWERTZ or QWERTY.

Hopefully I remember to try this evening and let you know :wink:

Now I have deactivated all other keyboards except AOSP and I get the settings you mentioned. But the characters, written by the BT keybord are wrong as before!

Have you set the language to German again (even if it is set already)?
Else set the keyboard back to AnySoftKeyboard and try the settings of AnySoftKeyboard …

Yippee!!!

I have got it now! But I really don’t what was wrong with my last configuration.
I went out from the settings and back again, and the setting was wrong. So I put it in again und now it works!

What I have learned about hardware keyboards and Android:

  1. The keyboard has to be connected to the device, otherwise you can’t set up the hardware keyboard setting, because there is no physical keyboard at the phone setting without!
  2. The Android keyboard app (ASOP) at settings\apps\ has to be activ. If you deactivate this app, you can’t set a language for the physical keyboard at ‘Languages & input’.

And thanks a lot for your help @AnotherElk! I would not have got it without your assistance and endurance!!!

4 Likes

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.