Divest OS: Everything about Divest OS on the Fairphones

Did you lock the bootloader after installing?

Edit: it seems you did! I don’t think I’m gonna risk it though

Yes my bootloader is locked.
After 6 weeks and three OTA updates it works well. There is a focus on privacy and security. Apparently FP firmware is now included. Only messanging application Signal drains so much battery without google services that it is arguably unusable. I have nothing else to declare apart from an efficient and available support on XMPP

1 Like

Experimental A13 based builds are now available for FP4: News - DivestOS Mobile

Reported working so far, albeit with some hiccups of two random reboots noted.
I don’t have a Fairphone myself to personally test with.


Calyx has released their device flasher now. I’m just wondering if there’s any way of making the device flasher flash Divest OS instead? Has anyone tried it?

Can it lock the bootloader safely if you use Divest OS?

I have updated my DivestOS FP4 to A13 last week and it works as before without any random reboot so far.


I have the same message on the FP3 I use, an also on my old Pixel2 XL. Can this message be ignored? Or is there a way to remove this message?

I don’t think there is:

1 Like

From what I read this message is normal whenever one use a custom rom on a phone that has some degree of respect for android security model with a locked bootloader probably to alert the user of a malicious attack if he was not at the origin of the OS change on a new phone; the only interest that I can see to remove it would be to achieve a quicker boot and there is probably no way to do it at the end user level


Does more people have problems with the GPS signal in Orgnic Mops? FP3 and Pixel 2 XL both have no GPS signal, or after using gpstest from fdroid there is some signal after A while, but the next time the same problem. Both phones on the latest update.

DivestOS has no network location provider, only GPS, and you have to wait for GPS to lock.

I’ve tested GPS working without issue on taimen.

Oké … I maybe it need some startup time. Btw … l like diverst OS very much! Thank you for the lot of work you put in it :clap::clap::clap:

Other question … is there a smart charge option in divestos? So charging stops at 80%… I cannot find it.


While Organic Maps doesn’t initially show the green dot, it will eventually lock after GPS is acquired.
Not sure why it is different in that regard compared to OsmAnd or others.
But they do work eventually.

A cold GPS lock can take up to 12.5 minutes, but will be quicker if you have accurate time and Internet to download the almanac.

smart charge option in divestos

There is not. And the patch commonly used in other systems actually has a fatal flaw that can cause the device to never charge again, hence why I will not add it.

On my FP4 it usually takes 1-5 minutes to acquire a GPS signal after toggling on location and then it is accurate and reliable enough to navigate a motor vehicle in dense traffic

As I understand it on the FP4 there is an anti-rollback feature that bricks the device if a system image with a lower version is installed.

I would like to try DivestOS but since I have a banking app I might have to lock in the bootloader (which I’d rather do regardless). If I install DivestOS and realize I must lock in but can’t, can I still revert to the stock OS and lock that? I only have this one (really new) phone and rather not do any experimentation with it that might result in it getting bricked. If I were to lock it and change my mind a couple weeks/months down the road can I still revert?

I would love to try DivestOS since android is my last tether to google and this way I could be completely free.

You can always* unlock the bootloader and flash back to stock from DivestOS.

***Take special care for FP4: Broken - DivestOS Mobile

Do NOT attempt to lock the bootloader if fastboot flashing get_unlock_ability returns zero or else it will brick.


Alright, awesome I followed the instructions, fastboot flashing get_unlock_ability returned 1 so I issued fastboot flashing lock and was able to reboot into DivestOS :partying_face:

I still get the yellow screen warning about a custom OS when booting, which I thought would no longer appear with a locked device. Is this to be expected or did I do something wrong potentially endangering my phone? I did not sideload copy-partititons-FP4.zip since it is striked out on the website.


There’s no way of getting rid of that message, unfortunately. There’s a small discussion about it if you scroll up a bit

1 Like

Ah I see, I completely misunderstood that discussion then. As long as it doesn’t indicate a deeper issue I don’t really care about it.

Thank you all so much.

1 Like

An experimental DivestOS 20.0 build is up for FP3. edit: tested not working well

Have fun!

edit: removed wiki bit