Display lock not working

Yesterday I wanted to try somethig with the display lock. My lock is “wipe” and I did set this to “pattern” with “on/off locks device” and pressed the power-button. Waited 10 secs, pressed power, wiped from bottom to top and homescreen was there without the need to paint the pattern.

The same with password, PIN and/or time to lock set to zero, waiting until the automatic lock set in. No success.

Only after rebooting I had once to give the pattern/password/PIN once.

Is this normal?


I can’t reproduce this on Open OS. I have to paint the pattern every time “power button instantly locks” or “automatically lock xx sec after sleep”.
I’m guessing an app bypasses the pattern unlock (device manager?, root?).

1 Like

The only apps of question are Gravity Box and XPrivacy. In XPrivacy I could not find anything concerning the problem and Gravity Box I tried some changes “background” and “smart start” without change. Hmmm, no clue where and what …

Update: I tested my phone in failsave-mode: the behaviour was the same. So IMHO no app involved.

Update 2: failsave deletes all accounts. Upps …

Did you maybe enable “Smart Lock” in Settings/Security? With this function you can choose for example “safe” places (home, work…) or bluetooth devices (car audio, finess tracker). When your phone is in such a “safe” zone, it doesn’t need to be unlocked.

1 Like

Tried that already to no avail. Thanks for the hint.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.