Display is not reacting after FP Update

Hi there,
a few minutes ago I installed the latest update for my FP2.
After I had restarted it I first got an error similar to this. (That had already occurred after the last update.) I pressed the lock button to reboot the phone. The error screen did not show up anymore and my FP was starting. Then the unlock sim screen appeared and I tried to unlock it. BUT: the display is not reacting anymore! I tried to reboot, but actually I can press the unlock button for as long as I want and nothing happens…
I already tried to remove the battery and then turned on my phone again. But still: My display is not reacting anymore.

Has anyone of you advice or the same problem?

Note: I did not drop my phone.


Babsini :slight_smile:

I also had an unresponsive SIM-unlock screen. But disassembling the screen and cleaning the connectors seems to have solved the problem. Did you try it already?
Good luck!

1 Like

After the battery had been totally empty, I recharged my phone. Seems linke the problem solved itself :slight_smile:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.