Discussion about the Open OS Fastboot Installation Guide

ADB and Fastboot are not missing on my system. But your resource was helpful to proof that. The expectet files can be founf in finder. But adb devices does not lead to the expectet output (fastboot devices did). Can anybody understand this?

schuseba-wlan2:~ sebastianschumann$ fastboot devices
fdbdb62a fastboot
schuseba-wlan2:~ sebastianschumann$ adb devices
List of devices attached

@Realcyke

Is there an error in PATH for ADB perhaps, does anything in this resource help you?
https://stackoverflow.com/questions/17901692/set-up-adb-on-mac-os-x

1 Like

fastboot devices works when your phone is booted into fastboot mode (aka bootloader).

adb devices works when your phone is booted into something supplying USB debugging, most prominently Android, or perhaps the TWRP recovery.

Short: fastboot and adb don’t work at the same time.

1 Like

Again this was helpful resource. I installed homebrew which made the phone appear in the list after typing adb devices. Unfortunately this seems to be only one step forward. I get the same error message when I launch flash-for-mac.command. The phone is still not recognized for this operation. :disappointed:

I tried the different operating modi and can proof this information. Thanks for this insight. Now I know that adb and fastboot work properly for me. The Error has to come from another direction.

I used a windows 7 machine which did the job without any issues.
And, by the way, I like Fairphone Open a lot.

1 Like

The error comes from the fact that the manual switcher is using the fastboot in /bin-darwin. If you try to replace that fastboot with the one from https://issuetracker.google.com/issues/64292422 (which works in High Sierra), you get a checksum error.

Was only able to workaround this using another Mac that had El Capitan.

Thank you! I have been trying all day to do this and your instructions were very clear. Am very happy to have Open OS again :smiley:

1 Like

Hi,
to install FP OPEN from a new FP2 with FP OS: I downloaded the file “fp2-sibon-18.04.1-manual.zip”, unzipped it and modified the “flash-for-unix.sh” due some issue with checksum:

ERROR: Checksums do not match.

I commented (#) the whole paragraph about SHA256SUM check.

Flashing successful!
Your Fairphone 2 will now run **Fairphone Open 18.04.1**.

Press Enter to reboot the device and complete the installation...
rebooting...

… so, the lines the script was giving before that error message would have been interesting.

I would assume checksums are there for a reason.
Commenting out a checksum check might be advisable with trouble unrelated to the process the checksum is there to check, but else I would be wary about the results :wink: .

yes, right but it’s can be launch from a terminal separately and it’s not necessary for complete the installation.

However my phone hadn’t finish the installation after reboot… So i followed this post (downloading the “fp2-sibon-18.04.1-ota-userdebug.zip”) and now I have FP OPEN on my FP2.

Glad you got it to work :+1:

I was trying to say that even if the script said that the checksums don’t match at this point, the error could have been something else entirely, as the script will abort there for other errors, too, but the message will be “Checksums do not match” anyway, because the script was just written that way, it doesn’t distinguish and catch other errors there.
You can see an example of this in the topic I linked to. The script said the checksums don’t match there, but the real error was that a file system path couldn’t be found in the process of checking. That was visible from the terminal output before the script gave the checksum message.

I just didn’t want to let it stand uncommented that the solution to a checksum check complaining is to disable the checksum check.
Get to the cause of the error (and fix it if possible). If the cause of the error is something else and perhaps unfixable momentarily and the checksum is alright otherwise, a checksum check might be discarded, but not only because it’s a nuisance :wink: .

1 Like

Well I’m feeling a bit thick now. I’ve spent all day trying to install fastboot on my iMac and I’ve got nowhere.

Following which guide?
Did you use this one? … #dic:fastboot

Hello everyone,

Thank you very much for this tutorial! I managed to follow all the steps with ubuntu (although the script needed to be made executable, for this I had to ask for help).

Anyway, since yesterday evening my phone is rebooting, I waited one whole night. I tried to turn it off and on this morning several times, still nothing. Then I tried removing the SIM card and it came to the screen “preparing settings” (or something similar) but remained on that screen. Since then I have tried turning it off and on again but it stays at the main Fairphone screen “change is in your hands”, maybe I should leave it like that a few hours and see what happens?

Do you have any suggestions? I was really looking forward to FP Open… Hope it will work.

Thank you very much!

Which package did you download/install? There is a manual update package and a manual switcher package - the latter is the package you need. It contains a few more partition images than the former one.

Thank you for your answer!

I’m not sure but I think I used “fp2-sibon-18.04.1-manual.zip” so apparently the wrong one… I hope that is the problem. It means I used one which is actually made for updating a device already running FP Open?

I will try again as soon as I’m home (I’m currently traveling). Thanks!

Exactly, this image is meant for upgrading only. I wish you best luck!

So, I tried installing Fairphone Open yesterday evening using the correct image and it worked perfectly! :smile:
Thank you!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.