Discussion about the Open OS Fastboot Installation Guide

So I re confirm (just tried it) that the FP2 shall be in Fastboot mode and the right command is “sudo fastboot devices” with the “s” at the end of “devices”, this way fastboot gives the FP2 reference.
(“Fastboot device” (or devices) command only gives a message and get stuck.)

So I’ve launched the installation from Ubuntu 16.04 with no root privilege.

1 Like

Just a remark concerning installing FP Open OS: you will need the installation by fastboot if you have a newer FP2, as apparently the build of the directly downloadable OTA package is older and cannot be installed over a newer build (Method 1). While with fastboot (Method 2) all went fine.



This should be changed in the installation guide on code.fairphone.com. Who is responsible for that page? @Douwe?


Hey there,

yesterday I tried to go back to normal without encryption but I got a bootloop. So I tried to flash a clean Fairphone Open-Image via Minimal ADB and Fastboot on Windows.

Somehow I got confused by the crossed lines above. My Fairphone is detected via fastboot but I could’t figure out which command to use for flashing and if there is any need to unzip the image. The official instruction didn’t help out, I don’t know where to but the (./flash.sh).

I would be very happy about any straight advices without too much of programming knowledge!

Thank you very much!



1 Like


  1. You have to unzip the file to install the release. As I don’t know the Windows command prompt at all (I’m a Linux user), just unzip it graphically.

  2. Enter the folder, you will see two subfolders (AP and RADIO) and two scripts : install.sh and install.bat. The install.sh is a UNIX script and you can’t use it with Windows. You have to use the install.bat script.

  3. Then open the command prompt, go to the directory in which the script is, and tap install.bat. It should work (I took my source from there)

I hope my answer will help ! Just in case : the Stackoverflow forum is a very good source, as it is a geeks and coders forum :slight_smile:

1 Like

Hey @anon59030904 ,

thank you so much for your great instruction. Fastboot did what it was meant to do. So thank you very much!

But there still is an issue: I got the feedback that flashing was successfull (see screenshots), but when rebooting it still asked for my decryption PIN and the boot loop was still there, too. Does anyone know why? Is there any recommended instruction how to get away from encryption when the GUI is not available anymore?

Again, I would be very grateful for any ideas how to deal with this…!



EDIT: I found another topic with the same issue: Endless Optimisation Restart Loop after OOS 17.01 update (encrypted + OpenGAPPS)

Looks like the clean install isn’t touching the userdata partition. If you want to remove encryption, you’ll need to wipe/format it.
As for the boot loop: If you previously had openGAPPs installed, starting the phone will still get you in a boot loop because a rebuild of the user-installed apps is performed at boot and for some apps this means that openGAPPs is required. If it isn’t there, the rebuild fails, the phone is restarted and a new attempt (that of course will also fail) is started. As openGAPPs is installed to the system partition (which isn’t ever encrypted), you can fix the boot loop in two ways:

  • install openGAPPs from recovery.
  • wipe all the user data (make sure you have proper backups if you need any of your data, as this is basically a factory reset). If you just want to remove your data fastboot -w should do that. Alternatively, fastboot format userdata should remove the data and remove the encryption, though I’ve never actually tested this.
1 Like

I just wiped and reinstalled my FP for the second time using Windows10. The installation guide at the top didn’t work for me. Here’s what I did:

  1. Then I installed the Android Studio mentioned in “How to get the Fastboot software on your computer
  2. Downloaded the latest manual_userdebug.zip from code.fairphone.com
  3. Moved the .zip file to the folder C:\Users<username>\AppData\Local\Android\sdk\platform-tools (where the fastboot.exe is) and unzipped it there. I moved all the files (flash.bat, flash.sh, and 2 folders) into the platform-tools folder.
  4. I wanted a clean slate, so in TWRP I wiped everything except the SD card (careful: backup everything first, save all your pictures etc.).
  5. Reboot the FP2 in fastboot-mode (Vol. Down + Power-Button) and connect via USB-cable.
  6. Go to platform-tools folder, start a command window there and write
  7. When finished, unplug the phone and reboot. Done.
  8. Then do all the “work”: reinstall F-Droid, Titanium Backup, Restor all Apps. Change Platform.xml, root.

@friek I just changed the instructions for Mac (which I use) maybe you can add your comments also to the wiki?


Thanks for the installation guide!
For me, it didn’t quite work as smoothly: I am good now, but needed to run the flash.sh script with root rights (sudo ./flash.sh) as fastboot wouldn’t recognize the device if run with user rights.

Maybe it should work with user rights and my installation of fastboot is misconfigured, I don’t know.
Anyway, it might be worth adding a note to the first post here (and to the official installation guide on code.fairphone.com) about it to save other users the hassle of unsuccessfully re-trying several times like I did.

Thanks. :slight_smile:

Hmmm, interesting, I always had to put the command ‘sudo sh flash.sh’ on my LunixMint, the command ‘sudo ./flash.sh’ would not run. Is this an ubuntu speciality?

Well, in fact, I had to make the script executable first (chmod +x flash.sh).
(Since the first line of the script, which is “#!/bin/sh”, tells the shell to execute it using sh then, ./flash.sh is actually equivalent to running “sh flash.sh”.)

1 Like

done. Thanks for the tip. :bouquet: :bouquet: :bouquet:

1 Like

Arrrgh - I can’t get this to work!!
I’m trying fastboot using a mac (because normal booting with OTA didn’t work) and a new FP2.

I get this message after following all steps above:
“Checksums do not match. Not flashing.”

What to do?

uncheck the box to check the signature before flashing :slight_smile:

1 Like

Hi there!
Will there be a fastboot file for FPOOS 17.06.4?

Looks like a good alternative.
I think I will wait maybe 2 weeks or so and if until then there ist no fastboot file I will go that way.

1 Like

I’m using Ubuntu and used the following tutorial to have adb and fastboot up and running in my Ubuntu box. Maybe you want to link it in the wiki or post it as further related info:

@rootboi: If you wish to update your guide, the version of FP OOS has changed (and with it the link) and also the flash files are now called flash-for-mac.command, flash-for-unix.sh and flash-for-windows.bat. Thanks for writing it!