Did my screen die or did the core module die?

Hi,

4-year old FP3, 2x replaced bottom module, 1x replaced battery.

Today the following happened:

  • while streaming a video in fullscreen, the screen froze, with roughly the top 40% of the image becoming scrambled
  • The only action available was turning off the phone by long-pressing the power button
  • Since then I haven’t been able to get the phone to start. Screen and LED stay black. When plugged in, the phone does not draw any power.
  • Tried disassembling and cleaning everything, to no avail.

Now I have 2 questions:

  1. I assume it is the mainboard and not the screen module that died. Is the above information enough to definitively confirm this?
  2. Luckily the important data on the phone (mainly photographs) is backed up. But re-activitating all services with 2-Factor Authorization will be a big hassle without a working current phone. Is there any way to bring it back to life (if only temporary to at least take care of all “logged in” services) ? Otherwise, any tipps with regard to 2FA would be helpful.

I would be extremely grateful for any help with the above questions.

Sincerely,
Mark

It sounds like a core module defect, however maybe there is an angel close that can change the display module to be sure.

Infos about the Fairphone Angels here fairphoneangels

4 Likes

Awesome, I didn’t know about the angels program. There’s 3 near me, I’ll look into it if all else fails.

Thanks!

2 Likes

Additional information: When the freeze / potential sudden death happened, my earbuds disconnected immediately. Furthermore, the phone does not appear as a USB device when plugged in to a laptop or PC.

Am I correct in assuming this all points to the core module (i.e. the mainboard) breaking and not solely the display module?

Thanks for any comments!

Hi! I had exactly the same issue today, earbuds disconnecting and now nothing turns on (even if plugged in a computer). I had another battery so tried to change that but it didn’t work. Did you manage to solve the issue by replacing a module?

I had exactly what you describe happen to my FP3+ a few months ago, and it was the core module, so I’d be leaning towards that.

I’d recommend contacting support, but at least in my case, they didn’t help at all. I wish you the best of luck though! :slight_smile: