Device not booting after disassembly for cleaning - are magnetic bits to blame?

tldr.:
Fairphone 4 5G
/e/ OS, unsure about the version
bootloader unlocked
After disassembly for cleaning, device booted into recovery mode for one time, brought up error about data being corrupted and data wipe being needed.
After that device got stuck in bootloop.
Recovery mode still accesible via PWR & Vol-

Things done:
Taken apart several times and checked connections.
Data wiped.
Left taken apart to dry.

Current main suspect: magnetic bits
Plausible?
Also: what to do now?
/tldr

Hi i am new to the Forum :wave:,

i took apart my FP4 5G to clean it. I was pretty happy to be able to get the gunk out of my hardware, but after careful reassembly the device entered recovery mode and told me my files were corrupt and i needed to wipe them :frowning:
Now i need help on A) figuring out what went wrong and B) on what to do now.

So here is what happened:
I am stumped what happened since i thought i was pretty careful. I worked in a room with little dust, layed out clean papertowels, used the correct size of bits, touched grounded metal to get rid of static charge, didn’t apply pressure and everything went smooth.

After that the phone would get stuck in a bootloop. Luckily i have the bootloader unlocked, so i can enter recovery mode via “Power-button” and “volume down”.
I took it apart again and checked the connections and took extra care to tighten everything snugly. Put it together again, but same problem.

A) What went wrong?

  1. As of writing this i noticed that the bits i used are magnetic. I thought those were non-magentic ones but i was wrong. -.- Could that be the cause of the trouble?

Other things that could be to blame:
2. When the thing was taken apart, I blew with my mouth into the frame holes for the USB port and the microphone to get the dirt out. Could it be that moisture got in through my breath? I can’t really imagine this being a problem since i didn’t spit or anything. Also i waited for several minutes before reassembly, so condensed water would have evaporated by then. But in any case i took it apart, to let it dry.
3. I used a toothbrush for cleaning out the edges (didn’t use pressure so no mechanic problem), but could static charge be the problem?

B) What to do now:
Now i did wipe my data -as the error message said-, but the phone still doesn’t start.
I googled stuff and found this forum, worked through the troubleshooting guide and searched stuff here.
I found a lot of posts on moisture, so i took it apart to let it “dry” but that was more because i was out of ideas at that point (see above).

My next steps would be to see how i can reset my OS or flash a new one or something. Is that correct or do i miss something here?

So i reassembled it.
e/ Version is 1.13, if that is of any importance…

BTW.: It is kinda cool that you can just take your phone apart like that. 5/7 would bungle again!

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.