English

đŸ‡©đŸ‡Ș Neues FP2 - "Keine Verbindung zur Kamera möglich"

camera
đŸ‡©đŸ‡Ș
Tags: #<Tag:0x00007f0008a225d8> #<Tag:0x00007f0008a22498>

#62

danke fĂŒr den tipp - ich habs gleiche problem und heut mal die kontakte “hochgehoben”. bin gespannt, ob die kamera jetzt zuverlĂ€ssig funktioniert :wink:


#63

Habe seit kurzem auch das Problem dass bei versuchter Nutzung der Kamera nur lila Fragmente zu sehen sind und zwar unabhĂ€ngig davon ob ich die Kamera direkt anwĂ€hle oder ĂŒber eine App.

Hab aber auch gelesen dass das Problem generell bei AndroidgerÀten, egal ob Smartphone oder Tablet hÀufiger vorkommt.

Erstmal hat mir jetzt der Tipp mit den hochgebogenen Kontakten weitergeholfen, bin mal gespannt ob das hÀlt.

Ich finde es ja schon seltsam dass hier mal die Hardware und mal die Software das Problem zu sein scheint



#64

Ich hatte das Problem mit der Kamera auch. Inzwischen ist mein Fairphone 2 aber komplett tot. Ist da auch schon jemandem passiert?


#65

Bei mir mir tritt das Problem (Fragmente / keine Verbindung) eigentlich nur bei schwachem Licht auf. Allerdings machen andere Handys da noch prima Fotos :frowning:


#66

Probe, ob Hardware- oder Software-Problem:
Tritt das Problem auch mit Open Camera (Play Store / F-Droid ) auf?


#67

Ja - genauso wie mit Standard-Kamera-App oder Scanner-Apps.

Bei mir wurde das neue Camera-Modul schon mitgeliefert. Anfangs war auch alles OK, bis es dann immer hÀufiger KamerahÀnger gab. Nach dem Upgrade von Android 6 auf 7 treten die HÀnger immer noch auf, dauern aber nicht mehr so lange (evtl. resetted Android 7 die Kamera schneller).

Den Tipp mit der Reingung der Verbindungskontakte probiere ich gelegentlich mal aus und berichte dann.


#68

Das klingt nach einem Fall fĂŒr #contactsupport .


#69

Auch nach Reinigung der Kontakte tritt das Problem weiterhin auf :frowning:

Bei Tageslicht oder in sehr gut ausgeleuchteten InnenrÀumen habe ich keine Schwierigkeiten; aber bereits bei normal beleuchteten InnenrÀumen gibt es HÀnger.


#70

Habe das Kamera-Modul aus- und wieder eingebaut.

Die ersten Tests waren erfolgreich - jetzt klappen auch wieder Fotos in dunklen Ecken :slight_smile:

Evtl. lag es also nicht an den Kontakten zwischen Screen- und CoreModul, sondern an denen zwischen Kamera- und CoreModul.

Jedenfalls Kompliment an die Ingenieure von Fairphone - das GerÀt ist wirklich servicefreundlich aufgebaut und einfach zu zerlegen.


Camera Error: Can’t connect to the camera
#71

Ich musste mich ebenfalls mit diesem Problem beschĂ€ftigen und denke, dass ich ihm einigermaßen nahe kommen konnte.
Es dĂŒrfte wohl an den Kontakten zwischen Kameramodul und Display liegen, genauer gesagt an einem von den drei, nĂ€mlich nicht an den beiden, die Lukas zuvor gekennzeichnet hat, sondern an dem dritten, der wahrscheinlich dem Potentialausgleich dient. Es ist der im Bild unten, unterhalb der Beschriftung des Moduls, links neben der Schraube:

Die Kontaktzunge ist leider nicht optimal gefertigt, bei der Stanzung des Blechteils sind da ausgeprÀgte Grate entstanden. Ich habe kein Bild des Originalzustandes. Den ersten (wie ich meine erfolgreichen) Reparaturversuch hatte ich da schon unternommen. Am Kontakt selbst sind die Grate bereits entfernt, links am Rand der Zunge und auch an deren Spitze kann man sie aber noch ganz deutlich erkennen:

Zum Vergleich eine andere, sauber ausgefĂŒhrte Zunge. Es ist die, die man im ersten Bild ganz am unteren Rand noch zum Teil sieht:

Was die Grate anrichten, sieht man hier, das ist die GegenflĂ€che auf der RĂŒckseite des Displays. Durch die wenigen Male, die ich es aus- und wieder eingebaut habe, sind tiefe Kratzer entstanden. Außerdem hat durch die geringen Bewegungen, die innerhalb des ganzen zusammengebauten FPs entstehen, wenn man es ein paar Monate in Verwendung hat, die Kontaktzunge bereits deutliche Dellen eingearbeitet:

Man kann davon ausgehen, dass an solchen FlĂ€chen vielleicht nicht immer der erwĂŒnschte niedrige Übergangswiderstand zustande kommt!

Die anderen KontaktflĂ€chen des Displays, denen sauber gefertigte Zungen aufliegen, erscheinen im Vergleich dazu beinahe unberĂŒhrt.

Ich habe dann noch einmal nachgearbeitet, unter der Uhrmacherlupe, mit einem feinstkörnigen Diamant-Gummipolierer aus dem zahntechnischen Bereich:

Damit funktioniert die Kamera derzeit einwandfrei.

Zuvor gab es beim Start der App (Open Camera) immer wieder die bekannten Fehlermeldungen, oder zwischendurch buntlila Streifenmuster im Display. Das kam spontan, man konnte es aber provozieren, indem man das ganze FP im Bereich der Kamera zusammen gedrĂŒckt hat.

Jetzt kann man es kneten, soviel man will, die Störungen treten nicht mehr auf.

Es ist wohl nicht ganz einfach, diesen Kontakt mit simplen Hausmitteln in einwandfreien Zustand zu bekommen. Ich hoffe, das Team leitet diese Information weiter, damit sie gleich in der Produktion entsprechend ungesetzt wird!

LG, Philipp


#72

Nachsatz:

Ich habe jetzt auch noch das FP meiner Frau zerlegt, vorbeugend, weil da macht die Kamera bisher (fĂŒnf Monate nach Kauf) keine Probleme.

Das Bild war dennoch identisch, Massekontakt an der Kamera gratig, die GegenflÀche im Display Modul genauso abgearbeitet wie bei meinem GerÀt.

Worauf ich jetzt noch geachtet habe:
Wenn Material an einer Stelle fehlt, muss es anderswo sein. TatsĂ€chlich lag speziell rund um diesen Kontakt einiges an feinsten SpĂ€nen herum. Außerdem konnte man Ă€hnlichen Verschleiß mit ebensolchem Abrieb auch an den anderen Masseverbindungen zwischen Core und Display feststellen. Dort zwar deutlich weniger, fast nur mit der Lupe zu sehen, aber immerhin!

Nun, dieser Abrieb hat wohl das Potential, in die eine oder andere Richtung Unheil zu stiften. Oxidiert und damit vielleicht isolierend, oder aber leitfĂ€hig besteht eine gewisse Chance, dass das Zeug, an ungĂŒnstige Stellen gerieselt, in der komplexen Elektronik Unfug anstellt.

Könnte dies eine Ursache fĂŒr die doch immer wieder auftretenden Spinnereien der Fairphones sein?

Die Kunststoffkonstruktion lÀsst einfach gewisse Bewegungen an diesen Kontakten zu, auch bei völlig normalem Gebrauch. SÀmtliche Masse Zungen zum Display Modul sind - genau betrachtet - suboptimal gefertigt, zwar bis auf die der Kamera ohne Grate, aber allesamt offensichtlich durch den Biegevorgang in der Fertigung an ihrer KontaktflÀche deutlich rau. Das kann man an den obigen Fotos ja gut erkennen.

Ihr jeweiliges GegenĂŒber ist von der einfachen Bauart, lediglich verzinnt, nicht vergoldet. Anhand der beiden FPs, die ich von innen betrachten konnte, wird deutlich, dass da recht schnell, innerhalb von wenigen Monaten vollkommen normalen, eher schonenden Einsatzes deutlicher Verschleiß auftritt. Denn an allen Massekontakten der Display Module fehlt bereits Substanz. Und wenn die dann irgendwohin 
, siehe oben!

Ich werde mich jedenfalls noch einmal mit Lupe und Feinpolierer bewaffnen und alle diese - wie ich meine kritischen - FlÀchen auf Hochglanz bringen!

LG, Philipp


#73

Hallo.
Konnte mit der App “Kamera” Version 2.0.002 ĂŒber ein Jahr lang einwandfreie Fotos machen. Dann kam plötzlich die Fehlermeldung “Kamerafehler - Keine Verbindung zur Kamera möglich”. Habe das Modul ausgebaut, gereinigt, die Dichtungsringe unter den Schrauben rausgenommen, das Modul wieder eingesetzt - immernoch derselbe Fehler.
Jetzt Open Camera installiert - die Kamera funktioniert einwandfrei. Mit der alten App “Kamera” der Verbindungsfehler. Schwierig zu erklĂ€ren, Hauptsache, ich kann wieder Bilder machen.


#74

Die Verbindung zur Kamera ist via MIPI CSI gelöst. CSI ist eine hochgeschwindigkeits Verbindung und sehr empfindlich was interferenz und Kontaktprobleme betrifft. Falls die Kontakte dreckig aussehen könnte das schon ausreichen um die probleme zu verursachen. Auch der Stecker von der Platitine zum Sensor könnte lose sein.


#75

Heho,
ich habe mit mit meinem F2 das oben beschriebene Problem ebenfalls.
Ich habe natĂŒrlich die Unterlegscheiben schon entfernt, ich habe auch vorsichtig versucht die Kontakte nach oben zu biegen, ich habe OpenCamera installiert.
Meine Feststellung: einmal danach hat sie funktioniert - dann nicht mehr.
Bei OpenCamera funktioniert die Selfie-Variante aber nicht die eigentliche Kamera.
Durch Zufall habe ich festgestellt, dass nach einer ErschĂŒtterung die Kamera lief (ich habe aus Frust das Telefon in meine Hand geschlagen)
allerdings auch nur kurz. Letzteres lĂ€sst mich vielleicht an einen Wackelkontakt denken?
Kurzum: ich habe keine Ahnung, bin nur recht ernĂŒchtert und frage mich, ob der Kauf einer neuen Kamera irgendeinen Sinn macht.


#76

Schau Dir die Bilder in Beitrag #70 hier an und lies den Text dazu. Auch wenn nicht jeder dieses Werkzeug zur VerfĂŒgung hat, mit feinem Schleifpapier (1000er Körnung oder höher) kann man sicher ganz Ă€hnliche Ergebnisse erzielen.

Mein FP2 fotografiert nach dieser Therapie seit vier Monaten einwandfrei!

LG, Philipp


#77

Dear @PhotoPhil. Would you be able to translate your post? I’ve tried running it through google translate, but there’s too much of it I’m unsure about. I would absolutely LOVE to use your fix :slight_smile:

Best Regards. Younes.


#78

I will try my best!

Obviously itÂŽs a matter of bad contact between the camera module and the
rest of the FPs electronics. But in my opinion itÂŽs not the multipin
thing between camera and core module accessible by removing the three
Phillips screws that some users tried to improve by removing the tiny
plastic washers situated between camera and core thus enhancing the
pressure on the contacts.

I think the point is the contacts between camera and display. And it is
probably one specific, not the two golden ones between the blue marked
screws in the picture “Kontakt 1” but the tiny little latch at the
bottom of the picture that at first glance seems to be more kind of a
spring than something conducting electricity.

But I am pretty convinced it is very important for potential
equalisation. I heard about the interface between camera and FP beeing
“MIPI CSI” which is known to be very sensitive to electromagnetic
interference.

Look at “Kontakt 2” this is a magnification of the latch described
above. It is coarse and it has sharp edges even though this picture
shows an already improved state after my first mild attempt to solve the
issue.

“Kontakt 4” shows the counterpart of the latch on the display modules
backside considerably scratched and excavated just by disassembling the
phone two or three times and normally using it over a period of maybe
half a year.
The pictured surface is thoroughly cleaned already, it was covered with
dirt and debris when I took the phone apart and one can imagine that
this mixture can cause a lot of electrical problems especially when
getting moist.

“Kontakt 5” shows the final state of the latch after my repairs using
rotating polishing tools out of my dental laboratory toolbox.
I suppose you can achieve a very similar result by using fine (very
fine! - grit 1000 at least) grinding paper. A loupe would certainly be
useful too!

To cut a long story short:
Remove the cover, remove the display, smooth the depicted latch and
clean its counterface.
To me this procedure resolved the issue persistently!

I wish you much success, best regards

Philipp


#79

Dude! Thank you so much for the quick and very descriptive reply. I’ll try it out. Thank you!!