English

🇩🇪 Neues FP2 - "Keine Verbindung zur Kamera möglich"

camera
🇩🇪
Tags: #<Tag:0x00007fefc8c72f08> #<Tag:0x00007fefc8c72c38>

#53

Patrick, ich glaube, es ging da – bei dem, an was Du dich erinnerst – um Kontaktprobleme Display-Core-Modul. Anders als bei den drei “kleinen” Modulen kann man da ja nicht durch Schraubenanziehen nachhelfen.


#54

Oh, ja - sorry. Hätte ich Deinen Post gefunden wäre mein Irrtum wohl nicht entstanden. Danke für die Klärung.


#55

Habe seit einigen Tagen das gleiche Problem, keine Verbindung zur Kamera möglich. Danke für die vielen Tipps, habe noch nicht geschraubt, da wohl eh kein Effekt. Wenn ich Pappe klemme geht nichts, wenn ich zusammendrücke erscheint ein Freezebild, nicht zum fotografieren zu gebrauchen. ich verstehe das “Display-Core-Module” nicht, was kann ich tun?


#56

Hallo HFischer,
habe Verschiedenes getestet: Kontakte reinigen, Unterlegscheiben entfernen, neue Kamera-App.
Alles hatte kurzfristig einen Effekt, d.h. ich wĂĽrde doch mal was ausprobieren. Jetzt funzt die Kamera oft, manchmal auch nur nach RumgedrĂĽcke am Case, manchmal auch gar nicht. Aber meistens kann ich sie benutzen.
Eine verlässlichen, stabilen Zugriff auf die Kamera habe ich jedoch seit Monaten nicht!


#57

Was sagt der Fairphone Support dazu? (#contactsupport)


#58

Am 2018-08-13 habe ich mir das Fairphone2 gekauft. Die verbaute Back-Kamera wird von “Einstellungen > Über das Telefon > Camera-Modul Info” beschrieben als “Hauptkamera 12MP - OmniVision OV12879”.

Schon wenige Tage nach dem Kauf bemerkte ich Probleme mit der Back-Kamera.
Manchmal funktionierte die Kamera problemlos,
manchmal erschienen nur feine, senkrechte, blau-lila-schwarze Streifen und nach einiger Zeit kam die Meldung “Keine Verbindung zur Kamera möglich” (oder so ähnlich).
Manchmal funktionierte die Kamera, nachdem zuerstmal fĂĽr ein paar Sekunden die blau-lila-Streifen angezeigt wurden.
Manchmal schien durch die blau-lila-Streifen hindurch auch noch ein echtes, offenbar aktuell von der Kamera aufgenommenes Bild hindurch.
Manchmal änderte sich dieses durchscheinende Bild dann noch ein-, zweimal, bevor dann endgültig die genannte Fehlermeldung erschien.
Manchmal half es, ein paar mal die Kamera-App aufzurufen, bevor ich die Kamera dann schlieĂźlich wieder problemlos benutzen konnte.
Manchmal half auch etwas Klopfen am Rand des Telefons.
Manchmal aber auch half alles nicht.

Alles deutete folglich auf ein reines Kontaktproblem hin.

Schließlich nahm ich dann das Fairphone auseinander, und reinigte die nicht ganz sauberen Kontaktflächen im Bereich der Kamera mit einem weichen, trockenen Pinsel.

Das half fĂĽr den Moment, aber nicht lange.

Den Weg über den Support scheute ich wegen der Unannehmlichkeiten und des Aufwandes, den ich für diesen Weg befürchtete (längere Zeit ohne Handy, Notwendigkeit der Neuinstallation wegen Datenschutz, etc.).

Vor ein paar Tagen fand ich Zeit, das Problem wieder in Angriff zu nehmen - dem bisherigen Anschein nach erfolgreich - und zwar mit dem oben von Lukas Gafner beschriebenen Lösungsansatz.

Siehe dazu seinen Beitrag vom 2018-10-22 15:36 Uhr und das von ihm hochgeladene Foto.

https://forum.fairphone.com/uploads/default/optimized/2X/4/4551a3b625045f987a1ac90358366863555a35ed_1_375x500.jpeg

Die beiden von ihm rot eingekreisten Kontakte und auch noch das freie Ende der sich rechts davon befindlichen, langen Kontaktzunge habe ich mit einem mit Brennspiritus befeuchteten Wattestäbchen ganz vorsichtig gesäubert (einfach ein paar mal darüberfahren - mit dem Strich, nicht gegen ihn).
Man muss wirklich sehr vorsichtig an die Sache ran gehen, denn die Kontakte sind wirklich winzig.
Zu leicht bricht man da etwas ab oder verbiegt etwas.
Auch eine Lupe ist hilfreich.
Die Kontaktflächen auf der gegenüberliegenden Platinenoberfläche habe ich ebenfalls mit dem Wattestäbchen abgerieben.
Dann habe ich mit einer sehr feinen, spitzen Pinzette die abgewinkelten Enden der Kontakte gegriffen und vorsichtig etwas stärker abgewinkelt, so dass sie nun etwas stärker als bisher auf die gegenüberliegende Kontaktfläche drücken müssten, sobald das Telefon wieder zusammengebaut ist.

Seit dieser “Reparatur” vor wenigen Tagen habe ich keine Probleme mehr mit der Back-Kamera.
Ich probiere seither wirklich alle paar Stunden, ob die Kamera noch funktioniert…
Auch war ich schon häufiger unterwegs mit dem Handy in der Tasche.
Es sollte also die ĂĽblichen ErschĂĽtterungen bereits abbekommen haben, die sich negativ auf Wackelkontakte auswirken.
Ich bin nun wirklich zuversichtlich, dass ich das Problem mit der Kamera an der richtigen Ursache packen konnte.

Herzlichen Dank an Lukas Gafner, der dazu den entscheidenden Tipp geliefert hat. :slight_smile:


Camera Error: Can’t connect to the camera
#59

Seither habe ich nie wieder Probleme mit der Kamera gehabt. Mittlerweile fast ein halbes Jahr.


#60

ich habe inzwischen vom support innerhalb zwei Tagen ein neues 12 MB Cameramodule geschickt bekommen, eingebaut, es funktioniert wieder alles. Die 2 Jahres Garanite war gerade noch gĂĽltig. Ich habe Kaufbeleg und screenshot eingeschickt.
Wenn ich wieder Probleme kriege komme ich auf die Kontaktbearbeitung von Lukas zurĂĽck, Danke!


#61

Hatte das selbe Problem, habe die Kontakte Bearbeitet, wie von Lukas beschrieben. Momentan ist alles in Ordnung, mal gucken, ob’s bleibt! Danke, Community :slight_smile:


#62

danke für den tipp - ich habs gleiche problem und heut mal die kontakte “hochgehoben”. bin gespannt, ob die kamera jetzt zuverlässig funktioniert :wink:


#63

Habe seit kurzem auch das Problem dass bei versuchter Nutzung der Kamera nur lila Fragmente zu sehen sind und zwar unabhängig davon ob ich die Kamera direkt anwähle oder über eine App.

Hab aber auch gelesen dass das Problem generell bei Androidgeräten, egal ob Smartphone oder Tablet häufiger vorkommt.

Erstmal hat mir jetzt der Tipp mit den hochgebogenen Kontakten weitergeholfen, bin mal gespannt ob das hält.

Ich finde es ja schon seltsam dass hier mal die Hardware und mal die Software das Problem zu sein scheint…


#64

Ich hatte das Problem mit der Kamera auch. Inzwischen ist mein Fairphone 2 aber komplett tot. Ist da auch schon jemandem passiert?


#65

Bei mir mir tritt das Problem (Fragmente / keine Verbindung) eigentlich nur bei schwachem Licht auf. Allerdings machen andere Handys da noch prima Fotos :frowning:


#66

Probe, ob Hardware- oder Software-Problem:
Tritt das Problem auch mit Open Camera (Play Store / F-Droid ) auf?


#67

Ja - genauso wie mit Standard-Kamera-App oder Scanner-Apps.

Bei mir wurde das neue Camera-Modul schon mitgeliefert. Anfangs war auch alles OK, bis es dann immer häufiger Kamerahänger gab. Nach dem Upgrade von Android 6 auf 7 treten die Hänger immer noch auf, dauern aber nicht mehr so lange (evtl. resetted Android 7 die Kamera schneller).

Den Tipp mit der Reingung der Verbindungskontakte probiere ich gelegentlich mal aus und berichte dann.


#68

Das klingt nach einem Fall fĂĽr #contactsupport .


#69

Auch nach Reinigung der Kontakte tritt das Problem weiterhin auf :frowning:

Bei Tageslicht oder in sehr gut ausgeleuchteten Innenräumen habe ich keine Schwierigkeiten; aber bereits bei normal beleuchteten Innenräumen gibt es Hänger.


#70

Habe das Kamera-Modul aus- und wieder eingebaut.

Die ersten Tests waren erfolgreich - jetzt klappen auch wieder Fotos in dunklen Ecken :slight_smile:

Evtl. lag es also nicht an den Kontakten zwischen Screen- und CoreModul, sondern an denen zwischen Kamera- und CoreModul.

Jedenfalls Kompliment an die Ingenieure von Fairphone - das Gerät ist wirklich servicefreundlich aufgebaut und einfach zu zerlegen.


#71

Ich musste mich ebenfalls mit diesem Problem beschäftigen und denke, dass ich ihm einigermaßen nahe kommen konnte.
Es dürfte wohl an den Kontakten zwischen Kameramodul und Display liegen, genauer gesagt an einem von den drei, nämlich nicht an den beiden, die Lukas zuvor gekennzeichnet hat, sondern an dem dritten, der wahrscheinlich dem Potentialausgleich dient. Es ist der im Bild unten, unterhalb der Beschriftung des Moduls, links neben der Schraube:

Die Kontaktzunge ist leider nicht optimal gefertigt, bei der Stanzung des Blechteils sind da ausgeprägte Grate entstanden. Ich habe kein Bild des Originalzustandes. Den ersten (wie ich meine erfolgreichen) Reparaturversuch hatte ich da schon unternommen. Am Kontakt selbst sind die Grate bereits entfernt, links am Rand der Zunge und auch an deren Spitze kann man sie aber noch ganz deutlich erkennen:

Zum Vergleich eine andere, sauber ausgefĂĽhrte Zunge. Es ist die, die man im ersten Bild ganz am unteren Rand noch zum Teil sieht:

Was die Grate anrichten, sieht man hier, das ist die Gegenfläche auf der Rückseite des Displays. Durch die wenigen Male, die ich es aus- und wieder eingebaut habe, sind tiefe Kratzer entstanden. Außerdem hat durch die geringen Bewegungen, die innerhalb des ganzen zusammengebauten FPs entstehen, wenn man es ein paar Monate in Verwendung hat, die Kontaktzunge bereits deutliche Dellen eingearbeitet:

Man kann davon ausgehen, dass an solchen Flächen vielleicht nicht immer der erwünschte niedrige Übergangswiderstand zustande kommt!

Die anderen Kontaktflächen des Displays, denen sauber gefertigte Zungen aufliegen, erscheinen im Vergleich dazu beinahe unberührt.

Ich habe dann noch einmal nachgearbeitet, unter der Uhrmacherlupe, mit einem feinstkörnigen Diamant-Gummipolierer aus dem zahntechnischen Bereich:

Damit funktioniert die Kamera derzeit einwandfrei.

Zuvor gab es beim Start der App (Open Camera) immer wieder die bekannten Fehlermeldungen, oder zwischendurch buntlila Streifenmuster im Display. Das kam spontan, man konnte es aber provozieren, indem man das ganze FP im Bereich der Kamera zusammen gedrĂĽckt hat.

Jetzt kann man es kneten, soviel man will, die Störungen treten nicht mehr auf.

Es ist wohl nicht ganz einfach, diesen Kontakt mit simplen Hausmitteln in einwandfreien Zustand zu bekommen. Ich hoffe, das Team leitet diese Information weiter, damit sie gleich in der Produktion entsprechend ungesetzt wird!

LG, Philipp


#72

Nachsatz:

Ich habe jetzt auch noch das FP meiner Frau zerlegt, vorbeugend, weil da macht die Kamera bisher (fĂĽnf Monate nach Kauf) keine Probleme.

Das Bild war dennoch identisch, Massekontakt an der Kamera gratig, die Gegenfläche im Display Modul genauso abgearbeitet wie bei meinem Gerät.

Worauf ich jetzt noch geachtet habe:
Wenn Material an einer Stelle fehlt, muss es anderswo sein. Tatsächlich lag speziell rund um diesen Kontakt einiges an feinsten Spänen herum. Außerdem konnte man ähnlichen Verschleiß mit ebensolchem Abrieb auch an den anderen Masseverbindungen zwischen Core und Display feststellen. Dort zwar deutlich weniger, fast nur mit der Lupe zu sehen, aber immerhin!

Nun, dieser Abrieb hat wohl das Potential, in die eine oder andere Richtung Unheil zu stiften. Oxidiert und damit vielleicht isolierend, oder aber leitfähig besteht eine gewisse Chance, dass das Zeug, an ungünstige Stellen gerieselt, in der komplexen Elektronik Unfug anstellt.

Könnte dies eine Ursache für die doch immer wieder auftretenden Spinnereien der Fairphones sein?

Die Kunststoffkonstruktion lässt einfach gewisse Bewegungen an diesen Kontakten zu, auch bei völlig normalem Gebrauch. Sämtliche Masse Zungen zum Display Modul sind - genau betrachtet - suboptimal gefertigt, zwar bis auf die der Kamera ohne Grate, aber allesamt offensichtlich durch den Biegevorgang in der Fertigung an ihrer Kontaktfläche deutlich rau. Das kann man an den obigen Fotos ja gut erkennen.

Ihr jeweiliges Gegenüber ist von der einfachen Bauart, lediglich verzinnt, nicht vergoldet. Anhand der beiden FPs, die ich von innen betrachten konnte, wird deutlich, dass da recht schnell, innerhalb von wenigen Monaten vollkommen normalen, eher schonenden Einsatzes deutlicher Verschleiß auftritt. Denn an allen Massekontakten der Display Module fehlt bereits Substanz. Und wenn die dann irgendwohin …, siehe oben!

Ich werde mich jedenfalls noch einmal mit Lupe und Feinpolierer bewaffnen und alle diese - wie ich meine kritischen - Flächen auf Hochglanz bringen!

LG, Philipp