🇩🇪 Internetzugang ohne wlan

In den meisten Fällen hat man kein wlan. Trotzdem möchte ich wie bei meinem alten handy eine Internetseite aufrufen, denn ich habe Internetzugant bei unitymedia bezahlt. Man muss verschiedene Daten eingeben. Das war bei “Motorola” nicht nötig.
bei “Fairphone” erscheint immer nur die Aufforderung: “Aktivieren Sie wlan”

Du brauchst die Definition für den sogenannten APN. Da steh alles drin für den mobilen Internet Zugriff. Den kann normalerweise Dein Provider automatisch per Konfigurations-SMS einstellen. (bei meinem hat es allerdings nicht funktioniert) Er kann Dir aber auch die Daten geben, und Du trägst es dann ein. Vielleicht ein bisschen unbequemer, aber es ist ja auch nur einmal

2 Likes

Könntest Du das etwas genauer beschreiben?
Ich hab ein ähnliches Problem und möchte gern die Einstellungen überprüfen. Dabei weiß ich allerdings nicht, wo.

Du musst in Einstellungen gehen, unterhalb des Punktes Datenverbrauch auf mehr, und dann Mobilfunknetze. Da ist der Punkt mit APNs. Den richtigen Wert kann Dir Dein Anbieter sagen, oder Du vergleichst mit einem Handy, von dem Du ausgehst, das stimmt

1 Like

Danke.
Das scheint bei mir alles soweit ok zu sein.

Ich kriege trotzdem nix gesendet oder empfangen.
Auch nicht über WLAN.
GRMBL.

Hmm… Beides ist natürlich komisch, und sollte auch nicht sein… Ist schließlich unterschiedlich. Ich hatte allerdings beim Umsteigen von fpos auf Open OS mit mobilen Daten auch das Problem, das zuerst nichts ging. Ich habe dann mit den Daten einen neuen APN angelegt und den aktiviert. Dann ging das zumindest.
Für wlan, schau doch mal bei Einstellungen ganz unten bei “über das Telefon” unter Status, ob Du eine IP Adresse hat, so als erster Einstieg.
Ansonsten, welches rom hast du aktiv?

Ooohps, das wird doch kein hijacking werden?

Umgestiegen bin ich schon länger, hat alles funktioniert, bis heute mittag.
Seitdem bekomme ich kein Netz, weder über eine der Karten (bei “Daten” aktiv) noch über WLAN.
Mein Rechner hängt am selben Netz, und das tut - sonst könntest Du das hier nicht lesen.
IP hab ich.

Welches ROM meinst Du?

Ich bekomme beim Versuch, mit F-Droid was runterzuladen die Nachricht:
“Herunterladen nicht erfolgreich”

“failed to connect to /127.0.0.1 (port 8118): connect : ECONNREFUSED (Connection refused)https://f-droid.org/repo/…”

Hijacking?
Mit ROM meinte ich, fpos oder Open os. Aber die Fehlermeldung ist interessant. Benutzt Du auf deinem PC privoxy oder einen anderen Proxy? Und lieferst das über dhcp aus? Oder hast Du irgendwie mit orbot experimentiert? Der will über einen Proxy gehen, jedenfalls. Beim WLAN kannst Du auf deinen ap lange drücken, und dann bei erweitert mal sehen, ob da Proxy eingetragen ist

[quote=“lklaus, post:9, topic:25233”]
Hijacking?[/quote]
thread-hijacking.
Durch mich.

Richtig: FPOOS.

Richtig2: Ich habe mit Orbot experimentiert. Seitdem tut es nicht mehr.
Dann hab ich Orbot deinstalliert, weil ich glaubte, das Problem so lösen zu können.
Falsch.^^
Wie schmeiße ich den Proxy raus?

Das WLAN zeigt an, daß es mit meinen Router verbunden ist.

Ach so… Naja, wlan ist ja auch Netz ohne Kabel…
Ich hatte auch immer wieder Probleme mit orbot, weswegen ich den auch erst mal wieder entfernt habe, neben den hohen Datenmengen bei mobilen Daten
Gretchenfrage: das hat einen reboot überlebt? Da sind auch keine Prozesse nach dem Deinstallieren hängen geblieben?
Sonst nochmal installieren, und in den Einstellungen ganz am Ende (glaube ich war das) gibt es einen Punkt “force remove transparent proxy rules”, den ausführen

Ja, leider.

Es möchte immer noch den Proxy…

Würde ich ja gern, bloß krieg ich eben nichts installiert.

Gibt es vielleicht einen manuellen override?
Proxy-rules finde ich nirgendwo…

Sonst würde wohl bloß der *.apk-download und installieren von der SD helfen.

Hmm. Stimmt. Ohne Netz ist doof
Wenn Du Dich mit iptables auskennst, dann ein Shell und prüfen, welche Regeln da für PREROUTING oder POSTROUTING drin stehen. Ansonsten apk download und auf sd Karte oder per adb installieren

So, nu steh ich wieder wie der Ochs vorm Berge:
apk auf der SD-Karte.
Aufruf mit Amaze und Wählen der Option “Installieren” - Amaze faltet sich zusammen (einzige Option: “OK”).
Dennoch: Installationsfenster von Orbot (“Abbrechen”, “Installieren”) führt bei “Installieren” zu “X App wurde nicht installiert”.
Optionsauswahl: “Fertig”.

GRMBL.

Ja, das ist nicht sehr ergiebig, als Meldung
Hast du ab auf Deinem PC? Eventuell darüber Mal adb install aufrufen?

Stellt sich überhaupt die Frage: irgendwas muss ja noch da sein, irgendwas muss die Einstellung ja machen. Hast du ein /etc/init.d? Ist was in /system/priv-apps? Gezaubert wird nicht
Und “unbekannte Quellen erlauben” hast du aktiv? (Vermutlich, der Fehler wäre dann anders).
Oder Du hier Dir das aktuelle rom und flashst system.img nochmal?

[quote=“lklaus, post:16, topic:25233”]
Hast du ein /etc/init.d?[/quote]

init.crda.sh
init.qcom.audio.sh

Scheinbar nicht.^^

[quote=“lklaus, post:16, topic:25233”]
Ist was in /system/priv-apps?[/quote]
/system/priv-app
41 Verzeichnisse 0 Dateien

[quote=“lklaus, post:16, topic:25233”]
Und “unbekannte Quellen erlauben” hast du aktiv?[/quote]
Japp.

[quote=“lklaus, post:16, topic:25233”]
Oder Du hier Dir das aktuelle rom und flashst system.img nochmal?[/quote]
Echt? So einen Aufriß hab ich angestellt?
Menno.

Da sollte ich es vielleicht in Ruhe als Tagesprojekt angehen - das backup funzt ja auch noch nicht und all die schönen Nummern…^^

[Quote]
Echt? So einen Aufriß hab ich angestellt?
Menno.

Da sollte ich es vielleicht in Ruhe als Tagesprojekt angehen - das backup funzt ja auch noch nicht und all die schönen Nummern…^^
[/Quote]
Tja, ich könnte mir vorstellen, dass nochmal das System flashen letztlich leichter ist… Wie gesagt, irgendwo hat er seine Persistenz ja abgelegt, gezaubert wird nicht. Ansonsten ein shell (app or adb) und direkt an den iptables arbeiten

Nu hat mich grade die Grippe im Griff.
Der Kopf ist voll Watte und klare Gedanken eher kurz.
In dem Zustand tue ich den Teufel, am Telefon rumzufummeln.

Vielen Dank erstmal, da muß ich einfach später dran.

@mungo: hast du das denn schon probiert?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.